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Osmose O-Calc® Pro Overview  
  

 About Osmose O-Calc® Pro  

Osmose O-Calc® Pro automates the calculation of structural loading on new and 

existing utility poles.  Major applications of this innovative software are line design, pole 

replacement, and joint use loading issues.  

In many cases, non-structural personnel at a utility must decide whether more cables 

can be added, or larger conductors can be used on existing pole lines without 

overloading the pole or structure.  O-Calc® Pro was developed to help technical and 

non-technical staff alike perform structural load analysis in a simple, straightforward 

manner.  The calculations within O-Calc® Pro are complex, but the operator interface 

is designed for simplicity of use.  In addition to technical load calculations and 

statistics, the application provides a configurable, three-dimensional visual rendering 

of each structure’s load conditions.   

O-Calc® Pro can be used to evaluate whether any structure within a line is already 

overloaded.  It can quickly assess the impact of re-conductoring for upgrading line 

performance.  The O-Calc® Pro analysis of stress along the length of a pole can be used 

to consider cost-effective alternatives to replacing overloaded poles.    

O-Calc® Pro is a valuable resource in evaluating structural load for joint use, safety, 

network reliability, and network planning purposes.   

 Osmose O-Calc® Pro Concepts  

Osmose O-Calc® Pro allows you to model a utility structure (wood, steel, concrete, 

composite, fiberglass pole, or multi-pole structure) by defining the components of the 

structure using the Inventory Window or interactively constructing the structure through 

the 3D View.  Both methods can be used simultaneously.  The model of the structure is 

created by adding equipment you manually define or by utilizing predefined components 

from within the Master or User Catalogs.  

The Osmose Master Catalog is installed with the O-Calc® Pro application. It contains 

a predefined list of common poles, structures, and equipment which are utilized in the 

field.  Master Catalogs contain a list of all available Load Cases, used to add the 

applicable pole loading safety regulations to the model.  Also included, are User 

Catalogs which offer a series of folders in which you can compile your own list of 

poles and equipment that you have created.  The User Catalog is helpful for modeling 

additional structures in the Inventory Window.  The Catalog Window within O-Calc® 

Pro provides you with the tools needed to manage and interact with all equipment 

catalogs.  
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Understanding the O-Calc® Pro Workspace  
  

O-Calc® Pro Workspace  

O-Calc® Pro provides you with a variety of options enabling you to interact 

with new data or existing data.  

  

 

  

Workspace Windows  Description  

Toolbar  Provides numerous options to interact with 

the data in O-Calc® Pro.  

Selected Load Case  Displays the Load Cases that are currently 

loaded in the Inventory Window.  

Display Layout Tabs  Enables you to switch between different 

window layouts; 3D View, Measure, Charts, 

Reports, OV Gallery.  

Menu Search  Allows you to easily find and execute menu 

items.  

Schematic Display  

  

Displays the major equipment on the 

structure and the elevation.  

Capacity Display  Summarizes the structure’s capacity as 

currently loaded.  
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Heat Map Display  Provides a color-coded two-dimensional 

representation of specific load values for the 

current structure.  

Data Entry Display  Allows you to enter or change equipment 

attributes.  

Status Bar  Displays the path information to the 

currently loaded PPLX file, the Capacity 

Summary Window calculation status and the 

user’s access level.  

Current Structure Type  Displays the pole model structure type.  

“R” Reset and “B” Birdseye View  Allows you to quickly reset the selected pole 

to the center of the ground line compass in 

the 3D View. Or to toggle to/from the 

Birdseye view of the top of the structure.  

Save Copy Print 3D View  The grey button between the Reset and 

Birdseye View buttons provides access to 

save, copy, and print functionality.  

Named View  Allows you to name, save, and recall any one 

of the multiple screen layouts you create 

based on work tasks and/or user preferences.  

Top View  Displays the pole model view from the top 

and provides access to the Gang Editor tool.  

Catalogs Display  Displays the repository of equipment and 

assemblies available to construct the pole 

model.  

Inventory Display  Displays the inventory of the structure as 

you construct it. Additionally, the inventory 

offers functionality using basic windows 

commands, including the drag and drop 

method for substitution and copying.   

  

  

Default Windows  Description  

Catalogs Display  Repository of equipment and assemblies 

available to construct inventory. The 

catalogs are the primary way to add items 

to the inventory.  

Inventory Display  Displays the inventory of the structure as 

you construct it.  

3D View Display  Displays a 3D view of the structure and the 

surroundings.  

Measure Display   Allows the measurement of pole features 

from image data. This process is referred to 
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as Digital Measurement Technology or 

DMT.  

Charts Display  Displays a predefined list of charts to be 

used to help complete a structure’s analysis.  

Reports Display  

  

Displays a list of reports to be used to help 

complete a structure’s analysis.  

    

O-Calc® Display Options  
  

Utilizing O-Calc® Pro Display Options   

Several advanced display options and tools are provided within the O-Calc® Pro application.  

Changing the Theme  

The View tool bar menu provides you with an ability to change the theme of your O-Calc® 

Pro display.   

1. On the Toolbar, select the View menu.  

2. Hover the mouse over the Theme options to view possible choices.  

3. Select either Light, Dark, Blue or Legacy.  

4. Restart the application for the changes to take effect.   

 

General Display Options   

The Options tool bar menu provides you with a variety of display options.   
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Capacity Display  Auto Capacity Summary.  Select the Auto 
Capacity Summary option to automatically 

update the Capacity Window whenever data 

changes.  

Capacity Meter Display.  Select the Capacity 

Meter Display option to have the Capacity 

Window display in a metered format.  

Capacity Numeric Display.  Select the  

Capacity Numeric Display option to have the 

Capacity Window display in a numeric format.  

Factor of Safety Display. Select the factor of  

Safety Display option to have the Capacity 

Window display the Factor of Safety Values 

and active loadcase.  

Command Bar  Toggle on the Command Bar to activate it.  

The command bar feature displays in the Data 

Entry area. Enter a “?” mark to display the list 

of commands. Using Alt+ C can also activate 

the command bar.  

Shortcut Keys  Presents the Shortcut Key Editor window 

which allows you to create any desired shortcut 

keys to replace common commands. Select 

from the menu of commands, choose an 

available option, and select Apply.  

Visualization Color Scheme  Select the Visualization Color Scheme option 

to change the color representation throughout 

the application.  
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Info Tips and Data  Inventory Info Tips.  Select the Inventory Info  

Tips option to see a subset of an object’s attributes 
when you hover over the object’s icon in the 

Inventory Window.  

Component Load Info Tips.  Select the  

Component Load Info Tips option to display what 
the percent of pole capacity that is consumed by the 

object components on the pole.  The tip will display  

as you hover over an object in the Inventory 

Window.  

Catalog Info Tips.  Select the Catalog Info Tips 
option to see an object’s attributes when you hover 

over the object icon in the Catalog Window.  

Heat Map Segment Tips Enabled.  Select the  

Heat Map Segment Tips Enabled option to see a 
subset of an object’s attributes.  The tip will display 

as you hover over an object in the HeatMap 

Window.  

Heat Map Moment and Load Details. Select the 
Heat Map Moment and Load Details option to 

display the full loading details for each element in 

the Heat map when the courser is hovered over the 

element.  

Show All Attributes in Info Tips. Select the Show 

All Attributes in Info Tips option to see an object’s 

editable attributes when you hover over the object’s 

icon in the Inventory Window.  

Expand All Attributes in Data Entry Panel.  
Select the Expand All Attributes in Data Entry Panel 

option to display all an object’s attributes in the 

Data Entry Panel  

Remember Attribute Filter Settings in DEP. 
Select the Remember Attribute Filter Settings 

option to always use the last filter selected in the 

Data Entry Panel, when selecting another object.  

Show TBD Item Status.  Select the Show TBD 

Item Status option to indicate TBD items in the 

Inventory window.  
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Options in 3D View  Options in 3D View.  See 3D View Display Options.  

Camera.  Toggle on/off user specific options. Select 

from an Additional Light Source, adjust Mouse 
Tracking Rates for orbit, pan, zoom functionality. Use 

the Alternate Control Scheme to allow enhanced camera 

control and movement.  

Labels.  Toggle on/off user specific options. Select from 

Label Elements in 3D View, Measure Cursor, Show 
Damage and Decay Markers, Show Sub-Damage and 

Decay Markers, Display Wind Direction Arrow, Display 
Wind Pressure, Display Heights / Ruler, and Show Pole 

Label.  

Show Messenger Only for Bundles.  Prevents 

communication wires from appearing.  

Height Filtering and Angle Filtering.  Narrows the 

scope of the data displayed.       

Visualization.  Ghost and Sweep visualization controls.    

Animate Selected Object (Flash).  Requires advanced 

device drivers to display flashing graphics features.  

Show 3D View When Pole Opened.  Displays the pole 

model in the 3D View when opening a PPLX file.    

Render 3D in Sperate Thread. Displays the pole 

model in a separate window.  

Image Brush Opacity.  Users set the opacity value.   

Units Convention  See Change the Unit Convention.  

Backward  

Compatibility Mode  

Use to save PPLX files in a format from a previous 

version of O-Calc® Pro.  The Backward Compatibility 

Mode also allows a person using a newer version of 

OCalc® Pro to create a PPLX that can be conveniently 

used by a user of an older version of O-Calc® Pro.  

Enable / Disable 

Prompts  

Lists various prompts throughout the application that 

can be enabled or disabled.  

Manage Available 

Reports  

Use to enable or disable various reports on a user-

byuser basis.  

Misc. Options  Use to enable or disable several display options.  
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Manage Plugins  Use to enable or disable various plugins on a user-

byuser basis.  See Manage Plugins.  

  

Working Within the O-Calc® Pro Workspace  

Working with the Inventory Window   

Inventory Window Overview   

The Inventory Window provides you with the ability to construct a model of a utility pole. 

This model includes the structure, the equipment attached and its environment.   

Toolbar Menu Options   

  
 

Sort  Use to sort the inventory object to match how they display on 

the pole from the pole tip to the ground.  

Expand  Use to expand all the plus sign nodes in the Inventory tree.  

Collapse  Use to collapse all the plus sign nodes in the Inventory tree.  

Insul Rotation  Use to rotate an insulator to the appropriate angle for attached 

span angles.  

Query  Use to search the data within the Inventory Window.  

Add   Use to add attachments to the selected equipment.  

Shortcut Key: Select the Insert button on the keyboard.  

Delete   Use to delete selected equipment.  Select multiple pieces of 

equipment, while holding down the Shift key, to delete them 

simultaneously.  Another option is to use the Delete key on 

the keyboard.  

Substitute   Use to substitute the selected equipment.  Multiple pieces of 

equipment of the same type that have been selected can be 

substituted simultaneously.  

Shortcut Key: Select Alt + Insert on the keyboard.  

Edit  Use to edit the selected equipment attributes.  
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Set Owners  Use to set bulk or selected object ownership operations.  

Description  Use to set bulk or selected object description operations, or to 

clear selected or all descriptions.  

Filter       

Use to display only the expanded inventory objects in the 3D 

View. The sunglasses icon indicates a filter is active.   

Note: To enable/disable the text that displays next to the Inventory Window toolbar, see Change 

the Inventory Window Toolbar Display.  

Note: When using the keyboard shortcut keys for Delete, Add and Substitute the Edit > Undo 

option can be used to undo any changes that have been made using these shortcut keys.  

Creating a Single Pole Structure  

Creating a Single Pole  

To create a new Wood, Steel, Concrete, Composite or Segmented Fiberglass pole in the 

Inventory Window, complete the following steps:  

1. Select the structure type from the File > New Pole menu.  

 

 

Note: Available tabs are dependent on corresponding structure types displayed in your 

catalogs.  
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Master Catalog  The Master Catalog tab displays a list of folders that 

contain structure types which coincide with the new 

pole type that you have selected.  

User Catalog  The User Catalog tab displays a list of folders that 

contain structure types which coincide with the new 

pole type that you have selected.  

Attr Values  The Attr Values tab displays an editable list of all the 

attribute values for the selected poles. After a pole is 

added to the Inventory Window these same attributes 

are available to edit in the Data Entry Window.  

Standards  The Standards tab provides a quick way to manually 

select the species, length, and class of the pole based 

on the ANSI 05.1 Standards.  
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2. Select a pole from the Master Catalog, User Catalog or the Standards tab.   

Note: For additional information on catalogs see Working With the Catalog Window.  

3. Select the Attr Values tab to modify the selected poles attribute values.  

4. Click OK.  

Note: Undo is not available when a pole is added. It is not possible to Delete a pole in the 

inventory. Use File > Close Pole to remove the pole. Or use the drag and drop method from a 

Catalog, to substitute for a different pole.  

  
Note:  If a default LoadCase has been set it displays automatically in the Inventory Window when a 

pole is added. To set a Default LoadCase see Set a Default Load Case.   

Setting the Depth of a Pole  

To set the depth of a pole, complete the following steps:  

1. Right click on the Pole you want to set the depth for.  

2. Select Set Length and Depth > Setting Depth of Unset (or Pole name displays).  

   

3. In the Setting Depth window, select the Mode from the drop-down list and enter the 

Depth in Feet.  

4. Select OK.  

         
Note: The Depth in Feet field will automatically display the default pole depth when initially 

opened. The Mode moves either the pole and all its attachments to the new set depth or just the 

pole keeping the attachments at the same height above groundline.  
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Setting the Above Ground Length of a Pole  

To set the length of a pole, complete the following steps:  

1. Right click on the Pole you want to set the length for.  

2. Select Set Length and Depth > Above Ground Length of Unset (Pole name).  

  

3. Select the Mode from the drop-down list and enter the AGL in Feet.  

4. Select OK.  

  
Note: To undo the Setting Depth change, select Edit > Undo. Setting the Above Ground Length is the 

complimentary function to the Setting Depth.  

Setting the Length of a Pole  

To set the length of a pole, complete the following steps:  

1. Right click on the Pole you want to set the length for.  

2. Select Set Length and Depth > Length of Unset (or Pole name displays).  
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3. Select the Mode from the drop-down list and enter the Length in Feet. OK.  

                       

  

Note: Changing the Length is typically for shorting the pole length because it has been stubbed 

in the field.  Only the length attribute of the pole changes.  But not the manufactured length, so 

that the other parameters of the pole such as the circumference and taper, remain unchanged.  

  

Creating Additional Structure Types  

Creating a Multi-Pole Structure  

To create a new Multi-Pole structure in the Inventory Window, complete the following steps:  

1. Select the Multi-Pole Structure type from the File > New Pole menu.  

  

2. The No default load case message box appears, select Yes or No.  
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3. Add an applicable Load Case to the pole from the Load Cases folder in the Catalog, 

using the drag and drop method. To set a Default LoadCase see Set a Default Load 

Case.  

                                            

   

Note: If a default Load Case has been set it displays automatically in the Inventory Window when 

the structure is created.  

   

4. Select the Structure in the Inventory window then select the Add button select the 

pole you would like to add to the multi-pole structure.   

 

  

Note:  Additionally, the same list of available poles can be accessed by right clicking on the multi-

pole structure in the Inventory Window.  

  

                                     

  Available  
Pole   
Types   

  and  
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Note: Available tabs are dependent on corresponding structure types displayed in your catalogs.  

  

5. Select a pole from the Master Catalog, User Catalog or the Standards tab.  

Note: For additional information on catalogs see Working With the Catalog Window.  

6. Select the Attr Values tab to modify the selected poles attribute values.  

7. Select OK.  

Note:  Complete step 2- 5 to add additional poles to the structure.  

Note: Undo is not available when a pole is added.  

8. Select a pole and modify the Offset value in the Data Entry Panel.  

Note: For additional information on changing attributes in the Data Entry panel see Working 

With the Data Entry Window.  
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Adding Attachments to a Structure  

Adding Equipment to a Pole  

To add equipment to a pole, complete the following steps:  

1. Select the Pole you want to add equipment to.  

  
the pole.  

 

Note: If the Divide Add Menu Items by Category option is unchecked in Misc Options, the 

resulting menu items appear as shown below.  

  

Note: The list of available equipment can also be accessed by right clicking on the pole in the 

Inventory Window. See menu options instructions below.  

Note: If the Divide Add Menu Items by Category option is checked in Misc Options, the 

resulting menu items appear by category as shown below.  

2.   Select  the  Add  button     and select the  equipment   or elements  to be added to  
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Note: Display results for the Divide Add Menu Items by Category option:  

   

Note:  The Mirror Guys option is used to easily copy, in the opposite (mirror) direction, any guy 

object in the Inventory that is attached to the pole.  
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Note: The Mirror Guys option can also be accessed by right clicking on the pole, anchor, or 

guy wire in the Inventory Window. See menu options below for right clicking the pole or right 

clicking the anchor.  

   

  

  

Note: If the Divide Add Menu Items by Category option is checked in Misc Options, the 

resulting menu items appear by category as shown below for Add Spans and Related.  
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Note: Only one piece of equipment can be added at a time.  
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3. To add a crossarm from the Catalog tabs or the Inventory tab select the 

appropriate tab and select the crossarm you want to add.  
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 Note:  Available tabs are dependent on corresponding equipment displayed in your catalogs or 

Inventory Window.  

Note: For additional information on catalogs see Working With the Catalog Window.   

4. Select the Attribute Values tab to modify the crossarm’s attribute values.  

5. Click OK.  

  
Note: To undo additions, select Edit > Undo.  
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Different types of equipment can have additional attachments (Example:  A crossarm can 

have insulators and spans attached to it).  To add additional attachments to equipment, 

complete the following steps:  

6. Select the equipment in the Inventory Window you want to add additional 

equipment to.  

7. Select the Add button  and select the equipment to be added from the 

equipment list.  

Note:  The list of available equipment can also be accessed by right clicking on the equipment 

you would like to add additional equipment to.    

  
Note: If multiple pieces of equipment are displayed in the list only one piece of equipment can 

be selected at a time.  

  
Note:  Available tabs are dependent on corresponding equipment displayed in your catalogs or 

Inventory Window.  
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8. To add an insulator from one of the catalog tabs or the Inventory tab select 

the appropriate tab and select the insulator you want to add, select OK.  

Note: For additional information on catalogs see Working With the Catalog Window.  

9. Select the Attribute Values tab to modify the insulator’s attribute values.  

10. Select OK.  

  
Note: To add additional attachments repeat steps 6 – 10.  

Adding a Span Bundle to a Pole  

A span bundle is a composite span that typically includes a messenger strand with 

other spans lashed to it plus the cross-sectional configuration of the lashing.  The 

SpanBundle object represents the messenger strand.  To add a span bundle to an 

attached insulator you first need to create the span messenger wire.  To create the span 

messenger wire, complete the following steps:  

1. Select the Add button  

   

 

2. In the Data Entry window, enter the desired Install Height value for the 

Insulator. 3. Select the Add button  and select the Span  
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4. To add a Messenger from one of the Catalog tabs or the Inventory tab select the 

appropriate tab and select the messenger strand you want to add.  

                
Note: For additional information on catalogs see Working With the Catalog Window.  

5. Select the Attribute Values tab to modify the Span Bundle attributes.  

6. Select OK  

Note: To undo additions, select Edit>Undo.  

Once the messenger strand has been added you need to add the spans.  Complete 

the following steps to add spans to the messenger wire:  

7. Select the Messenger strand in the Inventory Window.  

  

Note: The option to add spans can also be accessed by right clicking on the Span Bundle in the 

Inventory Window.  

8.   Select the  Add  button     and select  Span .   
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Note: Only one Span can be added at a time.  

   

9. To add a Span from the catalog tabs or the Inventory tab select the appropriate tab 

and select the span you want to add.  

  
Note: For additional information on the Catalog Window see Working With the Catalog Window.  

  

10. Select the Attribute Values Tab to modify the Span attributes.  

11. Select OK.  
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Note:  To add additional spans to the span bundle complete steps 7 – 11.  

Note:  To undo additions, select Edit > Undo.  

  

Working with the Span Bundle Editor  

Use the Span Bundle Editor to quickly and efficiently edit the spans positions or add 

additional spans to a span bundle.  The diameter value for a communication bundle is 

displayed in the description information of the messenger wire.  To open the Span 

Bundle Editor, complete the following steps:  

1. Right click on the Span Messenger wire you want to edit.  

2. Select Bundle Editor for (bundle display name).  
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Span Bundle Editor Toolbar Options  

  

The Span Bundle Editor toolbar menu provides you with a variety of operations and options.  

  

  

  

File. The following options are 

available from the File menu:  

Reset View. Select the Reset View 

option to set the Span Bundle editor 

back to the default view.  

Save.  Select the Save option to  

save any changes or additions. This 

is a test   

 Exit. Select the Exit option to close 

the Span Bundle Editor.  
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Edit. The following options are 

available from the Edit menu:  

Add Span.  Select the Add Span 

option to add a span to the span 

bundle.  

Layout Vertical. Select the Layout 
Vertical option to automatically 

reposition all the spans vertically 

under the messenger wire.  

Layout Pack Under. Select the 

Layout Pack Under option to 
automatically reposition all the 

spans under the messenger wire.  

Layout Pack Around. Select the 

Layout Pack Around option to 

automatically reposition all the 

spans around the messenger wire.  

Auto Pack. Select the Auto Pack 
option to have the spans packed as 

close as possible given their size 

and layout.  

Un-Collide.  Select the Un-Collide 

option to position the spans so they 

are not overlaid.  

Dynamic Un-Collide.  Select the 

Dynamic Un-Collide option to 

automatically un-collide the spans 

while you’re dragging them into 

position.  

  
Circumscribe. Selecting the 

Circumscribe option tells you what 

the minimum circle would be that 

all the spans and messenger wire 

could fit into.  

  
Show Labels. Select the Show 

Labels option to display the spans 

descriptions next to each span in the 

bundle.  
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Adding a Span Bundle to a Span Bundle  

  

To add a span to the Span Bundle using the Span Bundle Editor, complete the following steps:  

1. Select Edit > Add Span.  

  
Note: Only one span can be added at a time.  

   

Note: Available tabs are dependent on corresponding spans displayed in your catalogs or 

Inventory Window.  

2. To add a span from the Master Catalog or the User Catalog select the appropriate tab 

and select the span you want to add.  

Note: For additional information on the Catalog Window see Working With 

the Catalog Window.  

3. Select the Attribute Values tab to modify the Span attributes.  

4. Select OK.  

Note: The span is automatically added to the span bundle and is displayed in the Span Bundle Editor.  

Note: There is no Undo option available.  Select File>Save to close the Span Bundle Editor and save any 

modifications that have been completed.   

5. Select File > Save.  
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Repositioning Spans in the Span Bundle  

The Span Bundle Editor offers three ways you can reposition spans within the editor, 

which can affect overall diameter of the bundle.  To reposition span(s) in the span bundle 

use one of the following options:  

1. Select Edit and select a layout option from the Edit menu.  

2. Left click a span in the Span Bundle Display window and drag the span to a new 

location.  

3. Manually enter a Horizontal and/or Vertical value in the Span Detail Table.  

Editing Spans in the Span Bundle  

To edit span attributes from within the Span Bundle Editor, complete the following steps:  

1. Right click on the span in the Span Bundle Display window.  

2. Select Edit Span from the drop-down menu.  

  

3. Complete any modification to the Span Bundle attributes.  

  

4. Select OK.  

Note: There is no Undo option available.  Select File>Save to close the Span Bundle Editor and save any 

modifications that have been completed.  

5. Select File > Save.  

Deleting Spans in the Span Bundle  

To delete a span within the Span Bundle Editor, complete the following steps:  

1. Right click on the span in the Span Bundle Display window.  

2. Select Delete Span from the drop-down menu.  

  

3. Select Yes to the confirmation message: Do you really want to delete the span?  
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Note: There is no Undo option available.  Select File > Save to close the Span Bundle Editor and save any 

modifications that have been completed.  

4. Select File > Save.   

Adding Damage and Decay to Pole  

Poles that are not new may have damage or decay.  The WoodPoleDamageOrDecay 

object is utilized to reduce the overall strength of the pole based on any damage or 

decay on the pole.  To add damage or decay to a pole, complete the following steps:  

1. Select the Pole you want to add damage or decay to.  

  

Note: The Wood Pole Damage or Decay option can also be accessed by right clicking on the pole in 

the Inventory Window.  

  
Note:  Only one piece of damage or decay can be added at a time.  

  

  

Note: Available tabs are dependent on corresponding Wood Pole Damages or Decays displayed in 

your catalogs or Inventory Window.  

  

2.   Select the  Add   button    and select  WoodPoleDamageOrDecay .   
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3. To add damages or decay from the Catalogs tabs or the Inventory tab select the 

appropriate tab and select the damages or decay you want to add.  

Note: For additional information on catalogs see Working With the Catalog Window.  

4. Select the Attribute Values tab to modify the damage or decay’s attributes.  

5. Select OK.  

Note: To undo additions, select Edit > Undo.  

  

Adding a Damage and Decay Group Object  

Damage or Decay objects can also be grouped together. Create a damage or decay 

object using the process documented above, and simply duplicate the damage or 

decay object, with the original decay object as the parent, and each subsequent 

damage or decay object as a child item. This will prevent a long list of damage and 

decay items in the Inventory List.   

  

Adding a Node Junction to Multi-Pole Structures  

The Node Junction in an object that helps facilitates connecting Lattice Sections to 

either individual poles or crossarms.  To add a Node Junction to a complete the 

following steps:  

1. Select the pole you want to add a Node Junction to.  

  
Note:  The Node Junction can also be accessed by right clicking on the pole in the Inventory Window.  
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Note: Available tabs are dependent on corresponding node junction displayed in your catalogs 

or Inventory Window.  

3. To add a Node Junction from one of the Catalogs, select the appropriate tab and 

select the Node Junction you want to add.   

Note: For additional information on catalogs see Working With the Catalog Window.  

4. Select the Attribute Values tab to modify the Node Junction attribute values.   

5. Select OK.  

Note: To add additional Node Junctions complete steps 1 – 5.  

  
Note: To undo additions, select Edit > Undo.  

Adding a Lattice Section to a Multi-Pole Structures  

To add a lattice section to a multi-pole structure in the Inventory Window, complete the 

following steps:  

1. Select the structure you want to add a Lattice Section to.  

  2.   Select the  Add  button     and select  Lattice Section .   
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Note:  The Lattice Section option can also be accessed by right clicking on the structure in the 

Inventory Window.  

 

Note: Available tabs are dependent on corresponding Lattice Section(s) displayed in your catalogs.  

  
3. To add a Lattice Section from one of the Catalogs, select the appropriate tab and 

select the Lattice Section you want to add.   

Note: For additional information on catalogs see Working With the Catalog Window.  

4. Select the Attribute Values tab to modify the Lattice Section attribute values.   

5. Select OK.  
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Note: To add additional Lattice Sections complete steps 1 – 5.  Note: To undo additions, select 

Edit > Undo.  

  

Adding Material to a Lattice Section  

To add material to a lattice section in the Inventory Window, complete the following steps:  

1. Select the lattice section you want to add material to.  

2. Select the Add button  and select Material.  

  

 
  

Note:  Materials can also be added by right clicking on a lattice section in the Inventory Window.  

  
Note: Available tabs are dependent on corresponding materials displayed in your catalogs.  

3. To add Material from one of the Catalogs, select the appropriate tab and select 

the Material you want to add.   

Note: For additional information on catalogs see Working With the Catalog Window.  

4. Select the Attribute Values tab to modify the Material’s attribute values.   

5. Select OK.  

Note: To add additional beams complete steps 1 – 5.  
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Note: To undo additions, select Edit > Undo.  

Adding Beams to a Lattice Section  

To add beams to a lattice section in the Inventory Window, complete the following steps:  

1. Select the lattice section you want to add a beam to.  

 

Note:  Beams can also be added by right clicking on a lattice section in the Inventory Window.   

   

Note: Available tabs are dependent on corresponding beam displayed in your catalogs.  
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3. To add a Beam from one of the Catalogs, select the appropriate tab and select 

the Beam you want to add.   

Note: For additional information on catalogs see Working With the Catalog Window.  

4. Select the Attribute Values tab to modify the Beam’s attribute values.   

5. Select OK.  

Note: To add additional beams complete steps 1 – 5.  

  
Note: To undo additions, select Edit > Undo.  

Select Adding a Lattice Group to a Lattice Section  

To add a lattice group to a lattice section in the Inventory Window, complete the following steps:  

1. Select the lattice section you want to add a lattice group to.  

  

  

2. Select the Add button  and select Lattice Group.  

  

 

Note:  Lattice groups can also be added by right clicking on the lattice section in the Inventory Window.  
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Note: Available tabs are dependent on corresponding lattice groups displayed in your catalogs.  

3. To add a Lattice Group from one of the Catalogs, select the appropriate tab and 

select the Lattice Group you want to add.   

Note: For additional information on catalogs see Working With the Catalog Window.  

4. Select the Attribute Values tab to modify the Lattice Group’s attribute values.   

5. Select OK.  

Note: To add additional lattice groups complete steps 1 – 5.  

  
Note: To undo additions, select Edit>Undo.  

Adding Nodes to a Lattice Group  

To add node(s) to a lattice group in the Inventory Window, complete the 

following steps: 1. Select the Lattice Group you want to add a Node 

to.  
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Note:  Nodes can also be added by right clicking on the lattice group in the Inventory Window.  

   
Note: Available tabs are dependent on corresponding nodes displayed in your catalogs.  

3. To add a Node from one of the Catalogs, select the appropriate tab and select the 

Node you want to add.   

Note: For additional information on catalogs see Working With the Catalog Window.  

4. Select the Attribute Values tab to modify the Node’s attribute values.   

5. Select OK.  

Note: To add additional nodes complete steps 1 – 5. Note: To undo additions, select Edit > 

Undo.  

2.   Select the  Add  button     and select  Node .   
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Editing Equipment Attributes  

To edit equipment attribute(s), complete the following steps:  

1. Select the equipment whose attribute you want to edit.  

  

Note:  The Edit option can also be accessed by right clicking on the equipment whose attributes 

need to be edited and selecting Edit (Pole or equipment display name).  

   
Edit Icons  

  

Edit Icons  Description  

2.   Select the  Edit   button  .   
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  Allows you to select a value or extend the 

default list.  

  Allows you to change the vertical value 

based on mouse movement.  

  Allows you to increase or decrease the 

rotation value based on mouse movement.  

  Allows you to select a value from a 

predefined list.  

  Allows you to increase or decrease the 

value.  

  Allows you to toggle the value to Yes or 

No.  

  

Other Editable Icons that are available when different attachments are selected:  

Editable Icons  Description  

  Allows you to change the horizontal value 

based on mouse movement.  

  Found within a Note attachment.  When 

selected a calendar option is enabled, 

allowing you to select a specific date for a 

selected attribute.  

  Found within a Note attachment.  When 

selected the selected Note is displayed in 

edit mode.  

  Allows you to select the color.  

  Allows you to open a table and change 

values within the table.  

(Example: When a pole’s Moment Cap  

attribute table icon is selected it provides a 

table allowing you to change the values of 

the Moment Capacity vs. Height)  
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When entering data in the Data Entry window, there are several key words and 

calculation shortcut options available to be utilized. Note: Shortcuts are not generally case 

sensitive.  

Data Entry Shortcuts  

  

UNITS  

FFF’II   

  

  

  

  

CTRL+U  

  

Unit Shortcuts:  

FFF’II enters values in feet and inches 
instead of decimal feet.  

(Example: Crossarm>Initial Height attribute 

enter 40’6)  

  

CTRL+U enables a conversion tool that 
allows you to easily convert an input value.  

  
Enter an Input value, select the convert 
From/To options in drop-down menu. Select 

OK.  

  

HEIGHTS  

TIP-NNN  (T-NNN)  

  

  

  

  

HAGL=NNN  

HA=NNN  

  

  

  

  

  

REF=+NNN  

REF =-NNN  

  

  

  

  

  

  

T@NNN  

  

  

Height Shortcuts:  

Tip adds an object at the tip of the pole.  

tip-nnn allows you to enter feet down from 

pole tip.  

(Example: tip-3 or t-3 adds an object 3 feet 

down from the tip of the pole)  

  

hagl=nnn changes the end drop and rise of a 

span based on the height above ground line at 

another pole. Entering ‘sag’ values as 

measured from height above ground line.   

(Example: hagl-38 or ha-38)  

  

ref=(+/-)nnn adjusts ‘height of attachment’ of 

an object relative to another object by 
entering a height value.   

  

Note: You must enter either a (+/-) sign before the 

number to move the object either above or below 

the reference object.  

  

t@nnn sets the ‘height of attachment’ or 
‘Install Height’ value to correspond to the top 

of an object.   
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C@NNN  

  

  

  

B@NNN  

c@nnn sets the ‘height of attachment’ or 

‘Install Height’ value to correspond to the 

center point of an object.  

  

b@nnn sets the ‘height of attachment’ or 

‘Install Height’ value to correspond to the 
bottom of an object.   
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ROTATIONS  

ABS=NNN  

AB=NNN  

  

  

ABS=~NNN  

AB=~NNN  

  

  

IND=NNN  

  

  

  

REF=+NNN  

REF=-NNN  

Rotation Shortcuts: abs=nnn sets 
absolute rotation (compass coordinates) 
to the entered value.  

(example: abs=90 or ab=90)  

  

abs=~nnn adds 180 degrees to the entered 
value.  

(Example: abs=~90 or ab=~90)  

  

ind=nnn independently rotates an object 
without effecting the rotation of any attached 

objects.  

  

ref=(+/-)nnn adjusts the ‘rotation’ of an 

object in reference to (relative to) another 
object by entering a rotation value.  

  

Note: You must enter either a (+/-) sign before the 

angle to rotate the object in a given direction from 

the reference origin angle.  

  

WIRES  

MOE=  

  

  

  

  

  

  

  

  

AWG=NNN  

  

Wire Shortcuts: moe= enables the Modulus 
of Elasticity Calculator.  The MOE value 
can be adjusted in the calculator and 

populated into the Data Entry panel.  
Note: For additional information on working 
with the Modulus of Elasticity Calculator, 
see Working with the Modulus of Elasticity 
Calculator.  

  

awg=nnn populates the standard diameter 
from the AWG Table.  
(Example: awg=10 will automatically 

populate the AWG Gauge 10 conductor 

diameter)  

   

CIRCUMFERENCES  

DIAM=NNN  

D=NNN  

  

  

  

Circumference Shortcuts:  

diam=nn enters the diameter which is then 

automatically converted to a circumference 

value.  

RADIUS=NNN  

R=NNN  

  

(Example: diam=12.5 or d=12.5 will 

automatically be converted to circumference 
value) radius=nnn enters the radius which is 

then automatically multiplied by two.   

(Example: radius=12.5 or r=12 )  

  



Osmose O-Calc® Pro 7.0.1                                    Confidential  User Guide  

56                   ©2024 Osmose Utilities Services, Inc.  

EXPRESSIONS CTRL+E  

  
Expressions Shortcut:  

ctrl+e enables the Expression Evaluation 
which allows you to enter expression values 
and the results are automatically populated 

into the Data Entry panel.  

  

Enter the Expression and select OK.  

  

CALCULATOR CTRL+F  

  
Calculator Shortcut: ctrl+f enables the 

Calculator which allows you to enter 
calculations that are then automatically 

populated into the Data Entry panel.  

  

Enter a calculation and 

select OK.  

  

3. Complete your edits to the equipment’s attributes.    

Note: Certain attributes are only editable in Administrative User Mode.  

4. Select OK.  

Note: To undo edits, select Edit > Undo.  

  

Setting the Height of Equipment  

In the Edit tab are options to set the height of an object on the pole:  

  

1. Select the object you want to set the height for.  

2. Select Edit > Set Height.   
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3. Select the Set at default option or select the Edit Height option and enter a value for 

the selected object.  

  
  

4. Click OK.  

Setting Relative Height  

In the Edit tab are options to set the relative height of an object on the pole:  

1. Select the object to set the relative height for on the pole.   

2. Select Edit > Relative Height.   
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3. Set the parameters for the relative height;  

a. Choose what part of the object to set at the relative height; the 

Center of the  

Object, Top of the object, or the Bottom of the object  

b. Choose the value for the offset  

c. Choose what the height or offset will be relative to; Groundline, Tip 

of Pole, Top Power, Bottom Power, Top Comm, Bottom Comm  

  
4. Click OK.  

Setting a Reference Origin  

In the Edit tab are options to Set Origin Angle and Set Origin Elevation for an object on a pole:  

1. Select the object you want to use as the reference point and select the 

desired option; Set Origin Angle or Set Origin Elevation.  
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2. Once selected, enter the value for the Reference Angle or Reference Height 

option. When entering the Reference Height value, the specified value is 

displayed on the object in the 3-D screen.  

  

3. Select Clear Reference Origin to clear the option and remove the value 

displayed on the object in the 3-D screen.  

  

Note: When using the Reference Height option, the reference object is highlighted yellow. An 

orange marker is placed on the ground line compass in the 3-D view and the specified value is 

displayed on the screen for the corresponding Reference Angle.  
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Note: When selecting the Reference Height, the value is also displayed in the Schematic window, as 

shown below.  
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Rotating Insulators to Match Span Angles  

To rotate an insulator to be appropriate for attached span angles, complete the following steps:  

1. Select the insulator you want to rotate.  

  

2. Select the Insulator Rotation button  

The selected insulator is automatically rotated to the span angle.  

Note: The Rotate to Span Angle option can also be accessed by right clicking on the insulator to 

be rotated and selecting Rotate to Span Angle.  

Note: To undo the insulator rotation change, select Edit > Undo.  

.   
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Changing a Description  

To change the description that displays next to a pole or attached equipment’s icon in the 

Inventory Window, complete the following steps:  

1. Right click on the pole or attached equipment you want to change the display 

description of.  

  

2. Select Description of (pole or equipment display name).  

   

3. Enter the Description you would like to be displayed.  

   
Note: Select Clear to clear the description field and use the default value.  

4. Select OK.  

  
Note:  To undo the display description change, select Edit>Undo.  

Deleting Attached Equipment  

To delete equipment that is attached to a pole, complete the following steps:  

1. Select the equipment to be deleted.  
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Note: Multiple pieces of equipment can be deleted concurrently if they are all the same type of 

equipment.  Hold down the Ctrl key to select more than one piece of equipment at random 

within the Inventory list.  Hold down the Shift key to select a ‘range’ of equipment objects 

within the Inventory list by clicking on a top and a bottom piece of equipment that are in 

sequence.    

  

Note: Individual equipment can also be deleted by right clicking on the equipment to be deleted 

and selecting Delete (equipment). Or by clicking on the Delete key on your keyboard.  

     

  

Note: To undo a deletion, select Edit > Undo.  

  

Substituting Attached Equipment  

To substitute attached equipment in the Inventory Window, complete the following steps:  

1. Select the equipment you would like to substitute.  

   

Note: Multiple pieces of equipment can be substituted concurrently if they are all the same type 

of equipment.  Hold down the Ctrl key to select more than one piece of equipment at random 

within the Inventory list.  Hold down the Shift key to select a ‘range’ of equipment objects within 

the Inventory list by clicking on a top and bottom piece of equipment that are in sequence.   

2. Select the Substitute button .  

  

Note: The Substitute option can also be accessed by right clicking on the equipment that needs to 

be substituted and selecting Substitute (Equipment display name).  

2.   Select the  Delete   button .     
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Note:  Available tabs are dependent on corresponding equipment displayed in your catalogs or 

Inventory Window.  

3. To substitute equipment from the Catalogs or the Inventory tab, select the 

appropriate tab and select the equipment you want to use as a substitution.   

Note: For additional information on catalogs see Working With the Catalog Window.  

4. Select the Attribute values tab to modify the equipment’s attributes.  

    
Note:  To substitute equipment with equipment from the Catalog Window or in the Inventory 

Window select the appropriate tab and select the equipment you want to use as the substituted 
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equipment. For additional information on the Catalog Window see Working With the Catalog 

Window.  

5. Select OK.  

  
Note:  To undo the substitution change, select Edit>Undo.  

Substituting a Pole  

To substitute a pole in the Inventory Window O-Calc® Pro provides you with three 

options.  You can either manually select the substitute pole, select the substitute pole 

from the Catalog Window or you can use the Pole Solver option to help you select the 

substitute pole.  The pole solver option will display the minimum pole class and the 

estimated capacity that would be used based on the pole’s current load.  To substitute 

the current pole, complete the following steps:  

1. Select the pole you would like to substitute.  

  

Note: The Substitute option can also be accessed by right clicking on the pole and selecting 

Substitute (Pole’s display name).  

   
Note: Available tabs are dependent on corresponding equipment displayed in your catalogs or 

Inventory Window.  

2.   Select the  Substitute   button  .   



Osmose O-Calc® Pro 7.0.1                                    Confidential  User Guide  

66                   ©2024 Osmose Utilities Services, Inc.  

Note:  Estimated Capacity will display Infinity% until a pole is selected.  

3. Use one of the following methods to select the substitute pole you want:  

Note: The Estimated Capacity percentage will automatically be updated dependent on your 

attribute selections.  

A. Manually select the substitute pole attributes from the Attribute Values 

or Standards tab.  

B. Select the substitute pole from a Catalog tab.  The attributes can still be 

modified if needed in the Attribute Values tab.  

Note:  For additional information on the Catalog Windows see Working With the Catalog Window.  

C. Select the Use Pole Solver button   to have O-Calc® Pro  

automatically select the minimum Pole Class estimated to provide you 

with a passing pole.  

4. Select OK.  

If there are attachments already on the pole the Height Adjustments window will 

automatically be displayed.  The Height Adjustment window allows you to adjust the 

substitute poles depth and the height of the attachments relative to groundline or 

distance from tip on the newly substituted pole.  

   

5. Modify the Pole Depth if required.  

6. Verify and change each attachment height if required.   

7. Select OK.  

Note:  To undo the substitution change, select Edit > Undo.  
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Adding a Note to a Pole or Equipment  

  

To add a note and/or calculations to a pole or attached equipment in the Inventory 

Window, complete the following steps:  

1. Select the Pole or pole attachment such as the Crossarm.  

  

  

   

Note:  The Notes option can also be accessed by right clicking on any equipment to add a note.  

  

3. Enter a note Title, and the note Content.  

    

   

Editing a Note  

To edit a note or the calculations, complete the following steps:  

1. Select the note you want to edit.  
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  .  

  

Note:   The edit option for a note can also be accessed by right clicking on a note and either 

selecting Edit Note, Edit Note Contents or View/Print Note.  

  

  

Note:  Basic changes to a Notes Description, Note Type, Owner, Author or Date can be made 

right from the Data Entry window.  Content changes to a Note or Calculations need to be 

completed from within the Note window.  

3. Select the Contents Press to View >> button .  

4. Complete your edits to the note contents or the calculations.  

5. Select File > Save.  

  

  

Note:  To undo the addition of the Note, select Edit > Undo from the main toolbar.  

Changing the Note Type  

The note type field allows you to easily flag a structure as needing additional 

interaction. To change the note type, complete the following steps:  

1. Select the note whose type you want to change.  

  
Note: You can also edit a note by right clicking on a note and selecting the Edit Note option.  

2.   Select the  Edit   button   .   

2.   Select the  Edit   button  
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Note:  To have TBD Notes highlighted in the Inventory Window, enable the option in Options > 

Info tips and Data > Show TBD Item Status.  

  

Understanding Note Type Icons  

The Note icon in the Inventory Window will vary depending on what Note Type is selected.  

Note Type Icons  Description  

  Normal or Info  

  High Priority  

  

3.   Select the  Note Type   icon  .   

4.   Select a  Note Type   from the predefined list.   

  

  

Note  
Type is  
set to  
TBD  
Initial   
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  TBD Initial  

Note: The note, the pole, and the 

object that the 

note is attached to 

will  
be   if Show TBD 

Item  
Status is enabled.  

highlighted 

red 

  TBD Complete  

Note: The note, the pole, and the 

object that the note is attached to will 

be highlighted yellow if Show TBD 

Item Status is enabled.  

  TBD Accepted  

Note: The note, the pole, and the 

object that the 

note is attached 

to will  
be  if Show TBD  

Item Status is enabled.  

highlighted 

green 

  

View or Print a Note  

To view or print a note, complete the following steps:  

1. Right click on the note you view or print.  

  

2. Select View / Print Note (note display name).  

   

The selected note will automatically display in the Reports window.   



Osmose O-Calc® Pro 7.0.1                                     Confidential                                                                User Guide  

©2024 Osmose Utilities Services, Inc.                                                                                                  71  

  

Changing the Description of a Note  

To change the description that displays next to a note icon in the Inventory Window, complete 

the following steps:  

1. Right click on the note you want to change the display description of.  

  

2. Select Description of (note display name).  

  

3. Enter the Description you would like to be displayed.  

   
Note:  Select Clear to clear the description field and use the default value.  
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4. Select OK.  

  
Note:  To undo the display description change, select Edit > Undo.  

Deleting a Note  

To delete a note, complete the following steps:  

1. Select the Note to be deleted.  

  

Note:  Notes can also be deleted by right clicking on the note to be deleted and selecting Delete 

(note display name).  

  
Note: To undo a deletion, select Edit > Undo.  

Substituting a Note  

To substitute a note, complete the following steps:  

1. Select the note you would like to substitute.  

2. Select the Substitute button .  

  

2.   Select the  Delete   button  .   
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Note: The Substitute option can also be accessed by right clicking on the note that needs to be 

substituted and selecting Substitute (Note display name).  

  

Adding a Calculation to a Pole or Equipment  

  

From the Note Window, the Calculations tab provides a lightweight spreadsheet that 

allows you to enter values such as numeric and string variables, but it also allows you 

to enter basic calculations.  Numeric values can also be obtained from the selected 

equipment’s attributes or the selected equipment’s parent objects. To add a Calculation 

to the Note, follow these steps:  

1. Select the Add button  and select the Notes option.  

2. Select the Calculations tab.  

Note: When working with the Measure Window numeric values can also be obtained from taking 

actual image measurements.  For additional information on this, see Adding Measurements 

Information to a Note. In addition to the basic Notes menu options, the Calculations tab 

also provides the following menu options:  

  

Recalculate. Select the Recalculate 

option to update any formula 

calculations in the spreadsheet.  

Add Row. Select the Add Row 

option to add a row to the 

spreadsheet.  

Paste. Select the Paste option to 
paste values only or complete text 

from the Office Clipboard directly 

into the spreadsheet.  

Copy Sheet. Select the Copy Sheet 
option to place the sheet on the 

Office Clipboard for use in other 

applications.  

Item Attributes. Select the Item 

Attribute option to incorporate other 

values into the spreadsheet from the 

select equipment or a parent’s 

attributes.  

  
Formula Bar.  Use the Formula Bar 

to make it easier to view and edit a 

long formula or large amount of text 

in a cell.    

  

4. Enter data or calculations into the spreadsheet.  
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Adding an Item Attribute to the Calculation  

  

To incorporate attribute value from the equipment the note is attached to or from a 

parent item, perform the following steps.  Select the field you want the value populated 

into.  From the menu select Sheet > Item Attribute and choose the items whose 

attribute value you need displayed in the spreadsheet.  

  

  

  

  

  

  

  

  

  

String values  
entered into the  
spreadsheet   
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Manually Entering a Formula  

 

5. From the main menu select File > Save.  

  

  

  

  

    

Selected  
Crossarm  
Install Height  
attribute  

Manually enter a formula   
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Note: To undo the addition of the Note, select Edit > Undo from the main toolbar.  

Adding a URI to a Pole or Equipment  

To add a Universal Resource Identifier (URI) to a pole or attached equipment in the 

Inventory Window, complete the following steps:  

1. Select the pole or pole attachment.  

  

Note:  The Linked URI option can also be accessed by right clicking on the equipment you need to 

add a linked URI to.  

  

Note: To undo the addition of the URI, select Edit > Undo from the main toolbar.  

Editing a URI   

To edit a URI, complete the following steps:  

1. Select the URI you want to edit.  

  

2.   Select the  Add   button    and select the  LinkedURI  option .   

2.   Select the  Edit   button   .   
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Note:  Basic changes to a URI Description, Owner or Viewer can be made right from the Edit 

Window.  Content changes to a URI need to be completed from within the URI Window.  

Note:  The edit option for a URI can also be accessed by right clicking on a URI and either 

selecting Edit Link.  

3. Select the URI button .  

4. Select Edit URI.  

  

5. Enter the URI you would like to use.  
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6. Select Test to verify the entered URI is correct.  

7. Select OK.  

Note: To cancel the current URI, select the Cancel option.  The URI change can also be done by 

selecting Edit > Undo from the main toolbar.  

Setting the URI Viewer  

To set what viewer you want the URI opened in, complete the following steps:  

1. Select the URI you want to select a viewer for.  

  

Note:   The edit option for a URI can also be accessed by right clicking on a URI and selecting Edit Link.  

  

 

3. Select the Viewer button  

4. Select Built in to have the URI link open within the application as a separate 

tab.  Select External to have the URI link open in a separate window outside of 

the application.   

2.   Select the  Edit   button   .   

.   
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Changing the Description of a URI  

To change the description that displays next to the URI icon in the Inventory Window, 

complete the following steps:  

1. Right click on the URI you want to change the display description of.  

  

2. Select Description of (URI display name)  

  

  

  

  

3. Enter the Description you would like to be displayed.  

  
Note: Select Clear to clear the description field and use the default value.  

Opening a URI Link  

To open a URI Link, complete the following steps:  

1. Right click on the URI you want to open.  
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2. Select View Linked Item.  

  

Delete a URI  

To delete a URI, complete the following steps:  

1. Select the URI to be deleted.  

  

Note:  URIs can also be deleted by right clicking on the URI to be deleted and selecting Delete 

(URI display name).  

  
Note: To undo a deletion, select Edit > Undo.  

Adding Pole Coordinates  

To manually enter longitude and latitude coordinates to the pole currently loaded in the 

Inventory Window, complete the following steps:  

1. Select Edit > Pole Coordinates.  

2.   Select the  Delete   button  .   
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2. Enter the Latitude.  

3. Enter the Longitude.  

4. Enter the Elevation.  

5. Select the Set Convention button to change any of the convention formats.  

  

6. Select OK.  

Note: Select the Cancel option to close the Geolocation window without saving the changes.  

  

  

  

  

  

Sorting Attached Equipment  

To sort the equipment in the Inventory Window so that it displays in a top down view of the 

pole, complete the following steps:  
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1. Select the Sort button  

  

Note:  To undo the sort operation, select Edit > Undo.  

Filtering the Attached Equipment  

To utilize the Filtering option in the Inventory Window, see Filtering the 3D View.  

Expand or Collapse the Tree View  

To expand or collapse the Inventory Window tree view, complete the following steps:  

1. Select the Expand button  to expand the Inventory Window tree view.  

2. Select the Collapse button  to collapse the Inventory Window tree view.  

  

Creating a New Version of an Existing Pole  

  

While working with a pole or structure in the Inventory Window it may be beneficial to 

compare multiple versions of the pole or structure simultaneously.  O-Calc® Pro 

provides the ability to create multiple versions without losing any the functionality that 

O-Calc® Pro is known for.    

To create a new version of the existing pole in the Inventory Window, complete the 

following steps:  

1. Right click on the Pole you would like to create another version of.  

  

.   
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2. Select New > Version of This Pole.  

  

 

Note: To remove the new version, select Edit > Undo.  

The ‘New’ version automatically becomes the active version in the Inventory Window.  

The active version is always displaying the pole icon outlined in red  to easily 

identify which pole’s data is being displayed in the Capacity window.  The Data Entry 

window always displays the currently selected pole information.     

When saving a pole, all versions of the pole will be saved.  

Note: To create a new version of a pole without any attachments, select Edit > New Version > (Pole Type).  

 

  

Note: When creating a new version of the existing pole any images that are associated with the 

existing pole will not be copied to the new version.  

  

New  
version  
of the  
pole   
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Setting the Active Version   

To set which pole is the active version in the Inventory Window, complete the following steps:  

1. Right click on the Pole you would like to make the active version.   

2. Select Set Active Version.  

   

Note: The selected pole is now outlined in red  indicating it’s the active version.  All the windows 

in OCalc® Pro are automatically recalculated and updated to reflect the selected active version.  

Note: The Data Entry Window will always display the currently selected pole.  

Working with Stub Poles  

While working with a pole that has a span/head guy going to a stub pole attachment it is 

often the case that you may want to perform analysis on the stub pole as well.  O-Calc® 

Pro provides a convenient method to perform stub pole analysis.  You can either create 

the stub pole as a completely new pole analysis or you can create the new pole as a 

version within the same pole analysis.  

Keep in mind interchangeable terms commonly used for the Stub Pole object are Stub 

Pole for Span Guy; Span/Head Termination; Anchor. Terms commonly used for the 

Span/Head Guy object are Guy Brace; Span/Head; Guy Wire; Span Guy. 

Creating a New Pole using Stub Pole  

To create the stub pole as a completely new pole within the Inventory Window, complete 

the following steps:  

1. Using a pole model that already has a Stub Pole for Span Guy (see Catalog 

Assemblies > Guy and Anchor Assemblies folder) added to the pole. Left 

click on the pole you would like to use to create a new pole.  The new pole 
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can either be the current pole in the Inventory Window or a pole from the 

Catalog. 

  

2. Hold down the left mouse button and drag and drop the selected pole onto the 

Stub Pole for Span Guy object in the Inventory Window.  

3. In the Data Entry the Span/Head Term object is displayed as Description - 

Anchor. 

  

Note: A new stub pole can also be added by right clicking on the Span/Head Termination, 

selecting Stub Pole as New Pole then manually selecting the new pole.  

Ter

min

atio

n 

Stu
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Note:  While dragging the selected pole to the Inventory Window the cursor will change to an invalid cursor  
.  As the equipment is placed over the Span/Head Termination object in the Inventory Window the  

cursor wi ll change to indicate a valid move  .   
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e  

  

4. Right click on the stub pole in the Inventory, select Stub Pole as New Pole. 

Then select the type of pole from the menu options.  

 
  

Note:  A stub pole is guyed automatically, if a default Auto-guy assembly has been set. To disable 

the automatic guying of the new stub pole, see Enabling the Ability to Auto Guy a New Stub Pole.  

Note: Undo is not available for this operation.  

Creating a New Version of a Stub Pole  

To create a new pole as a version within the same pole within the Inventory Window, 

complete the following steps:  

1. Left click on the pole you would like to use to create a new version.  The 

new pole can either be the current pole in the Inventory Window or a pole 

from the Catalog.  

2. Hold down the mouse button and drag and drop the selected pole onto the 

Span/Head Termination object in the Inventory Window.  

  

Note: A new pole version can also be added by right clicking on the Span/Head Termination and 

selecting Stub Pole as Version.  

      

       

    

New  
Stub  
Pole   
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Note: While dragging the selected pole to the Inventory Window the cursor will change to an invalid 

cursor  

.  As the equipment is placed over the Span/Head Termination object in the Inventory 

Window the cursor will change to indicate a valid move .  

3. Right click on the stub pole in the Inventory, select Stub Pole as Version. 

Then select the type of pole from the menu options.  

  
Note: To disable the automatic guying of the new stub pole, see Enabling the Ability to Auto 

Guy a New Stub Pole.  

Note: To remove the new version, select Edit > Undo.   

Opening an Existing Pole  

To open an existing pole in the Inventory Window, complete the following steps:  

1. Select File > Open Pole…  

  

2. Browse to the location of the pole to open select the pplx file and click Open.  

Save a Pole  

To save the pole in the Inventory Window, complete the following steps:  

1. Select File > Save Pole.  
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2. Browse to the location where you will save the Pole and click Save.  

Save a Pole Using Save As   

To save a pole as a different file name, format or location, complete the 

following steps: 1. Select File > Save Pole As…  

  

2. Browse to the location where you will save the pole and 

click Save.  

Close an Existing Pole  

To close the current pole in the Inventory Window, complete the following steps:   

1. Select File > Close Pole.  

  
Note: If any changes have been made to the current pole you will be prompted to save your changes 

before closing the pole.  

Previewing an Existing Pole  

To preview an existing pole(s) without having to load each one manually, complete the following steps. 

WARNING: Any changes to the pole you are previewing can NOT be saved.  

  

1. Select File > More Options > Preview Pole.  
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Note: If you have an unsaved pole loaded in the Inventory Window you will be prompted to save 

your changes.  

2. Select the Browse button   and browse to the Directory that has the .pplx file(s) 

you would like to preview.  

3. Select OK.  

 
4. Select the .pplx file you would like to preview. Select OK.  

  

Note: Select Open to open the selected .pplx file in edit mode instead of Preview Mode.  Select 

Cancel to close the Preview Pole window.  

 

The pole is automatically displayed in Preview Mode within O-Calc Pro.  

  

  

  

Preview   Preview Mode   
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While previewing a pole in Preview Move several things are changed within O-Calc 

Pro to clarify that you are actually in Preview Mode.  A Preview Mode banner is 

displayed at the top of the 3D View window.  The File menu is automatically 

switched to Preview and offers several preview options.  

Preview Toolbar Menu Options  

The Preview toolbar menu option provides you with a variety of options:  

  

Preview to New Pole. Select the 
Preview to New Pole option to 

convert the currently previewed 

pole to a new pole.  

Preview to New Version. Select 
the Preview to New Version option 

to convert the currently previewed 

pole to a new version.  

Open Previewed Pole. Select the 

Open Previewed Pole option to 

open the currently displayed 

preview pole and exit preview 

mode.  

Create a New Pole for a Preview Pole  

To create a new pole from the pole you are currently previewing, complete the following steps:  

1. Select Preview > Preview to New Pole.  

  
Note: Once Preview to New Pole is selected the Preview Mode is automatically closed.   

2. Complete any modifications to the new pole.  

3. Select File > Save to save the new pole.  

Create a New Version from a Preview Pole  

To create a new version from the pole you are currently previewing, complete the 

following steps:  

1. Select Preview > Preview to New Version.  

  
Note: Once Preview to New Version is selected the Preview Mode is automatically closed   
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2. Complete any modifications to the new version.  

3. Select File > Save to save the new version.  

Open a Preview Pole  

To open the pole you are currently previewing, complete the following steps:  

1. Select Preview > Open Previewed Pole.  

  
Note: Once Open Previewed Pole is selected the Preview Mode is automatically closed.   

2. Complete any modifications to the pole.  

3. Select File > Save.  

Close the Preview Mode  

To close the pole, you are previewing and exit the Preview Mode, complete the following steps:  

WARNING: Any changes to the pole you are previewing will NOT be saved.  

1. Select Preview > Close Preview.   

  

  

Working with the Pole Reviewer  

To quickly edit several poles sequentially or to locate .pplx files, complete the following steps.  

1. Select File > More Options > Pole Reviewer.  

   
Note: If you have an unsaved pole loaded in the Inventory Window you will be prompted to save 

your changes.  
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2. Select the Browse button   and browse to the Directory that has the .pplx 

files.  

3. Select OK.  

  
Note:  The first pole in the Pole Reviewer list will automatically be displayed in the Inventory Window.  

4. Complete any modifications to the currently loaded pole and select Next to load 

the next .pplx file in the Inventory Window.  

Note:  If the Auto Save option is deselected you will be prompted to save the changes to each .pplx 

file you change.  

5. Select the X in the upper right-hand corner to close the Pole Reviewer window.  

6.   

Setting a Default File Name  

The Default File Name option provides you with the ability to use a reporting token to 

create a default file name to match a specific naming convention.  To set a default file 

name, complete the following steps:   

1. Select File >More Options > Set Default File Name.  

  

 

Note:  A pole does not need to be loaded in order to set a default file name.  
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2. Enter the file name token you would like to use.  

  
Note: Select Help to view a list of valid tokens.  A token can be copy and posted from the valid 

token list into the Default File Name field.   

3. Select Test to preview what the default file name will display as.   

4. Select OK.  

Note: To cancel the current Default File Name, select the Cancel Option.  

After you set the Default File Name, the first time you save a pole the default file name token 

will automatically be displayed in the file name.  

Note:  Once the pole has been saved with a specified name, it will not update the file name 

default File Name, unless a save Pole As…action is performed.  

   

  Default file name token   



Osmose O-Calc® Pro 7.0.1                                    Confidential  User Guide  

94                   ©2024 Osmose Utilities Services, Inc.  

Working with the Catalog Window   

Catalog Window Overview   

The Catalog Window provides you with the ability to efficiently assemble a pole and its 

common equipment in the Inventory Window.   The Catalog Window consists of two 

main areas.  The Master Catalog contains a compiled list of common poles, assemblies 

and equipment that are utilized in the field.  It also contains a complete listing of all the 

available Load Cases which are used to add the applicable regulations to the pole to 

apply wind, ice, and safety factors.  The User Catalog is a folder in which you can 

compile your own list of poles or equipment that you’ve created.   You can then use the 

data in the User Catalog to build additional poles in the Inventory Window.   

  

  

Note:  Changes and addition can only be done in the Master Catalog when you are in 

Administrative User Mode.   Load Cases cannot be edited in the Master Catalog.  The User Catalog 

is available to edit.   

  

Catalog Window Toolbar Menu Options   

The Catalog Window toolbar provides you with a variety of options.  

  

Collapse  Select the Collapse option to collapse all the objects in the 

current Catalog window.  

New Pole  Select the New Pole option to create a new pole in the 

Inventory Window from the selected catalog item.  

Preview  Select the Preview option to preview a pole in the Inventory 

Window from the selected catalog pole.  

Query  Select the Query option to search the data within the current 

catalog.  

Add  Select the Add option to add a sub folder to a User Catalog 

folder.  
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Remove  Select the Remove option to remove a selected folder or 

object within the User Catalog.  

 

 

 

Master Catalog Functions  

Set a Default Load Case  

Load cases are used to group a series of loads, boundary and safety conditions into load 

environments.  The Master Catalog provides a dynamic listing of load cases broken down 

into categories.    

For each category, a default load case should be specified dependent on pole type.  This 

ensures that the correct load case is used each time a pole of that category/type is 

created.  Use the following steps to set a default load case for each category:  

1. Expand the Master Catalog folder.  

2. Expand the Load Cases folder until the catalog list you need is displayed.  

  
Note: A default Load Case can only be selected from the Master Catalog.  

3. Right click on the Load Case you want to set as the default.  

4. Select Set as the default LoadCase and select the pole type.  
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5. Select OK to the verification message.  

   

Note:  A default LoadCase can be set for each LoadCase category.  In addition, one extra 

LoadCase is allowed to be set.  This extra LoadCase is the “Other” LoadCase.  Complete steps 1 

– 5 to set the default LoadCases for each category.  The default Load Case can be changed at any 

time.  

  

Setting a Default Auto-Guy Assembly  

An Auto-Guy Assembly is used in the 3D View to properly guy a structure using a 

limited number of steps.   An Auto-Guy Assembly should consist of one guy and one 

anchor.  The Master Catalog provides a common listing of Guy and Anchor 

Assemblies.  A default Guy and Anchor Assembly should be specified so that the 

correct one is used each time the Auto-Guy option is used.  Use the following steps to 

set a default Auto-Guy assembly:  

  

1. Expand the Master Catalog folder.  

2. Expand the Assemblies > Guy and Anchor Assemblies folder.  

Note: A default Auto-Guy Assembly can be selected from the Master Catalog or the User Catalog.  To 

be considered an Auto-Guy Assembly the assembly must consist of only one anchor and one guy.  
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3. Right click on the Anchor for Down Guy assembly, or any assembly you want to 

set as the default.  

  

4. Select Set as the default “Auto-Guy” assembly  

  

5. Select OK to the verification message.  

Note: The default Auto-Guy Assembly can be changed at any time.  

Creating a New Pole  

To create a new pole in the Inventory Window using a pole listed in a Catalog, complete 

the following steps:  

1. Poles can be added from any Catalog that has the pole you want.  

2. Expand the Poles folder and its subfolders until the pole you need is displayed.  
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3. Select the pole to be added to the Inventory Window.  

  

5. The selected pole is automatically added to the Inventory Window.  

Note: The selected pole can also be added to the Inventory Window by right clicking on the 

selected pole and selecting New > Pole Using This Pole as Template.  

Note: Undo is not available when adding a pole.  

Adding Equipment to the Pole  

To add equipment to a pole in the Inventory Window using the equipment found in any 

Catalog, complete the following steps:  

  

4.   Select the  New Pole   button  .   Or drag and drop the pole to the Inventory.   
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1. Expand the Master Catalog folders containing the equipment you want to 

add.  

2. Expand subfolders until the equipment you need is displayed and select it.  

  

3. Hold down the mouse button and drag and drop the select equipment onto 

the pole in the Inventory Window.  

Note:  While dragging the selected equipment to the Inventory Window the cursor will change to 

an invalid cursor .  As the equipment is placed over the pole in the Inventory Window the cursor 

will change to indicate a valid move .  

Note:  To undo the equipment you added, select Edit > Undo.  

Note:  To set a default percent of maximum span tension in Static Tension Mode to be applied 

to conductors when they are selected from the Master Catalog, see Modifying Span’s Default 

Rated Strength Percentage. Or go to Options > Misc. Options >Percent of Span Rated 

Strength to Apply as Tension.  

  

Adding a Load Case to the Pole  

To add Load Cases (pole loading regulations) to a pole in the Inventory Window using 

Load Cases listed a Catalog, complete the following steps:  

1. Expand the Catalog folder that has the Load Case you want.  

2. Expand the Load Cases folder until the catalog list you need is displayed.  
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3. Select the Load Case to be added to the pole in the Inventory Window.  

  

4. Hold down the mouse button and drag and drop the selected Load Case onto the pole 

in the Inventory Window.  

Note:  To undo the Load Case you added, select Edit > Undo.  

Note:  When using the drag and drop method to add equipment to the Inventory window the 

cursor will change to an invalid  cursor icon when the equipment is dragged over the white 

space in the Inventory. Once the cursor is dragged over the pole in the Inventory window, the 

cursor will change to a plus sign indicating the ability to add the object . To the pole.  O-Calc 

Pro always requires a connection point for all equipment added to the pole, these connection 

points then facilitate the calculation results.  

User Catalog Functions  

Adding a Subfolder  

To add a subfolder to the User Catalog, complete the following steps:  

1. Right click on the User Catalog folder you want to create a subfolder for.  

  

2. Select Add Subfolder.  
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3. Enter a catalog subfolder Name.  

  
4. Select OK.  

  
Note: Undo is not available.  

Note:  Once a subfolder has been added to the User Catalog additional folders can be added to 

that subfolder by selecting the Add button  or by right clicking on the subfolder and 

selecting Add Subfolder.   

Removing a Subfolder  

To remove a User Catalog subfolder, complete the following steps:  

1. Select the User Catalog folder to be removed.  

  

Note: The selected User Catalog folder can also be removed by right clicking on the folder and 

selecting Remove (name of the folder).  

3. Select Yes to permanently remove the selected folder.  

Note: There is no undo for this operation.  

Renaming a Subfolder  

To rename a User Catalog subfolder, complete the following steps:  

1. Right click on the User Catalog folder to be renamed.  

2. Select Rename Folder.  

2.   Select the  Remove   button  .   
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3. Name the selected folder.  

  

4. Select OK.  

  
Note: There is no undo for this operation.  

Adding Equipment to a Subfolder  

To add equipment to a User Catalog subfolder, complete the following steps:  

1. Right click on the User Catalog subfolder that equipment will be added 

to.  

2. Then select the equipment to be added from the equipment list.  
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Note: Only one piece of equipment can be selected at a time.  

   

Note:  Available tabs are dependent on corresponding equipment displayed in your catalogs or 

Inventory Window.  

3. To add equipment from one of the Catalog tabs or the Inventory tab select 

the appropriate tab and select the equipment you want to add.  

  

Note: For additional information on catalogs or the Inventory Window see Working With the 

Catalog Window or Working With the Inventory Window.  

4. Select the Attribute Values tab to modify any attribute values. Click OK.  
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Note:  There is no undo for this operation.  To delete equipment from a User Catalog folder, see 

Deleting Equipment in a Subfolder.   

Equipment can have several attachments (Example:  A crossarm can have insulators and 

spans attached to it).  To add additional attachments to equipment, complete the following 

steps:  

5. Right click on the equipment you want to add additional equipment to.  

6. Select Add Element and select the equipment to be added from the 

equipment list.  

   
Note: If multiple pieces of equipment are displayed in the list only one piece of equipment can 

be selected at a time.  
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Note:  Available tabs are dependent on corresponding equipment displayed in your catalogs or 

Inventory Window.  

7. To add additional equipment from one of the Catalog tabs or the 

Inventory tab select the appropriate tab and select the equipment you want 

to add.  



 Osmose O-Calc® Pro 7.0.1                                    Confidential  User Guide  

 106                   ©2024 Osmose Utilities Services, Inc.  

Note: For additional information on catalogs or the Inventory Window see Working With the Catalog 

Window or Working With the Inventory Window.  

8. Select the Attribute Values tab to modify the equipment’s attribute 

values.  

9. Select OK.  

   

Note: To add additional attachments to equipment complete steps 6 –10.  

Note: There is no undo for this operation.  To delete equipment from a User Catalog folder, see 

Deleting Equipment in a Subfolder.  

Edit Equipment Attributes in a Subfolder  

To edit equipment attribute(s) in a User Catalog subfolder, complete the following steps:  

1. Right click on the equipment whose attribute(s) you want to edit.  

2. Select Edit (equipment display name).  

     

Note: For a complete list of the editable icon’s descriptions see Editing Equipment Attributes.  

3. Complete your edits to the equipment attributes. Click OK.  

  
Note: Certain attributes are only editable in Administrative User Mode. There is no undo for this 

operation.  
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Changing the Display Descriptions  

To change the description that displays next to equipment icon in a User Catalog subfolder, 

complete the following steps:  

1. Right click on the equipment you want to change the display description of.  

2. Select Description of (equipment display name).  

   

3. Enter the Description you would like to be displayed.  

  
Note:  Select Clear to clear the Description field and reset it to the default value.  

4. Select OK.  

  
Note:  There is no undo for this operation.  

Deleting Equipment in a Subfolder  

To delete equipment in a User Catalog subfolder, complete the following steps:  

1. Select the equipment to be deleted.  

  

  

2. Select the Remove button .  
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Note: The selected equipment can also be removed from the subfolder by right clicking on the 

subfolder and selecting Remove (equipment display name). Or by using the Delete key on your 

keyboard.  

Note:  There is no undo for this operation.  

Working in the 3D View  

About 3D View   

The 3D View is a three-dimensional interactive image of the Inventory Window.  As 

equipment is added to the pole in the Inventory the 3D View is automatically updated with 

those changes.    

Structures can also be created or edited in the 3D View and automatically added in the 

Inventory.  

Note: Any object selected in the Inventory Window is rendered in the 3D View in the color yellow.   

  

Interacting with the 3D View Display   

The 3D View provides several ways to reposition the 3D View to better analyze the pole 

and the objects attached to the pole. You can use the mouse wheel to interact with the 3D 

View.   

Mouse Wheel  To zoom in or out scroll the mouse wheel forward or 

backward.   

Right Mouse Click  Click and hold down the right mouse button to pan 

the 3D View to the left, right, up or down, and orbit 

around the camera look point.  

Left Mouse Click  Click and hold down the left mouse button to 

either rotate the 3D View or move the 3D View 

vertically up and down.  Left mouse button click 

and moving mouse left-right will rotate the 

image.  Left mouse button click and moving 

mouse up or down will vertically move the 

viewing perspective of the 3D View down or up.    
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Invert Mouse Wheel  Inverting the mouse wheel changes the zoom in/out 

movement of the mouse wheel.  

To invert the mouse wheel, go to Options > 

Misc. Options > User Interface Conventions > 

Invert Mouse Wheel.  

 Invert Left Mouse  To invert these movements, go to Options > Misc.  

 in 3D X or 3D Y  Options > User Interface Conventions.   

Invert Right Mouse  To invert these movements, go to Options 

> Misc. in 3D X or 3D Y  Options > User Interface Conventions.  

The “R” button Resets the isometric view of the  

 structure in the 3D View.  

The “B” button displays a Birdseye view of the  

 structure in the 3D View.  

The grey button between the R and B buttons  

 provides save, copy, print options of the 3D View.  

  

  
The All Types menu for a list of span types which 

can be toggled off/on individually or All On/All Off, 

to narrow the scope of data displayed.  
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The Spans 2X menu for render sizes which display 
various thicknesses used to enhance the 3D View of 

spans; 1X, 2X, 4X, 8X, 16X.  

  

  

  

  

  

  

  

  

3D View Display Options  

  

The 3D View offers tools to review and interact with the 3D image. Options can be enabled 

or disabled by clicking on them (toggle on/off). Options displaying a check mark icon are 

enabled.   

  

Camera Options in 3D View  
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Camera  Additional Light Source. The Additional Light Source is used to 
brighten the 3D View display. Select to toggle on.  

  

Mouse Tracking Rates. The Mouse Tracking Rates allows for 
greater control of mouse movement. Mouse response rates can 

differ, use these controls to slow down or increase the mouse 

tracking rates.   

  

Use Alternate Control Scheme. The Alternate Control Scheme is 

enhanced to make navigating from pole to pole easier in the 3D 
View, using Line Design mode. This differs from the default 

cylindrical orbit controls used in the 3D View for single pole 

navigating.  

Note: For details regarding the Alternate Control Scheme reference   
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Labels  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

Label Elements in 3D View.  The Label 

Elements in 3D View option displays equipment 

names for each object added to the pole.  

Measure Cursor.  The Measure Cursor option 

displays the height for all the elements as you 

move the mouse along the pole in 3D View.  

Show Damage and Decay Markers. The Show 

Damage and Decay Markers option displays 

damage and decay markers in the 3D View.  

Show Sub-Damage and Decay Markers. The 

Show Sub-Damage and Decay Markers option 
displays sub-damage and decay markers in the 

3D View.  

Display Wind Direction Arrow.  The Wind 

Direction Arrow displays the worst possible 

wind angle.  

  
Note:  You can override what displays for the Wind 

Direction by selecting the Load Case that is attached 

to the pole and enabling Override Wind.  

Display Wind Pressure.  The Display Wind 

Pressure option displays the wind pressure on 

the wind direction arrow.   

Display Heights/ Ruler.  The Display Heights/ 

Ruler option displays a ruler in the 3D View 
displaying 5-foot increments beginning at 

ground level to the top of the pole.  

Show Pole Label.  The Show Pole Label option 

shows the Pole Number at the top of the pole in 

the 3D View.  

Show Messenger Only for 

Bundles  

The Show Messenger Only for Bundles option 

allows only the messenger to display in the 3D 

View for communication bundles.  

Height Filtering  The Height Filtering option filters the objects 

that display in the 3D view according to height.  

Angle Filtering  The Angle Filtering option filters the objects that 

display in the 3D view according to an angle.  
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Visualization Path 

Bars:  

  

Ghost Pole:  

  

Render Deflection Path Bars.   The Deflection 

Path Bars displays the amount the pole is 

deflecting (bending).   

Note:  If Render Deflection Path Bars is enabled 

then Render Deflection Ghost Pole cannot be 

enabled.  Only one of these options can be enabled at 

a time.   

Note:  If Auto Capacity Summary is disabled you will 

need to manually update the Capacity Summary in 

order to update the Render Deflection Path Bars 

calculation.  For additional information on the 

Capacity Summary see Working With the Capacity 

Window .   

Render Deflection Ghost Pole.  The Render 
Deflection Ghost Pole shows the amount the 

pole is deflecting (bending) as a ghost of the 

existing pole.   

Exaggerate Ghost Radius.  The Exaggerated 

Ghost Radius exaggerates the Deflection Ghost 

Pole view.   

Note:  The Exaggerated Ghost Radius only works 

with the Render Deflection Ghost Pole option.  

Show Cap Util on Ghost.  Displays the ghost 

pole with a color coded heat map of the capacity 

utilization.  

Render Sweep Visualization. The Render 
Sweep Visualization displays a 2-dimension, 

color coded heat map of the capacity utilization 
of the pole along the length of the pole as well as 

wind direction.  

Sweep Visualization 3D Surface. The Sweep 

Visualization displays a 3-dimention, color 

coded heat map of the capacity utilization of the 

pole along the length of the pole as well as wind 

direction.  

Animate Selected Object 

(Flash)  

Animate Selected Object (Flash).  The 

Animate Selected Object option helps identify, 

in the 3D View, what object has been selected in 

the Inventory Panel.  The selected object in the 

Inventory Panel will change color and flash in 

the 3D View.  
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Show 3D View When Pole 

Opened  

Show 3D View When Pole Opened. The Show  

3D View When Pole Opened option 

automatically displays the 3D View when a pole 

is opened or created.  

Render 3D in Separate Thread  Render 3D in Separate Thread.   

Image Brush Opacity  Image Brush Opacity. The Image Brush 

Opacity allows a user to manually modify the 

opacity value.   

  

Note: All options can be enabled/disabled by simply clicking on them (toggle on/off) again. Any 

enabled option displays the check mark symbol indicating it is on.   

  

Creating a New Pole Using This Pole as Template  

To create a new pole as template in the Inventory Window using the current pole in the 3D 

View, complete the following steps:  

1. Right click the pole in the 3D View and select New > Pole Using This Pole as 

Template.  

  
Note:  The pole is automatically highlighted in yellow once selected. Undo is not available when 

adding a pole using this pole as template feature.  

Creating a New Pole Version of This Pole  

As mentioned above there are two ways to create an additional version of the pole model 

within an existing pplx file. To create a new version of the pole in the Inventory Window 

using the current pole in the 3D View, complete the following steps:  

2. Right click the pole in the 3D View and select New > Version of This Pole.  

Note:  The pole is automatically highlighted in yellow once selected. Undo is not available.  
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Setting the Depth of a Pole  

To set the depth of a pole, complete the following steps:  

1. Right click the pole in the 3D View.  

2. Select the Setting Depth of (Pole display name).  

  

3. Select the Mode from the drop-down list and enter the Depth in feet. Click 

OK.  

  
Note: The Depth in Feet field will automatically display the default pole depth when initially opened.  

Setting the Above Ground Length in Feet of a Pole  

To set the length of a pole, complete the following steps:  

1. Right click on the Pole you want to set the length for.  

2. Select the Set Length and Depth option.  

3. Select Above Ground Length of (Pole display name).  
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4. Select the Mode from the drop-down list and enter the AGL in Feet.  

  

5. Select OK.  

Note: To undo the AGL Length change, select Edit > Undo.  

Setting the Length in Feet of a Pole  

To set the length of a pole, complete the following steps:  

1. Right click on the Pole you want to set the length for.  

2. Select the Set Length and Depth option.  

3. Select Length of (Pole display name).  

  

4. Select the Mode from the drop-down list and enter the Length in Feet.  

  

5. Select OK.  

Note: To undo the Length change, select Edit>Undo.  

  

Adding Equipment to a Pole  

To add equipment to a pole in the 3D View, complete the following steps:  

1. Right click the pole in the 3D View.  

2. Select the Add Element option.  

3. Select one piece of equipment from the list of available choices.  

Note: Only equipment which can be added to a pole appear in list of choices.  
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Note: Only one piece of equipment can be added at a time.  

  

Note:   Available tabs are dependent on corresponding equipment displayed in your catalogs or 

Inventory Window.  

  

4. To add a crossarm from the Catalog tabs or the Inventory tab select the 

appropriate tab and select the crossarm you want to add.  
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Note: For additional information on catalogs see Working With the Catalog Window.  

5. Select the Attribute Values tab to modify the crossarm’s attribute values.  

6. Click OK.   

Note: To remove the added equipment, select Edit > Undo.  

Equipment can have several attachments (Example:  A crossarm can have insulators and 

spans attached to it).  To add additional attachments to equipment, complete the following 

steps:  

7. Right click on the equipment in the 3D View that you want to add additional 

equipment to.  

8. Select Add Element and select the equipment to be added from the equipment 

list.  

  
Note: Only one piece of equipment can be selected at a time.  

  
Note:  Available tabs are dependent on corresponding equipment displayed in your catalogs or 

Inventory Window.  
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9. To add an insulator from one of the catalog tabs or the Inventory tab select the 

appropriate tab and select the insulator you want to add.  

10. Select the Attribute Values tab to modify the insulator’s attribute values.  

Note: For additional information on catalogs see Working With the Catalog Window.  

11. Select OK.  

Note: To add additional equipment complete steps 1 – 9.   

Adding a Span Bundle to a Pole  

To add a span bundle to an attached insulator in the 3D View you first need to create the 

span messenger wire.  To create the span messenger wire, complete the following steps:  

1. Right click on the insulator in the 3D View that you want to add a span bundle 

to and select Add Element > SpanBundle.  

  
Note: Only one Span Bundle can be added at a time.  
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Note: Available tabs are dependent on corresponding Span Bundles displayed in your catalogs or 

Inventory Window.  

2. To add a Span Bundle from one of the Catalog tab or the Inventory tab select 

the appropriate tab and select the Span Bundle you want to add.  

Note: For additional information on catalogs see Working With the Catalog Window.  

3. Select the Attribute Values tab to modify the Span Bundle attributes.  

4. Select OK.  

Note: To undo additions, select Edit>Undo.  

Once the span bundle messenger wire has been created you need to actually add the spans.  

Complete the following steps to add spans to the messenger wire:  

5. Right click on the Span Bundle in the 3D View.  

6. Select Add>Span.  

  
Note: Only one Span can be added at a time.  
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Note: Available tabs are dependent on corresponding spans displayed in your catalogs and Inventory 

window.  

7. To add an insulator from one of the catalog tabs or the Inventory tab select the 

appropriate tab and select the insulator you want to add.  

Note: For additional information on the Catalog Window see Working With the Catalog Window.  

8. Select the Attribute Values Tab to modify the Span attributes.  

9. Select OK.  

Note: To add additional spans to the span bundle complete steps 5 – 9.  

Note: To undo additions, select Edit>Undo.  

Working with the Span Bundle Editor  

To quickly and efficiently edit the spans positions or add additional spans to a span bundle 

use the Span Bundle Editor.  To open the Span Bundle Editor, complete the following steps:  

1. Right click on the Span Messenger wire you want to edit.  

2. Select Bundle Editor for (bundle display name).  

 

  

  

  

  

  

  

  

  

  

Toolbar   

Span bundle  
display window   

Span Detail  
Table   

Span bundle  
messenger wire   

Each circle  
represents a  
span within the  
span bundle   

Span bundle  
information   

Selected spans  
information   
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Span Bundle Editor Menu  

The Span Bundle Editor toolbar menu provides you with a variety of operations and 

options.  

  

  

File. The following options are 

available from the File menu:  

Reset View. Select the Reset View 

option to set the Span Bundle 

Editor back to the default view.  

Save.  Select the Save option to 

save any changes or additions.  

Exit. Select the Exit option to close 

the Span Bundle Editor.  

  

Edit. The following options are 

available from the Edit menu:  

Add Span.  Select the Add Span 

option to add a span to the span 

bundle.  

Layout Vertical. Select the Layout 

Vertical option to automatically 
reposition all the spans vertically 

under the messenger wire.  

Layout Pack Under. Select the 
Layout Pack Under option to 

automatically reposition all the 

spans under the messenger wire.  

Layout Pack Around. Select the 
Layout Pack Around option to 

automatically reposition all the 

spans around the messenger wire.  

Auto Pack. Select the Auto Pack 

option to have the spans as close as 

possible given their size.  

Un-Collide.  Select the Un-Collide 

option to position the spans so they 

are not overlaid.  

Dynamic Un-Collide. Select the 

Dynamic Un-Collide option to 

automatically un-collide the spans 

while you’re dragging them into 

position.  
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Circumscribe.  Selecting the 

Circumscribe option tells you what 

the minimum circle would be that 

all the spans and messenger wire 

could fit into.  

  
Show Labels. Select the Show 

Labels option to display the spans 

descriptions next to each span in the 

bundle.  

Adding a Span to a Span Bundle  

To add a span to the span bundle using the Span Bundle Editor, complete the following 

steps:  

1. Select Edit > Add Span.  

  
Note: Only one span can be added at a time.  

  

Note: Available tabs are dependent on corresponding spans displayed in your catalogs or Inventory 

Window.  
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2. To add a span from the catalog tabs or the Inventory tab select the appropriate 

tab and select the span you want to add.  

Note: For additional information on the Catalog Window see Working With the Catalog Window.  

3. Select the Attribute Values tab to modify the Span attributes.  

4. Select OK.  

Note: The span is automatically added to the span bundle and is displayed in the Span Bundle 

Editor.  

Note: There is no Undo option available.  Select File>Exit to close the Span Bundle Editor without 

saving any modifications that have been completed.  

5. Select File > Save.  

Repositioning Spans in a Span Bundle  

The Span Bundle Editor offers three ways you can reposition spans within the editor.  To 

reposition span(s) in the span bundle using the Span Bundle Editor, use one of the 

following options:  

A. Select Edit and select a layout option from the Edit menu.  

B. Left click a span in the Span Bundle Display window and drag the span to a 

new location.  

C. Manually enter a horizontal and/or vertical value for a specific span in the 

Span Detail Table.  

Editing Spans in a Span Bundle  

To edit span attributes from within the Span Bundle Editor, complete the following steps:  

1. Right click on the span in the Span Bundle Display window.  

2. Select Edit Span from the drop-down menu.  

  

3. Complete any modification to the Span Bundle attributes.  

  

4. Select OK.  

Note: There is no Undo option available.  Select File > Exit to close the Span Bundle Editor without 

saving any modifications that have been completed.  
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5. Select File > Save.  

Deleting Spans in a Span Bundle  

To delete a span within the Span Bundle Editor, complete the following steps:  

1. Right click on the span in the Span Bundle Display window.  

2. Select Delete Span from the drop-down menu.  

  

3. Select Yes to the confirmation message.  

Note: There is no Undo option available.  Select File>Exit to close the Span Bundle Editor without 

saving any modifications that have been completed.  

4. Select File > Save.  

  

Types of Guying Options  

Adding a Down Guy to a Pole using Auto-Guy  

To properly guy a structure in O-Calc® Pro an Auto-Guy function has been added.  The 

AutoGuy functionality uses the worst wind direction calculation to determine the lead angle 

placement of the anchor. And the pole deflection is used to determine the lead length of the 

Anchor.  

To use the Auto-Guy feature, you must first select an anchor and guy assembly to be the 

default auto-guy assembly. To set up a default auto-guy assembly, go to a Master or User 

Catalog and right click on a guy and anchor assembly. Select the Set as the default “Auto-

Guy” assembly option.  

  

   

  

The Auto-Guy function also allows you to manually change Anchor and/or Guy attributes 

such as the lead angle, lead length, attachment height, etc. to ensure the structure is guyed 

properly.  To use the Auto-Guy function in the 3D View, complete the following steps:  

  

1. Right click the area on the pole where you want the Down Guy placed. The 

point at which you right click on the pole automatically assigns the Install 
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Height for the guy, which can be edited in the Data Entry, when selecting the 

Guy wire.  

  

2. Select the Auto-Guy option.  

  
Note: If a default Auto-Guy Assembly has not been set a warning message will display that the 

system will use the first assembly in the catalog.  To set a default Auto-Guy Assembly see Set a 

Default Auto-Guy Assembly.  

3. Verify and edit any Anchor attributes. Select OK.  
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Note: The deflection of the pole is used to set the lead length.  The anchor and guy wire are 

automatically added to the pole.  The lead angle is picked based off the worst wind angle on the pole 

before the anchor/guy assembly was added.  

Adding an Extra Down Guy to an Anchor  

To automatically add extra down guys to an anchor already displayed in the 3D View, 

complete the following steps:  

1. Select the Anchor that you want to add an additional down guy to in the 3D 

View.  

2. Right click the area on the pole where you want the additional down guy 

placed.  
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3. Select Extra-Guy.  

  
Note: Extra guy wires can be added to existing anchors as needed, you must select the anchor first.  

  

Modifying a Down Guy into Another Type  

The Type attribute gives users the ability to change the guys type. Guy wires may be 

pretensioned to a desired value before environmental loads are applied.  

1. To change a down guy into another type of guy, complete the following steps:  

2. Select the Guy Wire in the Inventory or 3D View  



Osmose O-Calc® Pro 7.0.1                                Confidential                                                                User Guide  

©2024 Osmose Utilities Services, Inc.                                                                                                  129  

3. In the Data Entry, select the drop-down arrow next to the “Type” Attribute  

  

4. Select the guying type you would like to use.   

  

The Type attribute gives the user a number of options for the type of guying being used.  

Down (Down Guy)  A down guy is modeled as an anchor set at a 

given distance and angle away from the 

pole, with one or more attached guy wires.   

Span/Head (Span Guy)  A span guy, also called a stub guy, or a guy 

to a stub pole, models a blue “stub pole” 

and one or more associated guy wires.   

Sidewalk (Sidewalk Guy)  A sidewalk guy models an anchor set at a 

given distance and angle away from the pole 

with one or more attached guy wires 

connected to one or more struts.   

  

Use of this type creates a new filter option 

in the data entry panel called Sidewalk.   

Crossarm (Crossarm Down Guy)  A crossarm guy models a standard down 

guy, with the ability to make the attachment 

point a crossarm instead of the pole.   

CrossarmSpan (Crossarm Span 

Guy)  

A crossarm Span guy models a standard 

span/head guy, with the ability to attach the 

guy wire to a crossarm instead of the pole.   
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Pushbrace  A pushbrace is a pole that supports the 

structure being modeled, rather than using 

an anchor/guy wire combination.   

  

Note: The pole height and class of the 

pushbrace pole cannot be set.   

Truss (Truss Guy)  A truss guy models a guy wire with several 

attachment points on the pole, rather than an 

attachment point connected to an anchor on 

the ground. This model also includes two 

struts.   

  

Modifying the Guy Wire Tension  

Guy wires may be pre-tensioned to a desired value before environmental loads are applied.  

  

1. Select the Guy Wire you want to change the Tension value for.  

2. In the Data Entry change the filter from Standard  to Tension.  

   
3. Change the Tension Mode attribute drop-down menu from Calculated to Manual.  

   
4. Enter the Man Tension attribute value as desired.  
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Merging Struts (Strut Compression)  

O-Calc ® Pro offers the ability to combine comparable struts into one strut for analysis as a 

single entry.  The struts need to be placed on the pole on the same anchor and at almost the 

same height, angle, and length before they can be combined.  Struts are combined by 

default with the Merge Like Struts attribute set to Yes for multiple wires on the same strut.  

To unmerge (separate) the comparable struts, complete the following steps:  

1. Select the guys you would like to unmerge in the Inventory Window.  

Note: Multiple guys can be selected concurrently by holding down the ctrl key to select more than 

one guy that is out of sequence.  If the guys are next to each other hold down the shift key to select 

them.  

   

2. In the Data Entry window toggle the Merge Like Struts attribute to Yes.  
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Note: All windows within O-Calc® Pro are automatically recalculated and updated to reflect the 

attribute selection.   
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Note: O-Calc ® Pro provides a Strut Evaluation Summary so you can easily evaluate the load 

applied to a sidewalk guy strut arm by the guy or guys impinging upon it.  To display the Strut 

Evaluation Summary, see Viewing the Data in Reports.  

  

Over-Tensioning   

O-Calc ® Pro offers the ability to set a minimum tension on a guy brace regardless of the 

environmental loading. This attribute is called Over-tension and is found on the Guy Brace 

object. This attribute can be edited in the data entry panel as shown below.  

  

  
  

Note: This field will not apply any tension to the guy if the regular pole loading is greater than the 

value the user sets. If the pole loading doesn’t apply greater tension than the Over-tension value, the 

Overtension value will be applied.   
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Modifying the Span Drop or Rise  

To modify the end, drop or rise of a span, complete the following steps:  

1. Select the span in either the Inventory or 3D View  

2. In the Data Entry panel, enter a value under the Edit Drop/Rise (Ft) attribute  

  
*Note: When modifying the height of the pole, it is also possible to maintain the set heights of the 

opposite ends of the span created by entering an End Drop/Rise.   

  

Maintaining Span Height after Pole Modification  

To ensure the attachment heights of the opposite end of a span are maintained if the height 

of the pole is changed, follow the following steps:  

1. Select the pole in the Inventory or 3D View  

2. Right-Click on the pole and select the Substitute option.  

  

3. Select the new pole from the available Catalogs and click OK.  
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4. In the Height Adjustments Window, check the box Keep Span End Heights.  

5. Click OK.  

 

To change the description that displays next to a pole or attached equipment, complete the 

following steps:  

6. Right click on the pole or attached equipment you want to change the display 

description of.  

7. Select Description of (pole or equipment display name).  

  

8. Enter the Description you would like to be displayed. Click OK.  

  

Change the Display Description    
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Deleting Attached Equipment   

To delete equipment that is attachment to the pole in 3D View, complete the following 

steps:  

1. Right click on the attached equipment to be deleted.  

2. Select Delete (pole or equipment display name).    

  
Note: To undo the deletion, select Edit>Undo.  

Substituting Attached Equipment  

To substitute attached equipment in the 3D View, complete the following steps:  

1. Right click on the attachment you would like to substitute.  

2. Select Substitute (equipment display name).  
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3. In the Substitute Crossarm Window, select the equipment needed, click OK.  

  
Note:  Available tabs are dependent on corresponding equipment displayed in your catalogs or 

Inventory.  

4. To substitute equipment from the catalog tabs or the Inventory tab select the 

appropriate tab and select the equipment you want to use as a substitute.  

Note: For additional information on the Catalog Window see Working With the Catalog Window.  

5. Select the Attribute Values tab to modify the equipment attributes.  

6. Select OK.  

Substituting a Pole   

To substitute a pole in the 3D View O-Calc® Pro provides you with three options.  You can 

either manually select the substitute pole, select the substitute pole from the Catalog 

Window or you can use the Pole Solver option to help you select the substitute pole.  The 

pole solver option will display the minimum pole class and the estimated capacity that 

would be used based on the pole’s current load.  To substitute the current pole, complete the 

following steps:  

1. Right click on the pole you would like to substitute.  
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2. Select Substitute (pole’s display name).  

  

  
Note: Available tabs are dependent on corresponding poles displayed in your catalogs or Inventory 

Window  

3. Use one of the following methods to select the substitute pole you want:  

A. Manually select the substitute pole attributes using the Attr Values or 

Standards tab.  

B. To select the substitute pole from a Catalog, select the appropriate tab and 

select the pole you want to use as a substitute.  The attributes can still be 

modified if needed.  

Note: For additional information on the Catalog Window see Working With the Catalog Window.  
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C. Select the Use Pole Solver button  to have O-Calc® Pro  

automatically select the minimum Pole Class that would provide you with a 

passing pole.  

4. Select OK.  

Note: The Estimated Capacity percentage will automatically be updated dependent on your attribute 

selections.  

If there are attachments already on the pole the Height Adjustment window will automatically be 

displayed.  The Height Adjustment window allows you to adjust the substitute poles depth and the 

height of the attachments relative to groundline or the tip of the substitute pole.  

  

5. Modify the Setting Depth for the pole if required.  

6. Maintain Distance from Tip or Maintain Height from Groundline for 

attachments heights as needed.  

7. Select All Tip Relative or All GL Relative for attachment heights as needed.  

8. Select OK.  

Note: To undo the substitution change, select Edit > Undo.  

Create a New Version of the Existing Pole  

While working with a pole in the 3D View it may be beneficial to compare multiple 

versions of the pole simultaneously.  O-Calc® Pro provides the ability to create multiple 

pole versions.  

To create a new version of the existing pole in the 3D View, complete the following steps:  

1. Right click on the Pole in the 3D View that you would like to create another 

version of.  

Note: The pole will automatically be highlighted in yellow once selected.  

2. Select New > Version of This Pole.  
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Note: To remove the new version, select Edit > Undo.  

   

The new version automatically becomes the active version in the 3D View.  The active 

version of a pole is always outlined in red  in the Inventory Window to easily identify 

which pole’s data is being displayed in O-Calc ® Pro.  

When saving a pole, all the versions of the pole will be saved at that time.   

Repositioning Object in 3D View   

Objects can be repositioned from within the 3D View by selecting the object to be 

repositioned and using the following shortcut keys:   

Angle  Holding down the “A” key and selecting an object 

allows you use the mouse to rotate the object to 

reposition it.   

Vertical  Holding down the “V” key and selecting an object 

allows you to use the mouse to reposition the object 

up or down.   

Horizontal  Holding down the “H” key and selecting an object 

allows you to use the mouse to reposition the object 

to the left or the right.  (Use the “G” key option if 

the front of the object is facing you).   

Reverse Horizontal  Holding down the “G” key and selecting an object 

allows you to use the mouse to reposition the object 

to the left or the right.  (Use the “H”  keys if the 

back of the object is facing you)  

  



Osmose O-Calc® Pro 7.0.1                                Confidential                                                                User Guide  

©2024 Osmose Utilities Services, Inc.                                                                                                  141  

Resetting the Camera Position in 3D View   

To reset the 3D View back to the default view, complete the following steps:   

1. Select View > 3D View > Reset Camera Position.  

  

The 3D View is automatically reset back to the default 3D view.  

Note: The camera position can also be reset by clicking on the R button in the 3D View. To see the 

Birdseye view, click the B button in 3D View.  

Changing to an Overhead View   

To change the 3D View to an overhead view or “Bird’s Eye View”, complete the following 

steps:   

1. Select View > 3D View > Bird’s Eye View.  

  

The 3D View is automatically changed to the overhead view.  

Note: When the Bird’s Eye View option is selected, basic movements such as rotating and panning 

are enabled.   

Saving the 3D View    

To easily access the current 3D View at a later time you can save the current 3D View to a 

.png file or place the 3D View on the clipboard.   

Place the 3D View on the Clipboard   

To place your current 3D View on the clipboard, complete the following steps:  

1. Select View > Save 3D View to > Clipboard.  
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Note: A Copy 3D View to Clipboard option is also available by holding down the ctrl key and right 

clicking on the 3D View background display.  

Save the 3D View   

To save your current 3D View to a .png file, complete the following steps:  

1. Select View > Save 3D View to > Image File.  

  
Note: To adjust the size of the 3D View image being saved select Saved Image Size.  

Note:  The Save 3D View to File option can also be accessed by holding down the ctrl key and right 

clicking on the 3D View background display.  

2. Browse to where you want to save the 3D View .png file and select Save.  

3. Select OK to the confirmation message.  

  

Print the 3D View   

To print the current 3D View, complete the following steps:  

1. Select View > Save 3D View to > Print 3D View.  

  
Note: The 3D View is automatically printed to your default printer.  

Note:   The Print 3D View option can also be accessed by holding down the ctrl key and right 

clicking on the 3D View background display.  

Filtering the 3D View   

To filter the 3D View so that only the objects that are expanded in the Inventory Window 

display in the 3D View, complete the following steps:   

 

  

1. Collapse the desired objects in the Inventory by clicking on the minus button.  

    

  
These objects are  
collapsed in the  
Inventory Window  
but are displayed  
in the 3D View.   
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2.   Select  the  Filter   button      in the Inventory Window.   
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  or 

select the 

sunglasses 

 

3.   To turn the  filtering option off   deselect the Filter button   

button       in the 3D View > Reset All Filters.   
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Note:  The filtering option can also be turned off by selecting View > Reset All Filters or select the 

Filtering Notification button and selecting the Reset All Filters option.  

   
Working with the Capacity Window  

Understanding the Capacity Window  

The Capacity Window displays a summary of the active pole’s capacity.  The summary 

provides you with a quick and easy to understand overview of the active pole capacity 

information.  The Capacity Window can be displayed in either a metered format, a more 

detailed summary view, or explicit for GO95 load cases, a pole factor of safety view.  

About the Capacity Meter Display  

The Capacity Meter calculates the load capacity for the active pole.  The meter view 

displays the percent of the Pole Capacity, the Pole Stress and the guying adequacies.   

 

  

Enabling the Capacity Meter Display   

To enable the Capacity Meter Display, complete the following steps:  

1. The Capacity Meter is the default display option. There are various display 

options, which are controlled by selecting Options > Capacity Display 

options.  

  

      

  
  

  

Pole Stress  
Chart   

% of Pole  
Capacity  
Gauge   

Guy Status   

% of   
Allowed  
MCU  
Results   
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Note: The Capacity Meter is one of the three options.  A check mark displays next to the menu option 

that is currently active. Only one of the options can be displayed at a time.  

Note: All options can be enabled/disabled by simply clicking on them (toggle on/off) again. Any 

enabled option displays the check mark symbol indicating it is on.   

  

Understanding the Capacity Meter Display   

The following tables describe the default color representations in the Pole Stress Chart and 

the Percent of Pole Capacity Gauge.   

 Pole Stress Chart              % of Pole Capacity Gauge  

Display 

Color  

Description  Display 

Color  

MCU  

Thresholds  

Description  

Blue  0% Pole Stress  Green  < 80%  Acceptable 

Capacity  

Green  …  Yellow  80% to 89.9%  Near  

Capacity  

Yellow   50% Pole Stress  Orange  90% to 99.4%  Near  

Capacity  

Orange  …  Red  99.5% or above  At or Over 

Capacity  

Red  100% + Pole Stress        

Note:  Color Legend is also available from the Tools>View Color Legend.  

Note: The Capacity Meter display color schema can be changed by selecting a color schema from 

the Options>Visualization Color Scheme menu.  

          Acceptable Pole Capacity Example     Failed Pole Capacity Example  
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About the Numeric Capacity Display   

The Numeric Capacity Display calculates and displays details regarding the Maximum and 

Groundline moment, capacity utilizations, wind direction and guying adequacies.    

   
Note: The appearance of the Numeric Capacity Display can be change to a flat style by selecting 

Options > Misc Options > Flat Visual Style.  

Enabling the Numeric Capacity Display   

To enable the Numeric Capacity Display, complete the following steps:  

1. Deselect Options > Capacity Display > Capacity Numeric Display.  
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Enabling the Factor of Safety Display   

To enable the Factor of Safety Display for use with GO 95 Load Cases, complete the 

following steps:  

2. Deselect Options > Capacity Display > Factor of Safety Display.   

  
Note: All options can be enabled/disabled by simply clicking on them (toggle on/off) again. Any 

enabled option displays the check mark symbol indicating it is on.   

  

  

  

Capacity Window Menu Display Options   

Right clicking on the Capacity Window background provides several options.  

Copy Image.   Select the Copy Image option to 

copy the current Capacity Window as an image to 

the clipboard so that the image of the Capacity 

Window  

   can be pasted directly into other applications such as  

Microsoft Word, E-Mail, and Notepad etc.                       

Copy Data.  Select the Copy Data option to copy the  
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Capacity Window data to the clipboard so that 

the Capacity Window data can be pasted directly 

into other applications such as Microsoft Word, 

E-Mail, etc.  

Cancel. Select the Cancel option to close the 

Capacity Window menu option pop-up without 

taking any action.  

Automatically Updating the Capacity Window   

The Capacity Window is automatically updated each time a change is made to the active 

pole, by default, to disable the automatic calculation toggle it off complete the following 

steps:  

1. Select Options > Capacity Display > select Auto Capacity Summary.  

  

  

Note: All options can be enabled/disabled by simply clicking on them (toggle on/off) again. Any 

enabled option displays the check mark symbol indicating it is on.   

Note:  To change the idle time interval between updates, see Set the Idle Time Interval.   

Manually Updating the Capacity Window   

If the Auto Capacity Summary option is disabled, you can manually update the Capacity 

Window by completing the following steps:  

1. Select View > Update Capacity Summary.  

  

2. Or you can manually update the Capacity Window by clicking the red Ready 

button.  
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Working with the Measure Window  

Measure Window Overview  

The Measure Window allows you to take measurements from images using Digital 

Measurement Technology (DMT).  You can efficiently measure equipment attachment 

heights, arbitrary lengths, conductor diameters, and angles. With DMT we can learn a poles 

height above ground line and the resulting setting depth using an image.  

Before any measurements are taken from an image the calibration needs to be set for that 

image.  See Setting the Calibration.  As each measurement is done, the value is 

automatically updated in the Inventory Window, 3D View, and Data Entry Panel. Labels are 

also placed on the image.  

The camera’s lens calibration needs to be set before any measurements can be taken.  To set 

a camera’s lens calibration see Working with the Lens Calibration Tool.  

Working with Images in the Measure Window   

Selecting Images to Display   

To select the images needed to complete measurements, complete the following:  

1. Select Edit > Pole Images > Select Images.  

Note: Images can only be added after a pole has been added to the Inventory Window.   
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2. Select the image path by clicking the ellipsis button and navigate to where the 

images are for the current pole. 

3. In the Select Folder window, select the folder that contains the images you 

want. Click the Select Folder button, the images will load in the Select Pole 

Images window.   

  

4. Select the images to be associated to the current pole. Click OK.  

Note: Hold down the ctrl key to select more than one image out of sequence.  Hold down the shift key 

to select a range of images next to each other.  

Selecting Additional Images to Display  

Additional images can be added to the current pole at any time.    

To select additional images, you need to complete measurements, complete the following 

steps:  

   navigate to the location  
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1. Select Edit > Pole Images > Add Images.  

2. Select additional images from the current Path or click the Ellipsis button to 

navigate to other folders and click the Select Folder button.  

3. In the Select Pole Images window, select the images you want.  

4. Click OK.  

Paste Snapshot as Image  

Some images that need to be used in the Measure Window can be found as embedded 

images rather than standalone files. These can be pasted into the Measure Window as 

snapshots and saved as standalone files. To paste a snapshot as an image, follow these steps:  

1. Take a snapshot of an image and paste it to the clipboard; this can be done 

using a snipping or screen capture tool.  

2. Select Edit >Pole Images > Add Images.  

3. Select Paste Snapshot as Image or Simple Paste or Set Date and Paste.  

  

4. Select the Set Date and Paste option to save the images with a date stamp.   

  

5. In the Measure Window, the copied Image will be available to use in the 

Calibration Process.  
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Add Image URL  

To add an image URL (Universal Resource Identifier), complete the following steps:  

1. Select Edit > Pole Images > Add Image URL. Enter the URI address, click 

OK.  

  
Note: To test that the URL location entered is correct, click the Test button.  

Remove All Images  

To remove all the images that are displayed in the Measure Window for the current pole, 

complete the following steps:  

1. Select Edit > Pole Images > Remove All Images.  

  

2. Select Yes to the confirmation message.  
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Note: To undo the removal of all the images, select Edit > Undo.  

Remove Current Image  

To remove the current image that displays in the Measure Window for the current pole, 

complete the following steps:  

1. Select Edit > Pole Images > Remove Current Image.  

2. Select Yes to the confirmation message.  

Remove All Except Current Image  

To remove all the images except for the currently selected image that displays in the 

Measure Window, complete the following steps:  

1. Select Edit > Pole Images > Remove All Except Current Image.    

2. Select Yes to the confirmation message.  

Print the Images that Display  

To print the images that display in the Measure Window for the current pole, complete the 

following steps:  

1. Select Edit > Pole Images > Print Current Image.  

To print all the images that are displayed in the Measure Window:   

1. Select Edit > Pole Images > Print All Images.  

Current Image as Primary  

The primary image is printed out on the Analysis Report and located at the top of all the 

thumbnail images displayed in the Measure Window. To select the currently displayed 

image as the primary image, complete the following steps:  

1. Select the thumb nail of the image you want to be the primary image.  

2. Select Edit > Pole Images > Current Image as Primary.  

Reload Images   

To reload the images that display in the Measure Window for the current pole, complete the 

following steps:  

1. Select Edit > Pole Images > Reload Image. Or click the button on the far right 

within the Measure tool bar. 

  

Set the Target Type   

Initially when the Measure Window is opened a Target Type is set by default.  The target 

type represents which Calibrated Visual Target (CVT) or Range Survey Pole was used when 

the image was captured.  

Set Default Target Type  

The default target type ‘CVT: White 13 Foot’ displays when you initially open the Measure 

tab, shown in the image below in the upper left corner.  
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To change the default target type, complete the following steps:  

1. Under the Image drop-down menu, select the Set Default Target Type option.  

  

Begin by choosing the target type from the Type drop-down menu; the choices are 

Calibrated Reflectors, Range Pole, or Tip Groundline Mode.  
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2. Within the Type category select the specific target from the choices available.  

3. Click the Select button.  

Change Current Image’s Target Type  

  
To change the target type of only the current image displayed in the Measure Window, 

complete the following steps:  

1. Under the Image drop-down list, select Change Current Image’s Target Type 

from the list. 

2. Select the Type of target that to be used for the current image.  

3. Select the specific target from the list and click Select.   

  

The Image target type can be changed by selecting an option from the dropdown lists 

located on the far right in the Measure tool bar.  
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Understanding the Measure Window  

The Measure Window provides various tools designed to allow the user to complete image 

measurements, review and enhance image data.  

  

  

Measure Toolbar Menu Options  

The Measure toolbar menu provides you with a variety of options. Options appear left to 

right beginning with the Image option and ending with the Reload option. 

 

 

 

  

 



 Osmose O-Calc® Pro 7.0.1                                    Confidential  User Guide  

 158                   ©2024 Osmose Utilities Services, Inc.  

  

Image. The following options are 

available from the Image menu:  

Save Image As. Select the Save 
Image As option to save the current 

image as a variety of file types 

(JPEG, BMP, GIF or PNG).  

Copy Image to Clipboard. Select the 

Copy Image to Clipboard option to 
copy the current selected image to 

the clipboard so that the image can 
be pasted directly to other 

applications such as Microsoft Word, 

E-mail, etc.  

Copy Viewport to Clipboard. Select 

the Copy Viewport to Clipboard 
option to copy the selected image as 

it is currently displayed to the 
clipboard.   The copied image can 

then be pasted directly to other 
applications such as Microsoft Word, 

E-mail, etc. 

Copy Annotations to Clipboard. 
Select the Copy Annotations to 

Clipboard option to copy the 
measure labels from the image. The 

copied annotations can then be 
pasted directly to other applications 

such as Microsoft Word, etc. 

Set Default Target Type. Select the 

Set Default Target Type option to 
select the Calibrated Visual Target 

(CVT) used to get accurate 

measurements.  

Change Current Image’s Target 

Type. Select the Change Current 
Image’s Target Type option to change 

the currently selected (displayed) 

images target type.  

Display EXIF Information.  Select 

the Display EXIF Information option 

to display the metadata in the image.  

 

Photo Edit. Select the Photo Edit 

option to display other applications 

with which to view/edit the image. 
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The following options are available 

from the View menu:  

Magnifier. Click this option to show 
or hide the magnification window.  

With the magnification window 
displayed, move the mouse anywhere 

in the image to view that area in the 

magnification window.    

X Magnification. Select the 

magnification level to use with the 

Magnification Window.  

Smooth. This option is toggled on by 

default to smooth hard edges of the 

image.  

Reset. Click the Reset option to undo 

any display/enhancement options that 

were selected.  

Show Labels. This option is toggled 

on by default to show the results of 

the measured values.  

Show Label Background.  This 

option is toggled on by default to 

show a white background to enhance 

label visibility.   

  
Zoom to Fit. Click the Zoom to Fit 

option to reset the image to its 

original size and fill the image frame.  

  

Bright. Click the Bright option to 

brighten the image.  

  

Dim. Click the Dim option to darken 

the image.  

  

Invert. Click the Invert option to 

invert the colors of the image.  

  
Grayscale. Click the Grayscale 

option to set the image to black and 

white.  
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Contr +  Click the Contr + option to 

set the contrast higher.    

Increasing the contrast will make 

dark tones darker and the light tones 

brighter.  Using the Contrast option 

also affects the sharpness of the 

image.  

  

Contr -  Click the Contr – option to 

set the contrast lower.  

  

Rotate.  Select the Rotate option to 

rotate the image 90 degrees to the 

right or left.  

  
Reload.  Select the Reload option to 

reload the images that display in the 

Measure Window.  

  

The Image Viewer also provides several ways to navigate within the image by providing the 

following tools:  

Mouse Wheel  To zoom in or out move the mouse wheel to 

scroll forwards or backwards.   To pan right 

click.   

Added Images  All images associated with the selected pole 
are displayed as thumbnails in the upper right 
side of the Measure Window.   

Select any thumbnail to change images.  

Navigation Pane  Clicking a point in the Navigation Pane will 

center the image on that point in the Image 

View Window.  

Zoom Scale    

Click various levels on the scale to zoom-in 

or zoom-out to see more details in an image 

or use the roller wheel on your mouse. 
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Measure Modes  

  

Click any Measure Mode to activate the 

measurement task for the selected mode.   
Note: The image must be calibrated first, then the 

other measure modes are available to use.   

  

Setting the Calibration   

When the Measure Window is initially opened, the Calibrate mode is selected by default. 

The image must be calibrated first, then the other measure modes are available to use. To 

perform the Calibration measurement, complete the following steps:   

1. Select the image you want to calibrate.  

Note: When setting the calibration, the cursor will change to a box   enabling you to 

get a precise measurement.  

The Calibrate mode requires 3 – 4 targets be placed on the image, based on the use of the 

CVT (White 13 Foot). The number of targets to be placed varies based on the Target Type 

selected.   

2. Place the mouse cursor box over the red reflective band closest to the base of 

the pole. Begin at the bottom and work your way up as a best practice. Zoom in 

so close that the red reflective band and cursor box are the same size on the top 

and bottom. Zooming in this close increases measurement accuracy.  
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3. Place the cursor box where the first calibration point is 

and click the left mouse button.  A red plus sign “target” 

marks your first calibration measurement.  

  

4. Using the cursor box continue placing the remaining calibration targets at the 

same zoom level. Right click to pan up the CVT in the image and click to place 

targets at each red reflective band.  

Note:  If you need to estimate one of the calibration points due to vegetation or an obstruction 

limiting your view of a red reflective band, hold the Shift key and left click with mouse to place a 

white target. Since these CVT points are known points in DMT, it can accurately locate the estimated 

white target calibration point.  

   

Once the Calibrate process is complete the Height mode will automatically be selected.  

At this point you can begin placing height labels or select any of the other measure modes.  

Note:  If you need to redo the calibration process at any time, select the Calibrate mode and repeat 

the steps as directed.  There is no cancel or undo options for the Calibration process.     

Note:  Redoing the calibration process does not affect any of the measurements that have already 

been completed you would need to redo the measurements.    

Note: When using IKE Images the Calibrate Mode is automatically changed to Select GL.  This 

mode only requires one point on the image before additional measurements can be taken.  If the 

ground line is not visible in the image an offset value can be entered by selecting File > Groundline 

Offset after the initial, Select GL point has been added.  

 



Osmose O-Calc® Pro 7.0.1                                Confidential                                                                User Guide  

©2024 Osmose Utilities Services, Inc.                                                                                                  163  

  Configuring the measurement labels 

Once the height labels are placed, right click on the label to open a menu for edits.  

 

 

 

 

 

 

 

 

 

Edit Text. Select Edit Text to 

change the label text. 

 

 

Change Font Size. Select Change 

Font Size to change the font.  

 

 

Change Color. Select Change 

Color to open a color pallet. Select 

a color and click ok to change the 

color of the label. 

 

 

 

 

 

 Reposition. Select Reposition to 

reposition the label on the image. 
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Set as Control Point. Select Set as 

Control Point to add the point 

where calibration begins to 

measure attachments on the pole in 

the image. Control points can be 

any known location such as the 

ground line or the height of the 

lowest communication attachment. 

 

 Delete. Select Delete to remove all 

labels or only the label selected. 

 

 

 

 

Overview of Measurement Mode Selector  

To complete measurements you will need to select the corresponding Mode.   Each Mode 

uses a different visual tool to help you complete the measurements.    

 

Calibrate  Calibrate.  In the Calibrate Mode the 

cursor changes to a 

measurement sight for an accurate measurement.   

Height Mode  Height Mode. In the Height Mode the cursor 

changes to crosshairs  for an accurate 

measurement of height relative to groundline.  

Arbitrary (Arbitrary 

Length) Mode  

Arbitrary Mode. In the Arbitrary Mode 

the cursor changes to crosshairs   for 

an accurate measurement between two points in 

the plane of the target. Left click (1) and drag the 

red line to the point to measure, release the click. 

Select Yes.  

Cond Dia  

(Conductor  

Diameter) Mode  

Cond Dia Mode. In the Cond Dia Mode draw a 

line to accurately determine the conductor size by 

left click (1) and drag the yellow expanding band 

along any object (conductor) to be measured and 

release click. Select Yes.  
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Angle Mode  Angle Mode. Click the Angle Mode and the cursor 

will change to crosshairs  to accurately calculate 

angles. Left click (1) on the object and drag gold 

line to the desired angle midpoint and click (2), 

continue to drag cursor to the final angle point and 

click (3). Select Yes.   

  

Note: If a mode is selected that does not have any associated task an error message will be 

displayed.  

Height Mode Measurements  

The height is relative to the groundline of the pole.  To complete a Height measurement, 

complete the following steps:   

1. Select the equipment in the Inventory Window that you want to measure the 

height of.  

2. Select the Height Mode.  

  

3. Place the crosshairs at the point you want the Height measurement to be taken 

at.  

4. Left click, a menu listing the Height Task to be performed is displayed.  Select 

the Height Task you would like the measurement associated with.    

  

5. The Inventory and Data Entry windows will automatically be updated to 

reflect your measurement.  

Note: To cancel the current Height measurement, select the Cancel Option.  If you need to retake the 

measurement after it has been set, completed steps 1 thru 4 as directed above.   There is no undo 

option available.  

  

6. To trim the pole top but keep the taper and setting depth, select Advanced > 

Trim top of (name of pole).  
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Using Control Points  

When there is no CVT Stick or Range Pole in the images, measurements can be taken using 

Control Points set in the image, if the Target Type has been set to no CVT. Control Points 

can be used in the following way:  

1. In the Measure Window, select the Image menu, select the Change Current 

Image’s Target Type option.  

   

2. Select the Type: Tip Groundline Mode. The default choice is None, click the 

Select button.  

 

3. While in Calibrate mode, click to place a red target at the base the pole.  

4. While in Calibrate mode, click to place a red target at the top of the pole.  

5. While in Height mode, hold down the Ctrl key, and click a point on the pole 

that is the known height.  

6. In the Edit window enter the control point height value that is known.  
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7. Select OK  

  
Note: Only one control point can be used at a time. Control points ensure greater accuracy of 

attachment heights near the control point, when no CVT or Range pole is available in the image. 

This method only works if the pole is not selected in the Inventory Window or 3D View, deselect the 

pole if it is selected.  

Arbitrary Mode Measurements  

To complete an Arbitrary measurement between two points in the plane of the target, 

complete the following steps:   

1. Select the equipment in the Inventory Window that you want to take an 

Arbitrary measurement of.  

2. Select the Arbitrary Mode.  

  

3. Place the crosshairs at the point you want the Arbitrary measurement to start.  

4. Hold down the left mouse button and draw a line to where the Arbitrary 

measurement ends.  

5. Select the option from the list displayed.  
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6. The Inventory and Data Entry Windows will automatically be updated to 

reflect your measurement.  

Note: To cancel the current Arbitrary measurement select the Cancel Option.  If you need to retake 

the measurement after it has been set, completed steps 1 thru 5 as directed above.   There is no undo 

option available.  

Conductor Diameter Mode Measurements  

The Cond Diam (Conductor Diameter) is used to collect wire sizes.  To complete a 

Conductor Diameter measurement, complete the following steps:   

1. Select the equipment in the Inventory Window that you want to measure the 

diameter of.  

2. Select the Cond Diam Mode.  

  

3. Place the cursor on the middle of the Conductor whose diameter you want to 

measure.  

4. Hold down the left mouse button and drag along the conductor until the yellow 

line is the same width as the conductor then release the mouse button.   

5. Left click and select the Conductor Diameter Task you would like the 

measurement associated with.  

  

6. The Inventory and Data Entry Windows will automatically be updated to 

reflect your measurement.  

Note: To cancel the current Conductor Diameter measurement, select the Cancel Option.  If you 

need to retake the measurement after it has been set, completed steps 1 thru 5 as directed above.   

There is no undo option available.  

Angle Mode Measurements  

Angle measurements need be entered into O-Calc® Pro manually.  To assist you in 

measuring an Angle, complete the following steps:   



Osmose O-Calc® Pro 7.0.1                                Confidential                                                                User Guide  

©2024 Osmose Utilities Services, Inc.                                                                                                  169  

1. Select the equipment in the Inventory Window that you want to measure the 

angle of.  

2. Select the Angle Mode.  

  

3. Place the crosshairs at the point you want the Angle measurement to start.  

Note:  The Angle measurement is a three-point process.  After the Angle measurement is complete the 

Angel measurement is displayed for reference purposes only.  

4. Click the left mouse button and draw your first line, click the left mouse button 

again and draw your second line.  

  

5. Left click and the Angle measurement is automatically displayed for reference 

purposes.  

Note: If you need to retake the measurement, completed steps 1 thru 5 as directed above.   There is 

no undo option available.  

Adding Measurement Information to a Note  

To add measurement information to an existing note, complete the following steps:  

1. Select a note object in the Inventory Window.  

     

Note   
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2. Select the Mode you would like to use for the measurement.   

  

3. Place the crosshairs at the point you want the measurement to be taken at and 

click the left mouse button.  You may want to use the Scale Tool or the mouse 

wheel to zoom into a specific area in the image.  

   

4. The selected note in the Inventory Window automatically is displayed.  

  

5. Complete any edits to the notes description, note context or spreadsheet.  
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6. Select Edit > Paste to incorporate the measurement into the note content area 

of the note.  The selected measurement is automatically inserted into the 

selected note.  

 

7. To have the measurement automatically pasted into the spreadsheet, select the 

cell you want to paste the measurement into and select one of the following 

options from the Sheet menu:  

Sheet > Paste > Value Only - Excludes the measurement text and only paste 

the measurement value into the spreadsheet.   

Sheet > Paste > All Text - Pastes the complete measurement into the 

spreadsheet with nothing excluded.   

 

8. Select File > Save.  

Adding Specific Measurements to the Notes Data Grid  

To add specific measurements to the Data Grid while working in the Measurement 

Window you can create custom Measurement Labels in a Note’s Data Grid.  These 

Measurement Labels display each time the note is selected while completing 

measurement.  To create a Measurement Label in a note and use them to paste 

measurements directly into the selected note, complete the following steps:  
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1. Create a new note object or open an existing note object in Edit Mode.  

2. Enter a description and the note context.  

3. Select a cell in the Data Grid View and enter a Measurement Label.  

There is not limit as to the number of Measurement Labels you can enter.  The only 

exception is that the measurement label needs to be entered with brackets around it 

<Measurement Label>.  

As there is no measurement value enter, place holder values of zero where you would like 

the measurement value to be entered.  Also, enter calculation formulas if they are needed.   

 

6. Select the Measure tab.  

7. Click the left mouse button where you would like each measurement taken 

from and select the appropriate Measurement Label.  

    

4.   Select  File   >   Save .   

5.   Select the  N ote   object in the Inventory Window.   

  Measurement    
Labels   
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8. To return to the select note object left mouse click and select Show Note.  

   

Note: Additions and modified can be made to any area of the note at any time.  The note can also be 

copied to a User Catalog to be used as a template for future use.  

  

Note: If measurements have been incorporated into the Data Grid using Measurement Labels and 

the Units Convention (English or Metric Convention) is changed the measurements that are 

displayed in the Notes Data Grid will not change.  
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Working with the Data Entry Window  

Data Entry Overview   

The Data Entry Window works in conjunction with the Inventory Window.  When selecting 

an object(s) in the Inventory Window the object’s attributes are displayed in the Data Entry 

Window.  This provides a comprehensive way to review or make changes to editable 

attributes.    

Editing Attributes   

To edit an attribute, complete the following steps:  

1. Select the Data Entry tab.  

2. Select an object in the Inventory Window.  

  

3. The selected object displays in the Data Entry Window.  

   

4. Select the attribute to be edited in the Data Entry Window.  
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Note:  If additional attributes are available a drop-down menu will display next to the selected 

object’s name in the Data Entry Window.  Select the drop-down menu to display additional attributes.  

5. Press the space bar and edit the selected attribute.  

Note: Certain attributes are only editable in Administrative User Mode.  If you are no in 

Administrative User Mode, the attribute will be grayed and not changeable.  

  

Note: For a complete list of the editable icon’s descriptions Editing Equipment Attributes.  

6. Select Enter.  

  

Expand All Attributes   

By default, the Standard list of attributes is initially displayed in the Data Entry Window 

when an object is selected in the Inventory Window.  To change the default setting so that 

all the selected object’s attributes are displayed, complete the following steps:  

1. Select Options > Info Tips and Data > click the Expand all Attributes in Data 

Entry Panel option.   

Note: All options can be enabled/disabled by simply clicking on them (toggle on/off) again. Any 

enabled option displays the check mark symbol indicating it is on.   
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Display Multiple Attributes   

  

To display multiple objects for review or editing from the Inventory Window, complete the 

following steps:  

1. Select any objects in the Inventory Window.  

  

  

Note: Hold down the ctrl key to select more than one object out of sequence.  Hold down the shift key 

to select a group of objects that are next to each other.  

2. The selected objects are displayed in the Data Entry Window.  

  
Note:  When multiple objects are displayed in the Data Entry Window all like objects are 

automatically grouped together.   

Display Multiple Corresponding Attributes   

To display multiple objects that are of a specific type, that are all on the same hierarchy 

level, for review or editing from the Inventory Window, complete the following steps:  

1. Right click on any object in the Inventory Window.  

2. Select the Select All of Type option.  
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3. The selected object and any like objects within that hierarchy level are displayed in 

the Data Entry Window.   

  
Note: Hierarchy levels (parent-child relationships) indicate how objects are connected. A visual 

indicator of hierarchy levels is indicated by the dotted line icons which show the connections 

between objects in the Inventory Window.  

Creating a Custom Attribute List  

To create a Custom Filter containing a list of attributes to view in the Data Entry Window, 

complete the following steps:  

1. Select an object in the Inventory Window.  

2. In the Data Entry Window, select the attributes filter drop-down menu arrow.  
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4. The Custom Filter Editor window opens; select the Add Filter button and 

enter a name for the custom filter. Check the boxes for the attributes you want 

included in the custom filter.  

  

  

3.   From the filters list, select   the   Custom Filters   option.   
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5. Select the attributes to be included in this filter list from the available checklist 

of Attributes Displayed.  

6. Once Selections have been made, select OK.  

7. In the Data Entry Window, open the filters drop down list.  

8. The new custom list of attributes will display at the top of the filter list.  

  

  

Note: A Custom Filter listed can be deleted in the Custom Filter Editor Window. If the custom filter 

is displayed in the Data Entry, it can not be deleted. To delete, first deselect the customer filter, then 

you can delete it in the Custom Filter Editor Window.  

  

Working with the Top View Window  

About the Top View Window   

The Top View Window displays a polar (North/South orientation) view of the pole with 

span angles. Changing the Ganged Geometry or the Line of Lead will automatically change 

all the spans.    
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Top View Display Options  

The Top View provides a variety of operations and options.  

Functionality Icons  Description  

  
Zoom-Out.  Click the Zoom-Out 

option to zoom the display out.  

Zoom-In. Click the Zoom-In option 

to zoom the display in.  

  
Gang Editor.  Click the Gang 

Editor button to set of spans in a 

single direction to edit. This also 

automatically select all the spans in 

the given direction.  

  
3D Compass.  Click the “C” button 

to cause the Top View Window and 

the 3D View Window to track in 

concert with one another.  The 

permanently enable simply check 

the 3D Compass box.  

  

Reset.  Check the Reset option to 

undo any display options that were 

selected.   

Note: This does not undo any changes 

completed in the Ganged Geometry 

Editor or to the Line of Lead.  

  Line of Lead.  Click the Line of 

Lead option to change the line of 

lead.  

  Angle Filter. Click and drag the 

Angle Filter button to set the area to 

be filtered.  

  Position the Angle Filter. Click 

and drag the Position Angle Filter 

button to reposition the Angle Filter.  

Change the Zoom Level  

To change the zoom level in the Top View display, which is helpful in 

expanding/contracting the space between the “G” buttons, complete the following steps:  
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1. Click the Zoom In button  to zoom in the view of the spans.  Click the Zoom 

Out button  to zoom out the view of the spans.   

Note: To remove the zoomed display level select the Reset button .  

Using the Gang Editor for Span sets in a Single Direction  

  

   To edit the attributes for set of spans in a single 

direction, complete the following 

steps:  in the Top view Window on 

the spans you want to edit.   

  

2. In the Gang Editor window, use the default Absolute Mode, or select the 

Relative mode option from the drop-down list.  

  

3. Modify the Angle, Span Length, End Drop value.  

4. Modify the Rotate All option by changing the No radio button to Yes and enter 

a value in the Angle attribute. Click OK. Resulting in the entire structure being 

rotated to reflect the new Line of Lead (LOL) value entered.  

1.   Select the  “G”  button   
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5. Click the Lat Lon button for a shortcut to the Geolocation information for the 

pole.  
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6. Select OK.  

Note:  To undo the Gang Editor change, select Edit > Undo.   

Incorporating the 3D Compass View   

Click the “C” button to cause the Top View Window and the 3D View Window to track in 

concert with one another.  The permanently enable tracking, simply check the 3D Compass 

box. Complete the following steps:  

1. Click the 3D Compass button .  The display is automatically rotated to match 

the 3D View.   

Note: To enable the 3D Compass tracking so that every time the 3D View is repositioned the Top 

View  

Window automatically tracks the change, check the 3D Compass box .  Deselect the 3D 

Compass check box to disable tracking.  

Reset the Top View Display   

To undo any changes to the Top View display, complete the following steps:  

1. Click the Reset button .  

Note: Resetting the Top View display does not undo any changes that have been completed in the 

Gang Editor or Line of Lead.  

Edit the Line of Lead   
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To change the line of lead, complete the following steps:   

  

2. Enter a value for the Angle which will rotate the entire pole. Click OK.  

  

Setting an Angle Filter   

  

When working with a pole that has numerous spans attached at different angles, it may be 

beneficial to narrow the scope of the data displayed.  The Angle Filter allows you to set a 

filter so that only spans in a specific area are displayed.   

 
1. Complete the following steps to enable the Angle Filter, select Options > 

Options in 3D View > Angle Filtering.  

1.   Select the  Line of Lead   button     located in the center of the Top View .    

Note:  The Line of Lead will rotate the complete pole and  all attachment s .   

  

  

Position the  
Angle Filter   
( red button )   

Angle Filter   
( purple button )   
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2. Click and drag the purple Angle Filter icon to set the position of the filter.  

 

3. Click and drag the red Position the Angle Filter icon to set the amount of area 

to be filtered.  

 

  

  

  

  

  

  

  

Blue background  
area will be  
filtered   

  

Gray background  
area will not be  
filtered   
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Note: If you have multiple filters set you can remove just one or all of the filters by right clicking on 

the Filter Notification button  and selecting one of the Reset Filter options.  

  

Working with the Schematic Window  

About the Schematic Window   

The Schematic Window displays a side elevation view of the major equipment on the pole.  

Within the Schematic Window you can change the height of the equipment, view basic 

information about the equipment, or filter the scope of the data displayed.  

Note:  Hovering over the equipment height will display basic information about the equipment.    

  

Note:   To remove the Angle Filter ing   select the Rest button  .   

Only the filtered spans  
are displayed in 3D  

The   filter notification   ( sunglasses )   
icon is added to the 3D View   



Osmose O-Calc® Pro 7.0.1                                Confidential                                                                User Guide  

©2024 Osmose Utilities Services, Inc.                                                                                                  187  
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Schematic Window Menu Display Options   

Right clicking on the Schematic Window background provides several options.  

  

Save Schematic View to File. This 

option saves the current Schematic View 
as a variety of file types (JPEG, BMP, 

GIF or PNG)  

Copy Schematic View to Clipboard. 

This option copies the current  

Schematic View to the clipboard so that 

the Schematic View can be pasted 

directly into other applications such as 

Microsoft Word, E-Mail, etc.  

Print Schematic View. This option 

prints the currently displayed Schematic 

View.  

Cancel. This option closes the available 

Schematic View options without taking 

any action.  

Display Above GL Portion Only   

To display only the portion of the pole above the groundline (GL), complete the following 

steps:  

1. Check the Above GL Portion Only box to display only the portion of the pole 

that is above the groundline.  Un-check the box to display the complete pole.   

Display Draft Pole Break   

To replace a portion of the pole with no attachments with a drafting break, complete the 

following steps:  

1. Check the Draft Pole Break box to insert a temporary drafting break.  Un-check 

the box to display the entire pole.   

  

Changing Equipment Height   

To edit the equipment height, complete the following steps:  

1. In the Schematic View, click on the equipment height label you would like to 

change. In the Edit window enter a new height for the equipment. Click OK.  
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Note: To undo a height modification, select Edit>Undo.  

Setting a Height Filter   

To filter the spans on the pole according to height, complete the following steps:  

1. To enable the Height Filtering option, select Options > Options in 3D View > 

Height Filtering.   

  

2. Use the slider scale buttons to set the filter height. Slide one or both buttons.  

 

  

  

  

  

  

  

    

Height Filtering  
Scale   
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Note: If you have multiple filters set you can remove just one or all of the filters by right clicking on the  

Filter Notification button  and selecting one of the Reset Filter options.  

Administrative Settings Tool 

This tool allows the user to control certain O-Calc Pro settings only accessible to advanced O-

Calc Pro users with administrative privileges. Below are the steps to activate administrative mode 

for qualified users. 

 

1. In the lower left of the O-Calc Pro application is the user level designation, typically set to 

‘Normal’. Select this button to access the User Level pop up window. 

  

  

    

  

Note :   To remove the Height Filtering select the Reset button  .   

Only the filtered span heights  
are displayed in 3D View   

A filter notification (sunglasses)  
icon is added to the 3D View   

Constraints of the  
Height Filter scale   
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2. For Administrative Mode select Set user level to Administrative. When selected, you will see the 

user level change to Administrative in the lower left of the application.  

 

With the user level set to administrative you will be able to see the Administrative Settings menu 

option under the Tools dropdown menu where otherwise you would not be able to. 
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Using the Administrative Settings Feature 

To access Administrative Settings go to Tools>Misc> Administrative Settings from the main 

toolbar at the top left of the application. 

 

After clicking on the Administrative Settings menu option this following window will 

appear 
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This setting allows the user to change the Default Pole Segment Length used by the O-

Calc Pro finite element analysis calculations. User may want to increase or decrease this 

value in order to adjust the resolution of the finite element model of the pole being 

calculated. 

 

Increasing the value decreases the number of elements used per model, thus lowering the 

definition of the analysis and potentially lowering the accuracy of the analysis, with the 

trade off being a quicker calculation time. 

 

Decreasing the value in the dialog has the opposite effect, increasing the number of 

elements in the analysis. This results in a higher resolution calculation which may be 

more accurate at the cost of being less time performant. 

In order to save any changes to the Administrative Settings O-Calc Pro will have to be 

restarted. 
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Working With the O-Calc® Pro Data  

Viewing the Data in Charts   

Once a pole is completed in the Inventory Window you may want to perform additional 

analysis by consulting several predefined charts.  

  
Note:  A pole needs to be displayed in the Inventory Window in order for data to display in the 

Charts.  

Toolbar Menu Options for Charts   

The charts toolbar menu provides you with a variety of operations and options.   

  

  

File. The following options are available from 

the File menu:  

Print Chart.  Select the Print Chart option to 

print the currently displayed chart.  

Page Setup. Select the Page Setup option to 

configure how the chart will be printed.  

Print Preview. Select the Print Preview 

option to preview the currently displayed 

chart exactly as it will be printed.  
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Condition Selector. Select MCU to see data 

at maximum capacity utilization or select GL 

to see data at groundline.  

  Chart. Select the desired Chart to display 

from the drop-down menu.  

  

Ignore Sign. Check the Ignore Sign option to 

ignore the Trans/Long values.  

  
Northing / Easting. Check the Northing / 

Easting option to plot the individual 

component vector lines in the selected chart.  

  

Magnitude. Check this option to plot the 

Magnitude line in the selected chart.  

  Capacity. Check this option to plot the 

Capacity line in the selected chart.  

  
Total. Check this option to plot the sum of the 

individual components in the selected chart.  

  Left\ Right arrows. Select the left\ right 

arrows to scroll through and display the 

various charts without having to use the chart 

drop down menu.  

Note: Available plotting options are dependent on the selected chart.  

Viewing Charts   

To perform a pole analysis using a Chart, complete the following steps:   

1. Load a pole that has a LoadCase in the Inventory Window.  

2. Select a Chart to be displayed from the available Charts drop down list.  

  

Once a Chart has been selected the Chart will automatically be loaded.  
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Note:  The chart uses the currently selected LoadCase when calculating and displaying a chart.  

Note:  Use the mouse wheel to zoom in and out on a specific area on the chart. To set the chart back 

to the default view, See Additional Menu Options for Charts.  

Additional Menu Options for Charts   

In addition to the basic menu options that are available, once a chart is displayed additional 

chart options are available by right clicking on the chart.   

  

Copy.  Select to copy the current chart to the 

clipboard so that the chart can be pasted directly 
into other applications such as Microsoft Word, 

E-Mail, etc.  

Save Chart.  Select to save the current chart as a 

variety of file types (JPEG, BMP, GIF, etc.).  

Show Point Values.  Select to display floating 

point values when hovering in a chart.  

Un-Zoom.   Select to undo a previous zoom 

operation.   

Set Scale to Default.  Select to set the chart back 

to the default scale.  

  

Interpreting the Chart   

Each chart value is plotted using lines as identified by color in the chart legends.  

The line definitions are as follows:   
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Capacity(Gray)  Capacity.  The Pole Fiber Stress X Strength 

Factor is plotted on Moment and Stress Charts.    

Example: For a yellow southern pine (8,000 psi) 

under NESC Grade C (.85 strength factor) criteria, 

the pole’s allowable stress is plotted at 6,600 psi on a 

Total Stress chart.  

Easting (Blue)  Easting.  These values are perpendicular to the 

frame of reference and represent results in the 

90°/270° direction.  Easting values are plotted on 

all charts.  

Northing (Green)  Northing.  These values are those in the 

direction of the northing value and represent 

results in the 0°/180° direction.  Northing values 

are plotted on all charts.  

Magnitude (Red)  Magnitude.  A non-directional value 

representing the summary of forces along the 

length of the pole.  This line is critical because it 

represents a combined value of the Easting and 

Northing directions.  This line represents the 

summary of forces acting on the pole.  
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Viewing the Data in Reports   

Once the pole is completed in the Inventory Window you may want to generate a variety of 

reports.  The O-Calc ® Pro Analysis Report is provided to help you inspect the analysis 

results.   
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Note:  A pole needs to display in the Inventory Window to enable the Reports option.  

Toolbar Menu Options for Reports   

The report’s toolbar menu provides you with a variety of operations and options.   

  

  

File. The following options are available 

from the File menu:  

Print Report. Select Print Report to print 

the current report.  

Page Setup. Select the Page Setup option 

configure how the report will be printed.  

Save to PDF.  Select Save to PDF to save 

the current report to edit an existing 

report template.  

Save to RTF.  Select the Edit Report 

Template to edit an existing report 

template.  

 E-Mail Report To.  Select the E-Mail 

Report To option to e-mail the currently 

viewed report.   
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  Report. Select the desired Report to 

display the from the drop-down menu.  

  
Left\ Right arrows. Select the left\ right 

arrows to scroll through and display the 

various Reports without having to use the 

chart drop down menu.  

  

Refresh. Select to refresh the Report 

Window.  

  

Batch Report.  Select to open and work 

with the Batch Pole Reporting tool.  

  

Custom Reports. Select to create 

Custom Reports.  

  
Manage Reports. Select to manage 

which reports display in the Report drop- 

down list.  

Note: Manage Report configurations are 

carried over to Bulk Reports  

  
Auto.  Select to automatically reload the 

currently displayed report after 

calculations have been performed.   

    

Reports Toolbar Options  

Once a Report is displayed the report’s toolbar menu provides you with a variety of 

operation and options.    

  

Navigation Controls  

  

Navigation Controls. Click the arrows to 

navigate through the document. Double 

arrows navigate to the first or last page. 

Single arrows navigate to one page at a 

time.  

  

Zoom.  Select the Zoom drop-down list to 

change the report magnification level.   

  
Zoom In/Zoom Out.  Click the zoom in 

or zoom out buttons to manually zoom 

within the currently selected report.   

  
Zoom to Fit.  Click the Zoom to Fit 

option to automatically have the report fill 

the space provided.  



Osmose O-Calc® Pro 7.0.1                                Confidential                                                                User Guide  

©2024 Osmose Utilities Services, Inc.                                                                                                  201  

  

Page Count.  Displays the current 

page/the total pages in the report.     

  

Viewing Reports   

To view an existing report, complete the following steps:   

1. Load a pole that has a LoadCase in the Inventory Window.  

2. Select a Report to be displayed from the available Report drop down list.   

Note: The list of available reports is dependent on which reports are selected under Manage Report.  

The list of available reports also corresponds with the currently loaded pole. (Example: The 

crossarm reports will not be displayed in the report list if there are no crossarms on the currently 

loaded pole).  

  

Once a report has been selected the Report will automatically be loaded.  

Note: The report may take a moment to load.  
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Note: The selected report uses the currently selected LoadCase when calculating and displaying a 

report.  

Creating a Batch Pole Report   

The Batch Pole Report allows you to print report(s) against specific poles that you select.  

To create a Batch Pole Report, complete the following steps:   

1. Select Tools>Batch Pole Report.  

Note: The Batch Pole Report can also be accessed by selecting Batch Report in the Reports Window.  
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Display Layout  

Toolbar Menu Options  Add Poles. Select the Add Poles option to add 

poles that will be processed in the Batch 

Reports.  

Remove Poles. Select the Remove Poles option 

to remove poles that have been to the Poles to 

Process list.   

Printer Setup. Select the Printer Setup option 

to configure the printer that the Bulk Reports 

will utilize.  

Print Reports. Select the Print Reports option 

to print the currently selected batch reports.  

Display Layout  Display Layout. Enables the ability to switch 

between different window layouts.    

Sort Files  Sort Files. Select the Sort Files option to sort 

the PPLX files in alphabetical order when they 

are printed to files.  

  

  

Toolbar   

Pole to Process   

    

Report  
Output  
Type   
  

PPLX File  
O ptions   

Bulk  
Reports   
  

Per - Pole  
Reports   
  

Named  
Report   
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All Versions  All Versions.  Select this option to create a 

print to file report for each version within the 

selected PPLX files.  

Note: For additional information on pole 

versioning, see Create a New Version of the Existing 

Pole.  

All LoadCases  All LoadCases.  Select this option to create a 

separate print to file report for each loadcase 

attached to a PPLX file.  

Print to files  Print to files. Select the Print to files option to 

print the currently selected batch reports into 

file format.  

File Per Report: Select the File Per Report 

option to create an individual file for each 

report selected.    

File Per Pole: Select the File Per Pole option 

to create one file per each processed pole.   

Single File: Select the Single File option to 

create a single file that includes all the selected 

Per-Pole Reports.  

Poles to Process  Poles to Process.  Displays the poles that will 

be processed in the selected Batch Reports.  

Note: The order of the poles can be changed by 

using the drag-and-drop option.  

Bulk Reports  Bulk Reports.  Displays the list of available 

Bulk Reports.  

Note: These reports print separate from the Per- 
Pole Reports.  

Per-Pole Reports  Per-Pole Reports.  Displays the list of 

available Per-Pole Reports.    

Note: The order in which the reports will be printed 

can be changed by using the drag-and-drop option.   

  

2. Select the Add Poles button .    

3. Browse to the location of the pole(s) you wish to add to the Batch Report 

process and select the (pole name).pplx file and click Open.  

Note: Hold down the ctrl key to select more than one pole out of sequence.  Hold down the shift key 

to select a group of poles that are next to each other.  
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Note:  To remove selected poles from Poles to Process area select the pole then select the Remove 

Poles button .  Hold down the ctrl key to select more than one pole out of sequence.  

Hold down the shift key to select a group of poles that are next to each other.  

4. To change the order in which the (pole name).pplx file(s) will be printed click 

and drag the .pplx file.  

Note: When a. pplx file is being dragged to a new location the cursor will change to 

indicate a valid move  .  

5. Select the Bulk Report(s) to be include.  

  

6. Select the Per-Pole Report(s) to be included.  
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7. To change the order in which the Per-Pole Report(s) will be printed click and 

drag the report.   

 

Note: When a report is being dragged to a new location the cursor will change to indicate a valid 

move  .  To save the changed layout of the Batch Pole Reporting window see Save a Named View.  

  

8. Check the Sort Files to sort the PPLX files in alphabetical order when printed 

to file(s).  

9. Check the All Versions to create a report for each version within the selected 

PPLX files.  

    

  
The O - Calc® Pro  
Clearance Report is  
repositioned to print  
before the Analysis  
Summary.    
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10. Check the All LoadCases to create a report for each loadcase attached to a 

PPLX files.  

11. Select the Print Reports button  to print the Batch Reports to your 

default printer.  

To print the Batch Reports to a different printer, select the Printer Setup 

button  and select your printer of choice.  

OR  

Check the Print to files  option, select the Report Output Type then navigate to 

and select where you want the Batch Report files saved to.  

Note: Only the initial Pole Image will be included in the Batch Report.  Subsequent images that are 

attached to the./pplx file will be printed or saved as individual PDF files as ‘pplx file 

name_image#’.   

Exporting Batch Pole Information   

The Export Batch Pole Information Report allows you to export specific pole attributes 

and calculation results to a .CSV file.  To export a Batch Pole Information, complete the 

following steps:   

1. Select Tools > Export Batch Pole Report Info.  
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Toolbar Menu Options  Add Poles. Select the Add Poles option to add 

poles that will be processed in the export.  

Remove Poles. Select the Remove Poles option 

to remove poles that are listed in the Poles to 

Process list.   

Export Info. Select the Export Info option to 

export the selected items and calculations to a 

.CSV file.  

Check All  Check All.  To select the entire Items to Export 

list.  

Uncheck All  Uncheck All.  To uncheck the entire Items to 

Export list.  

Display Layout  Display Layout.  Enables you to swiftly switch 

between different window layouts.    

All Versions  All Versions. Select  create a separate entry for 

each item and calculation based on each version 

within the selected PPLX files.  

Note: For additional information on pole versioning, 

see Create a New Version of the Existing Pole.  
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All LoadCases  All LoadCases.  Select to create a separate 

entry for each item and calculation based on the 

loadcase(s) attached to a PPLX file.  

Poles to Process  Poles to Process.  Displays the poles that will 

be processed in the exported batch pole .CSV 

file.  

(The order of the poles can be changed by using 

the drag-and-drop option)  

Items to Export  Items to Export.  Displays a list of available 

items (attributes) that can be exported.  

(The order of the items can be changed by using 

the drag-and-drop option)  

Selected Items  Selected Items.  Displays a complete list of all 

the selected Items to Export.  

  

2. Select the Add Poles button .    

3. Browse to the location of the pole(s) you wish to add to the Batch Pole 

Information Export process and select the (pole name).pplx file and click 

Open.  

Note: Hold down the ctrl key to select more than one pole out of sequence.  Hold down the shift key 

to select a group of poles that are next to each other.  
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Note:  To remove selected poles from Poles to Process area select the pole then select the Remove 

Poles button .  Hold down the ctrl key to select more than one pole out of sequence.  

Hold down the shift key to select a group of poles that are next to each other.  

4. Select the Items to Export from the available list.  

  

5. To change the order in which the Items to Export will be displayed in the 

.CSV file click and drag an item to arrange the items placement.   

 

Note: When an item is being dragged to a new location the cursor will change to indicate a valid move  .   
To save the changed layout of the Items to Export window see Save a Named View.  

  

7. Browse to the location you would like the Batch Pole Information Export 

saved to and enter a file name.  

8. Select Save.  

9. Select OK to the export confirmation message.  

6.   Select the  Export Info  button   .   
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Working with the Clearance Analysis Tool   

The Clearance Analysis Tool allows you to evaluate and report on clearance violations 

along the spans emanating from a pole.  Examples of clearance requirements that can be 

encoded and violations that might be found between them are:  

• Spans of different types (power to comm. for example)  

• Spans and structures or vehicles  

• Spans and surfaces  

• Spans and foliage  

  

The tool provides the ability to model actual field conditions accurately, giving you the 

ability to define elements arrayed under or interfering with the spans emanating from a 

pole.  

  

Creating a Clearance Analysis on a new or existing (transmission) pole allows you to take 

into effect field conditions such as surfaces (terrain), structures, foliage and wires.  The 

Clearance Analysis tool creates a 2D representation (model) of the spans and field 

conditions that you have input.  A Clearance Analysis report is also available to easily 

detect any clearance issues.   

  

Creating a Clearance Analysis is a four-step process:  

  

1. Create Clearance Rules and Violations definitions.  

2. Using Clearance Group objects on specific spans to identify the category or 

categories that a span falls into.  

3. Recording the actual field conditions surrounding the pole (surfaces, structures 

and foliage).  

4. Running the Clearance Analysis report.  

  

Create Clearance Rules and Violations   

Before any Clearance Analysis can be completed, the Clearance Rules and Violations need 

to be set-up.  Creating these Clearance Rules and Violations should typically only be done 

once for any power company or division.   Once the Clearance Rules or Violations have 

been established extreme caution is advised when removing or editing them after 

Clearance Analysis is configured.  Removing or editing existing Clearance Rules or 

Violations may invalidate existing clearance elements or rules.     

To create Clearance Rules and Violations, complete the following steps:   

1. Select Tools > Clearance Analysis > Edit Clearances Rules.  
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or right click and  

  

2.   To add a  Structure ,   Surface  or   Foliage   element   select the area you want to add an  

element to and either left click and select the  Add   button  

select  Add   from the popup menu.   

New Structure  
element is  
created   
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   Define the elements attributes  

  

  

  

  

3. Enter the new element attributes.  

  
Note: Only the Structure area allows you to define a Shape.    

Note: When adding a Surface element, a Default surface attribute is available if you’d like to have 

a specific surface added by default when creating Clearance Analysis.   The default surface area 

can be changed at any time.  

4. Select File > Save.  

Note: Complete steps 2 – 4 to create additional elements for Structures, Surfaces and Foliage.  

Note: There is no undo for this operation.  To remove an element, select the Structure, Surface or 

Foliage and select the Delete button   from the toolbar. The Delete option is also available by 

right clicking on the element and selecting Delete.  

5. Clearance Groups depict what categories spans can be a part of.   To add a 

Clearance Group either right click on Clearance Groups and select Add from 

the popup menu 
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or left click Clearance Groups and select the Add button   

  
Define the Clearance Group attributes  

  

6. Enter the new Clearance Group attributes.  

  

7. Select File > Save.  

Note: Complete steps 5 - 7 to create additional Clearance Group rules.  

Note: There is no undo for this operation.  To remove a Clearance Group rule, select the Clearance 

Group to be removed and select the Delete button  from the toolbar.  The Delete option is 

also available by right clicking on the rule and selecting Delete.  

  .   

  

New Clearance  
Group is created   
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8. Rules and Violations define the rules and violations that will be used when 

completing a Clearance Analysis.  To add a Rule or Violation either right click 

on Rules and Violations and select Add from the popup menu or left click 

Rules and  

Violations and select the Add button  

Define the Rule or Violation attributes  

9. Enter the new Rules or Violations attributes.  

.   

    

New Clearance  
Rule is created   
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11. Check the Source(s) to be used.  

12. Check the Target(s) to be used.  

Note: Multiple Sources and Targets can be selected.  The only exception being that you cannot 

select the identical Source and Target.  

13. Select OK.   

14. Select File > Save.  

Note: Complete steps 8 – 14 to create additional Rules and Violations.  

10.   To set the  Source s   Target s   select the  radio   button  .   
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Note: There is no undo for this operation.  To remove a rule, select the Rule and Violation item and 

select the Delete button  from the toolbar.  The Delete option is also available by right 

clicking on the rule and selecting Delete.  

  

Note: A comprehensive listing of all the current Clearance Rules is available by selecting File > 

Show Clearance Rules.  The O-Calc® Pro Clearance Analysis Rules report will display and is 

available for printing.  

Categorizing Spans   

Once the rules are in place you need to categorize the actual spans on the current pole.  To 

identify which spans, go into specific categories you will need to place a Clearance object 

on each span.  To place a Clearance Objects on a span, complete the following steps:   

1. Select the Span to add a Clearance Object to.  

Note:  Spans can be selected from the Inventory Window, the 3D View or the User Catalog.  If a 

span is selected from the 3D View or the User Catalog use the right click menu to add a clearance 

object.  

2. Select the Add button .  

Note: The Add Element > Clearance option can also be accessed by right clicking on the span you 

need to add the Clearance Object to.  

3. Select the Clearance option.  

  
Note: Only one Clearance Object can be added at a time.  

  
Note: Available tabs are dependent on corresponding equipment displayed in your Catalogs or 

Inventory window.  
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4. To add a Clearance Object from a catalog or the Inventory, select the 

clearance object you want to add.  

Note: For additional information on catalogs or the Inventory Window see Working With the 

Catalog Window or Working With the Inventory Window.  

5. Select the Attribute Value tab to modify the clearance object attribute values.  

Clearance attributes descriptions:  

Description  Description. A general description of the 

Clearance Object.  

Clearance Group  Clearance Group.  The name of the Clearance 

Group.  

Render in 3D View  Render in 3D View.  A visualization of the 

vertical clearances.  

Population Mode  Population Mode.  Determines the method by 

which the midspan sag values are populated. 

Manual: Sag values are entered by the operator.  

Automatic: Sag values are populated 

automatically.  

External: An external process populates the 

values  

Sag Minimum  Sag Minimum. Enter the minimum sag allowed 

at midspan.  

Sag Nominal  Sag Nominal.  Enter the nominal sag allowed at 

midspan.  

Sag Maximum  Sag Maximum.  Enter the maximum sag 

allowed at midspan.  

6. Click OK.  

  
Note: To undo the addition of the Clearance Object, select Edit > Undo.   

Create a Clearance Analysis Profile   

To model the actual field conditions surrounding the pole you need to create a Clearance 

Analysis Profile.  As you are creating the field conditions a 2D representation of the model 

will be displayed as a visual reference.  To create a Clearance Analysis Profile, complete 

the following steps:   
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1. Select Tools > Clearance Analysis > Clearances and Violations.  

  

  

  

Setting up Vectors  

The first step to modeling the actual field conditions is to set the vectors.  Vectors are 

notional lines that extend outward from the pole at given angles and which describe the 

type and elevation changes of the surface under the pole.  Vectors may contain instances of 

structures and foliage that fall along that line.  Typically, these vectors have a close 

correspondence with the spans attached to the pole, but this is not a requirement.     

2. To set the Vectors select the Add Vectors button  from the Vectors toolbar.  
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Note: To automatically create a vector at each span angle select the Auto button from the Vector 

toolbar.  

  

3. Enter a Vector Angle.  

Note:  An overhead view of the pole with all the span angles is available by selecting the Overhead 

button  

.  The Overhead window utilizes some of the same features as the Top View window; 

see Top View Display Options  for a description of these options  

4. Select OK.  

Note: There is no undo or edit for this operation.  To remove a Vector Angle, select the Vector Angle 

to be removed and either select the Delete button  from the Vector toolbar or right click the 

Vector Angle and select Delete.  

5. To create a structure at a specific vector, select the vector you want to add a 

structure object to.  

6. Select the Add Structures / Surfaces / Foliage drop down menu and select 

Structure.   

  

7. Enter the structures attributes.  
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8. Select OK.  

Note: Complete steps 5 – 8 to establish additional structures at a specific vector.  

Note: There is no undo for this operation.  To remove a structure select the structure to be removed 

and either select the Delete button  from the toolbar or right click the Structure and select 

Delete.  

9. To set the surface at a specific vector select the vector you want to add a 

surface object to.  

10. Select the Add Structures / Surfaces / Foliage drop down menu and select 

Surface.  

  

11. Enter the surface attributes.  

12. Select OK.  

Note: Complete steps 9 –12 to establish additional surfaces at a specific vector.  

Note: There is no undo for this operation.  To remove a surface, select the surface to be removed 

and either select the Delete button  from the toolbar or right click the Surface and select Delete.  

13. To create the foliage at a specific vector, select the vector you want to add a 

foliage object to.  

14. Select the Structures / Surfaces / Foliage Add drop-down menu and select 

Foliage.  
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15. Enter the foliage attributes.  

  

16. Select OK.  

Note: Complete steps 13 –16 to establish additional foliage at a specific vector.  

Note: 

There is 

no undo 

for this 

operation.  

To remove 

foliage, 

select the 

foliage to 

be 

removed 

and either 

select the 

Delete 

button 

  from 

the 

toolbar or 

right click 

the 

Foliage 

and select 

Delete.  
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Note: Structures, Surfaces and Foliage can be edited at any time by selecting the object and either 

selecting the Edit button from the toolbar or right clicking on the object and selecting Edit.  

17. To Save the Clearance Analysis Profile select File > Exit.  Then in the O-

Calc® Pro main window select File > Save Pole.  

Running Clearance Analysis Reports   

The Clearance Analysis report displays any clearance violations along the spans you 

modeled.  A  

Clearance Analysis report can be run against all the vectors you’ve specified or just one 

vector. To run the Clearance Analysis report, complete the following steps:   

1. Select Tools > Clearance Analysis > Clearances and Violations.  

  

2. Select the Clearance Analysis drop down menu.  

  

• Current Vector – Creates a Clearance Analysis report on the currently select 

vector in the Clearance Analysis window.  

• All Vectors – Creates a Clearance Analysis report on all the currently listed 

vectors in the Clearance Analysis window.  
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Clearance Analysis Reports Toolbar Options  

Once the Clearance Analysis report is displayed the toolbar menu provides you with a 

variety of options. The following options are available from the File menu:  

   

  

Print Report. Select the Print 

Report option to print the Clearance 

Analysis.  

Page Setup. Select the Page Setup 

option to configure how the  

Clearance Analysis will be printed.  

Save to PDF.  Select the Save to 

PDF option to save the Clearance 

Analysis as a PDF file.  

Save to RTF.  Select the Save to 

RTF option to save the Clearance 

Analysis as a RTF file.  

E-Mail Report To.  Select the 

EMail Report To option to E-Mail 

the Clearance Analysis.  

Copy to Clipboard. Select the Copy 

to Clipboard option to copy the 

Clearance Analysis to the clipboard 

so that it can be pasted directly into 

other applications.  
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Navigation Controls  

  

Navigation Controls. Click the 

arrow buttons to easily navigate 

through the document pages.  

Zoom Controls  

  

Zoom Controls. Use to change the 

documents magnification level.  

  

Clearance Rules Maintenance   

The Clearance Analysis rules can be exported for use by other O-Calc® Pro users, 

preventing the need to develop a new set of Clearance Analysis rules.  The export process 

makes a copy of the current Clearance Analysis rules and saves them in a location you 

specify.  The saved Clearance Analysis rules can then be imported into another users O-

Calc® Pro application and be modified as needed.    

Export Clearance Rules   

To export your Clearance Rules, complete the following steps:  

1. Select Tools > Clearance Analysis > Clearance Rules Maintenance >  

Export Clearance Rules.  

  

2. Browse to the location where you will save the Clearance Rules and click 

Save.  

3. Select OK to the export confirmation message.  

  

Import Clearance Rules   

To import Clearance Rules, complete the following steps:  

1. Select Tools > Clearance Analysis > Clearance Rules Maintenance > 

Import Clearance Rules.  

  

2. Browse to the location of the Clearance Rules file you want to import and 

select the (Clearance Rules name).crx file and click Open.  

3. Select OK to the import confirmation message.  
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Viewing the LoadCase Comparison   

When several LoadCases are attached to a pole in the Inventory Window O-Calc® Pro 

provides a LoadCase Comparison summary.  The LoadCase Comparison provides detailed 

calculations for each LoadCase and identifies and displays the worst LoadCase in the 

comparison.   

  

Create a LoadCase Comparison   

To create a LoadCase Comparison, complete the following steps:   

1. Select Tools > LoadCase Comparison.  

   
Note: A pole with more than one LoadCase needs to be displayed in the Inventory Window to enable 

the  
LoadCase Comparison option.  The pole should also have the latest calculations displaying in the Capacity  

Window.  If the Auto Capacity Summary is disabled and calculations need to be performed the 

LoadCase Comparison option will be disabled.  See Manually Updating the Capacity Window to 

manually update the calculations.  
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LoadCase Comparison Toolbar Options  

Once the LoadCase Comparison is displayed the toolbar menu provides you with a variety 

of options.  
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File. The following options are 

available from the File menu:  

Print Report. Select the Print  

Report option to print the 

LoadCase Comparison.  

Page Setup. Select the Page 

Setup option to configure how 
the LoadCase Comparison will 

be printed.  

Save to PDF.  Select the Save to  

PDF option to save the  

LoadCase Comparison as a PDF 

file.  

Save to RTF.  Select the Save to  

RTF option to save the  

LoadCase Comparison in RTF 

format.  

E-Mail Report To.  Select the E-
Mail Report To option to EMail 

the LoadCase Comparison.  

Copy to Clipboard. Select the 

Copy to Clipboard option to 

copy the LoadCase Comparison 

to the clipboard so that it can be 

pasted directly into other 

applications.  

Navigation Controls  

  

Navigation Controls. Click the 

arrow buttons to easily navigate 

through the document pages.  

Zoom Controls  

  

Zoom Controls. Use to change 

the documents magnification 

level.  

  

Working with the Strength Reduction Calculator   

The Strength Reduction Calculator allows you to calculate and apply the effective 

groundline circumference using the Osmose industry accepted strength calculations.   

Create a Strength Reduction Calculation   

To create a Strength Reduction Calculation, complete the following steps:   

1. Select Tools > Strength Reduction Calculator.  
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Note:  When the Strength Reduction Calculator is initially opened some of the fields will already 

prepopulated with information from the pole.  

  

Select any attributes you want to modify in the Strength Reduction Calculator window.  

1. Adjust the Orig. GL Circumference (if necessary).  

2. Adjust the Shell Rot Circumference (if necessary).  

  

3. To include heart rot, check the Include Heart Rot box.  

4. Enter a value to adjust the Heart Rot Shell Thickness if Include Heart Rot is 

checked.  

5. For each instance of decay or damage perform steps 6 – 10:  

  

To add a Strength Reduction due to a particular type of damage, complete the following 

steps:   
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2. Select the Reduction Type from the drop-down list.  

  

3. Enter the Width or Thickness value.  

4. Enter the Depth value.  

5. Select the Direction from the drop-down list.   

  

6. Select OK.  

7. Select the Apply Effective Circumference button. 

  

1.   Select the  Add   button  .   
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Note:  Once a Strength Reduction Calculation has been added the Calculated Effective 

Circumference will automatically be updated.  This is the value that will be used in calculating the 

groundline capacity.  

Note: The Orig. Effective Circumf  field is automatically updated to reflect the Applied Effective  
Circumference.  To set the Applied Effective Circumference back to the default value select the Clear  

Effective Circumference button       

  

8. Select Yes to apply the effective circumference.  

Edit a Damage Record in Strength Reduction Calculator   

To edit a damage record in the Strength Reduction Calculation, complete the following 

steps:   

1. Select the damage record to be edited.  

Note: Double clicking on the damage record will also open the damage record in edit mode.  

  

Updated  
Effective  
Circumference    
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3. Complete any edits that need to be made.  

  

4. Select OK.  

2.   Select the  Edit   button  .   
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Remove a Damage Record in Strength Reduction Calculator   

To remove a damage record from the Strength Reduction Calculation, complete the 

following steps:   

1. Select the damage record to be removed.  

  2.   Select the  Remove   button  .   
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Working with the Sag Tension Calculator   

The Sag Tension Calculator allows you to calculate and apply a Sag Tension to a span 

whose Tension Type is set to Static.   The Sag Tension Calculator can also be used for 

reference purposes without applying a sag tension calculation.   

Create and Apply a Sag Tension Calculation   

When working with a span that has a Tension Type of Static, complete the following steps 

to set the sag tension using the Sag Tension Calculator:   

1. Right click on the span you would like to set the sag tension for.  

2. Select the Tension of (span display name) option.  

  
Note: To use the Sag Tension Calculator as a visual tool to alter the calculations but not apply them 

to the currently selected span.   
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Note:  When the Sag Tension Calculator is initially opened some of the fields will already pre-

populated with information from the pole.    

Note: When opening the Sag Tension Calculator by selecting Tools > Tension Calculator the Apply 

to Span button is not displayed, you must right click on a span to have this option.   

  

Sag Tension Calculator Options   

The Sag Tension Calculator provides you with a variety of operations and options. The following 

options are available from the Reference menu:  

  

  

Reload References. Select 
the Reload References option 

to reload the pertinent values 

from the selected LC.    

Select Alternate Reference 

LoadCase. Select this option 

to select a different loadcase 

to reference.  

Sag to Tension  
or Tension to  

Sag mode   

Sag in feet or Tension in pounds display   
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 Load Default Values. Select 

this option to load a set of 

nominal load parameters.  

Cancel. Select this option to 

close the Reference menu 

option pop-up without taking 

any action.  

  

  

Apply to Span. The Apply to 
Span options transfers 

selected attributes back to the 
original span and optionally 

changes the tension mode.  

The menu items will reflect 
the tension mode of the 

original seed span   

Cancel. Select the Cancel 

option to close without taking 

any action.  

3. Complete any attribute modifications.  

4. Enter the Initial Sag measurement.  

5. Click Apply to Span to transfer selected attributes back to the original span 

and optionally change the tension mode.  

Note: For reference purposes the Modulus of Elasticity Calculator and the AWG to Diameter 

Conversions can also be accessed from the O-Calc ® Pro Tools> Misc toolbar menu. For 

additional information see Working with the Modulus of Elasticity Calculator or Viewing the AWG 

to Diameter Conversions.  

Working with Tension Tables  

To create a custom table with tension values for a specified span length, complete the 

following:   

1. Select the span for which you are creating a custom tension table.   

2. In the Data Entry window, change the filter to Tension Sag.   
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3. Under the Tension Type attribute, change the value to Table.   

 .   

  

5. In the Span Tension vs Length window, a graph is shown with a list of 

values, where additional length values can be associated with an applied 

tension at a specified length along the span.  

4.   Under the  Tension Table   attribute, select the  radio button  
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6. Use the Value menu to Add or Remove values. Additionally, values can be 

Sorted Imported or Exported, for use by other users or when imported from 

another source.  

   

7. Once a list of lengths is created and the tension values are set, the table can be 

saved using the save feature under the file dropdown list. Tension tables must 

be saved each time they are adjusted to apply changes in tension.   

  

Working with Sag Tension Table Generator  

To generate a Sag Tension Table, complete the following steps:   

8. Select the Tools drop-down list  

9. Select Tension Table Generator from the list to open the Sag Tension Table 

Generator window.  

10. In Step 1, Select the loadcase or loadcases to be considered in the generated 

tables using the Add Loadcase button  
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Note: Only one Loadcase can be added at a time.  

  

11. In Step 2, select the span or spans or span bundles to be considered in the 

generated table.  
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12. In Step 3, create the report by modifying the settings displayed:  

▪ Set a Start Length or starting increment.  

▪ Set an End Length or ending increment.  

▪ Set the Increment to be used.  

▪ Set the Order method to either order by loadcase or span type.  

▪ Select the temperature and sag values to display.  

▪ Select the Output Format.  

▪ Select the Mode to be used to calculate the tables.  

  

13. Select Create Tables to generate an output report.  

14. Close the tool when finished.   
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Appendix A – Installing Osmose O-Calc® Pro  
  

System Requirements   

System requirements for Osmose O-Calc® Pro include the following:   

▪ Supported Operating Systems: Windows 7 - Windows 10 (64-bit version)  

▪ 16 GB System memory  

▪ 1-2 GB min. available Storage Space  

▪ DirectX11 compatible Graphics Subsystem, hardware accelerated 3D graphics 

(dedicated/separate)  

▪ Microsoft .Net Framework version 4.7.1 or later  

▪ PDF Reader Software  

Note: Surface laptop with integrated graphics card not recommended.  

Installing Osmose O-Calc® Pro   

This page; http://www.o-calcpro.com/LineDesign/ allows registered users of O-Calc Pro 

to install and run their software.  You will need the following items:  

1. A valid and up-to-date O-Calc Pro license key.  

2. An Expiration Token.  

If you need a key or token contact Osmose email ocalcsupport@osmose.com 

before proceeding. To install/download the software at https://O-

CalcPro/LineDesign/setup.exe and run it.  

Note: It is strongly recommended that you uninstall previous versions of O-Calc before 

proceeding. You may receive a message that windows has prevented the application from 

running.  
If this happens simply click "Advanced" or "More Info" and select "Run 

Anyway". This software is fully vetted and digitally signed.  

Use the following procedure to install O-Calc® Pro:  

1. Double-click on OCalcPro_(version)_Setup.MSI to run the installation 

application.  

http://www.o-calcpro.com/LineDesign/setup.exe
http://www.o-calcpro.com/LineDesign/setup.exe
http://www.o-calcpro.com/LineDesign/setup.exe
http://www.o-calcpro.com/LineDesign/setup.exe
http://www.o-calcpro.com/LineDesign/setup.exe
http://www.o-calcpro.com/LineDesign/setup.exe
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2. When the installer Welcome screen appears, click Next.  

  

3. Review and check the “I accept the terms in the License Agreement”.  
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to a different Destination Folder then click Next.  

  

5. Click Install to begin the installation process.  

    

4.   Click   Next  to use the default Destination Folder or click Change    to browse  

License  
Agreement  
check box   
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6. When the installation is complete, click Finish to acknowledge the completed 

installation.  

  

Registering Osmose O-Calc® Pro   

Once you have installed the Osmose O-Calc® Pro application you will need to enter a 

Product Registration Key to register the application and accept the License Agreement.  To 

register the Osmose O-Calc® Pro application, complete the following steps:  

1. Open O-Calc ® Pro.  The O-Calc® Pro Product Key window is displayed.  
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2. Enter the Registration Key Code that was provided in the email you received 

from Osmose. Note:  The Registration Key Code is not case sensitive.  

  
Note:  If you have questions about the type of Product key needed for your installation, contact O-

Calc product and sales support at ocalcsupport@osmose.com.  

3. Click the Register O-Calc® Pro button.  

Note:  You can cancel out of the registration by clicking the X in the upper right corner.  However, 

you will not be able to use the Osmose O-Calc® Pro application until it has been successfully 

registered.  

Note:  The Demo Version of O-Calc® Pro restricts you from using the save, email, print or DMT 

options.   

4. When the O-Calc® Pro License Agreement window displays, scroll to the 

bottom of the license agreement while reading it carefully and check the “I 

have read and accept all of the terms of this agreement”.  

Note:  You must scroll to the bottom of the license text window to make the check box and the Accept 

button active.   

5. Click the I accept the terms in the licensing agreement box.  

  

O-Calc ® Pro Security Administration   

O-Calc® Pro limits what user levels are available based on the Windows User Group a 

person is in.  The following table lists what user levels are available to each Windows User 

Group. Users can select any User level with a  in it.  The default level is also indicated.   

  



Osmose O-Calc® Pro 7.0.1                                Confidential                                                                User Guide  

©2024 Osmose Utilities Services, Inc.                                                                                                  247  

  Access Level  Windows User Groups  

    O-Calc 

Administrators  

All Others  O-Calc 

Limited  

 

Limited       (default)  

Normal  
 (default)   (default)    

Administrative        

  

O-Calc Administrators and O-Calc Limited are the names of the actual Windows User 

Groups that need to be created to grant or limit privileges.  When placing users into 

specific security groups they need to log off and then log back onto their computers to 

ensure the proper security group settings are enabled.   

O-Calc® Pro User Level Definitions   

O-Calc® Pro offers three different user levels: normal, limited and administrative.  These 

levels allow companies to grant or restrict access to individual features within O-Calc® 

Pro.  Below is a brief description of each user level.   

• Limited – Restricts access to certain attributes and operations that if changed 

could gravely affect the data within O-Calc® Pro.  Placing a user at the 

Limited level is intended to support training, inexperienced users and 

untrained data entry personnel.   

• Normal – This is the default user level.  All attributes except those in sealed 

LoadCases can be edited at this level.  At this level the user can also unseal 

LoadCases and manipulate the Catalog items.  The user will not be able to 

manipulate the Master Catalog directly.    

• Administrative – Users at this level have access to all the features within O-

Calc® Pro including the option to manipulate Catalogs, re-seal LoadCases and 

edit read only attributes.  

Note:  If a user is in both O-Calc Administrators and O-Calc Limited groups, they will be 

considered a member of the O-Calc Administrators group.  

Change the Product Registration Key  

To change the initial Product Registration Key entry, complete the following steps:  

1. Open O-Calc ® Pro.  

2. Select Help > Enter or Change Product Key.  
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The O-Calc® Pro Product Key window is displayed.  

  

3. Enter or change the Registration Key Code. Note:  The Registration Key Code is 

not case sensitive. Click the Register O-Calc® Pro button.  

  
To verify the O-Calc Pro software version and key information installed on your device, 

follow these steps:  

1. Click to open the Help menu drop-down list.  

2. Select Help > click the About option.  
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3. Click the Details >> button to view the user details or System Info.  

4. Click OK to close the About O-Calc Pro window.  

  

Additional Resources  

Various resources contain additional information about O-Calc Pro.  These resources can 

be easily accessed by following these steps:  

1. Click to open the Help menu drop-down list.  

  

2. Select O-Calc Pro Help to be automatically navigated to various User 

Manuals at osmose.com/o-calc/help  

 

  

Help Resources available at the site are:  

• O-Calc Pro 7.0.1 Line Design User Guide (contains features and 

functionality only found in Line Design)  

• O-Calc Pro Command Bar (step by step guide to the Command features)   

• O-Calc Pro 7.0.1 User Guide (contains all O-Calc Pro features and 

functionality, excluding Line Design)  

• Intro to Custom Reports with Excel ( a guide to creating custom reports 

with Excel) 

• Html Tags Chart (contains a list of Html tags with examples) 

 

To navigate to ‘topic specific’ instructional YouTube videos on osmose.com/o-calc/video, 

follow these steps:  

https://www.osmose.com/o-calc/help
https://www.osmose.com/o-calc/video
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3. Select Help > More Information > View Informational Videos.   

 

  

To navigate to ‘topic specific’ instructional articles on osmose.com/o-calc/wiki, follow 

these steps:  

4. Select Help > More Information > O-Calc Pro WIKI.   

  

For help with submitting an issue or feature request, follow these steps:  

5. Select Help > More Information > Submit an Issue or Feature Request.   

 

6. Complete the online form and click the Submit Request button. Be sure to 

enter all the applicable information and attach any images, screen shots, and 

files.  

  
 

 

 

Appendix B – Creating a Customized View  
  

  

https://www.osmose.com/o-calc/wiki
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Understanding the Default View   

  

Within O-Calc® Pro the default location of the windows can be changed at any time.  This 

allows users to create unlimited screen layouts, which can be saved for future use in the 

Named View dropdown list  in the right corner of the Tool Bar 

menu.    

The O-Calc® Pro home page is broken into six panels.  Any of the windows within O-

Calc® Pro can be moved into any of the six panels based upon user preference. See the six 

panels below:  

   

Repositioning a Window   

To create a separate window, complete the following steps:   

1. Left click on the windows heading, hold and drag the overlaid blue window to 

its the new location or release it, to create a separate window.  

  
Note: The separate window can be dragged and dropped on to a second monitor if desired.  

To change the location of a window to a different panel, complete the following steps:   
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1. Left click on the windows heading, hold and drag the window, an overlaid 

blue window appears, hold and drag to its the new location.  

2. Place your mouse cursor in the desired docking location within the yellow and 

white navigation cross, and release.  

 

3. Below is the resulting the docking placement within the panel based on the 

right quadrant location within the navigation cross:  

 

  

Once the blue overlay window is near the center of a panel or the edge of a panel, the 

yellow and white navigation cross automatically displays.  

 

  

The docking placement options using the navigational cross for all quadrants and center 

are:  

      

Cursor is   placed  in   the  
right  q uadrant of the  
navigation cross.   

  

Window is docked at  
the right of the panel.   

  

Navigation cross appears  
when the window is  
dragged into the panel.   
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Drag the blue overlay window over the navigational cross quadrant that best interprets 

where you would like the window docked.  

When dragging a window over a navigational cross quadrant or center, the blue overlay 

window will display where the window is be docked within the panel.   

   

Note: Undo is not available.  

Save a Named View   

To save the view that you’ve created and add it to the Named View list, complete the 

following steps:   

1. Click in the Named View box.  

2. Enter a name.   

  

3. Press the Enter key to save your Named View.  

4. The view is automatically added to the list, viewable in the drop-down list.  

Delete a Named View  

To delete a Named View, complete the following steps:   

1. Select the view to be deleted from the Named View drop-down list.  

  

2. Select the Delete button  next to the Named View box.  

3. Select Yes to the Delete? confirmation message.   

Note:  Undo is not available for this operation.  

  

  

Window  
placed at the  
top of the  
panel   

Window placed at the top,  
bottom, right, or left  
quadrant within the panel.  
Or if docked at the center, it  
becomes a tab within the  
panel.    

Window  
placed at the  
bottom of the  
panel   

Window  
placed at the  
left of the  
panel   

Window  
placed at the  
right of the  
panel   
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Return to the Default Docking Layout   

To return to the default docking layout, complete the following steps:   

1. Select View > Docking Layout > Default.  

  

Refresh All Views  

To refresh all views, complete the following steps:   

1. Select View > Refresh All Views.   

  

  

    
Appendix C – Other Tools & Functions   

  

Working with the Lens Calibration Tool  
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The Lens Calibration Tool is used to determine the barrel / pin cushion distortion present 

for a particular brand of camera prior to its use in the Digital Measurement Technology 

(DMT) process.  

Enabling the Lens Calibration Tool   

To properly calibrate your camera lens, follow the 4-step process outlined in the Lens 

Calibration Tool. To enable the Lens Calibration Tool,  complete the following steps:   

1. Select Tools > Misc > Photo Measurement > Lens Calibration.  

  

  

  

Lens Calibration Tool 4-Step Process  

To complete the Lens Calibration process, complete the following steps:   

1. Select the Step 1 tab.  

2. Click the Click here to print calibration chart button and print the 

calibration chart.  

Note: You will need a printer, calibration chart, and camera whose lens you plan to calibrate to 

proceed to the next step.  

3. Click the Next button or select the Step 2 tab.  
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4. Using the camera that needs to be calibrated take a picture of the calibration 

chart that you printed out on the Step 1 tab.  

Note:  Make sure document is lying flat, tape the corners down.  Use the detailed directions 

provided on the Step 2 tab to get the best possible image.  Incorrectly taken images of the 

calibration chart will result in an incorrect lens calibration.   

5. Save the image you took of calibration chart.  

6. Click the Next button or select the Step 3 tab.  

  
7. Click the browse button  and navigate to and select the image you took of 

the calibration chart and click Open.  

8. Your image should display in the Step 3 tab.  
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9. Click the Next button or select the Step 4 tab.  

Note: Verify the Camera Make and Camera Model being displayed are correct for your camera.  

 

  

10. Click the Click here to select points button. The Lens Calibration Pick Points 

window displays.  

  

The Camera  
Make, Model  
and Sensor  
Ratio are  
automatically  
populated.    
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Begin with the outside row of points in a clockwise direction, zooming in close to place 

each pick point precisly. Using the detailed directions provided select each point until all 

points are selected on the chart in order.  

     

Select all outer  
points in a clockwise  
direction   
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11. When all points are selected, click the Done button.  

12. Click the Click here to calibrate button.  The calibration status bar displays 

the lens calibration progress.  

  

When the lens calibration is complete the Lens Distortion field will automatically be 

populated.  

 

13. Click the Click to update cameras file button.   

  

Select all inner  
points in a  
clockwise direction   

       

Lens Distortion  
is automatically  
populated once  
the cal ibration is  
completed.   
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14. Select OK to the verification message that the camera has been added to the 

supported camera database.   

15. Select Finished to close the Lens Calibration Tool.  

Working with the Calculator   

A basic calculator is provided to help with simple calculation or conversions. To access the 

calculator, complete the following steps:   

1. Select Tools > Misc. > Calculator.  

  

Working with the Modulus of Elasticity Calculator   

To create a Modulus of Elasticity (MOE) calculation for reference only, complete the 

following steps:   

1. Select Tools >Misc. > Modulus of Elasticity Calculator.  
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Note:  A pole does not need to be loaded in the Inventory Window in order to use the Modulus of 

Elasticity Calculator.  

  

2. In the Main Material Tab, Select the Material from the drop-down list.  

▪ Enter a value for % Solid, Diameter, and Young’s 

Modulus 3. In the Core Material Tab, Select the Material from the 

drop-down list.  

▪ Enter a value for % Solid, Diameter, and Young’s 

Modulus  

4. In the Insulation Tab, Select the Material from the drop-down 

list.   

▪ Enter a value for Thickness, Young’s Modulus, and check the box if 

Insulation is present.   

  

The Modulus of Elasticity (MOE) is automatically calculated.  

   

5. Select the X in the upper right corner to close the window.  

  

Note:  The Modulus of Elasticity Calculation cannot be applied to a currently loaded pole.  This 

calculation is for reference only.  
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Viewing the AWG to Diameter Conversions  

To display the AWG to Diameter conversions, complete the following steps:   

1. Select Tools > Misc. > AWG to Diameter Conversion.  

  
Note:  A pole does not need to be loaded in the Inventory Window in order to display the AWG to 

Diameter Conversion window.  
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2. Select OK to close the window.  

  

Viewing the Concrete Pole Class List  

To view the list of Concrete Pole Classes, for reference only, complete the following steps:   

1. Select Tools > Misc. > Concrete Pole Class List.  

  
Note: A pole does not need to be loaded in the Inventory Window in order to display the Concrete 

Pole Class List window.  

   

2. Adjust the Strength Factor.  

3. Select OK to close the window.  
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Viewing the Soil Class List  

To view the list of Soil Classes, for reference only, complete the following steps:   

1. Select Tools> Misc>Soil Class List. Select OK to close.  

  

RUS-based Overturn Moment Calculation  

The RUS method (RUS Bulletin 1724E-200) will take into consideration pole length, 

setting depth, and soil type.  The user will have the option to change the soil classification 
based on local known conditions and/or field data.  The tool will automatically fill in the 

overturn moment value and the O-Calc Pro calculation engine will flag the pole if overturn 
is a limiting factor for the pole model. This functionality is in support of the CPUC GO95 

Rule 94.11 (pole overturning calculation).   

Activating RUS-based Overturn Moment  

To enable the RUS-based overturn moment feature, complete the following steps:   

1. Select the pole from your 3D view or Inventory Window.  

2. In the Data Entry window, change the filter to the Overturn option.  
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3. Select a Soil Class from the list; the Overturn Moment sets to Auto.  

  
Note: The soil class number corresponds to a value for the Overturn Moment, referenced in the 

table below.   

Class  Description  Soil Constant  

Class 0  Sound hard rock; bedrock; un weathered  Soil Constant 140  

Class 1  Very dense and/or cemented sands; coarse gravel 

and cobbles  

Soil Constant 140  

Class 2  Dense fine sand; very hard silts and clays (may be 

preloaded)  

Soil Constant 140  

Class 3  Dense sands and gravel; hard silts and clays  Soil Constant 70  

Class 4  Medium dense sandy gravel; very stiff to hard silts 

and clays  

Soil Constant 70  

Class 5  Medium dense coarse sand and sandy gravels; stiff 

to very stiff silts and clays  

Soil Constant 70  

Class 6  Loose to medium dense fine to coarse sand; firm to 

stiff clays and silts  

Soil Constant 35  

Class 7  Loose fine sand; alluvium; loess clays; soft-firm 

clays; varied clays; fill  

Soil Constant 35  

Class 8  Peat; organic silts; inundated silts; fly ash; very loose 

sands; very soft to soft clays  

Soil Constant 35  

  

4. Verify that the Overturn Moment displays in the Analysis Report.  
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Deactivating RUS-based Overturn Moment  

To enable the RUS-based overturn moment feature, complete the following steps:   

1. Select the pole from your 3D view or Inventory Window.  

2. In the data entry window, set the filter to Overturn Moment.  

3. In the Overturn Moment (ft-lbs) attribute box, double-click within the box 

that says Auto, and type in the word Unset.  

  

4. Press Enter to deactivate RUS-based overturn moment calculations.  

Working with the Ruling Span Calculator  

To calculate the ruling span for reference only, complete the following steps:   

1. Select more than one span in the Inventory Window or 3D View.  

2. Select Tools > Misc. > Ruling Span Calculator.  
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Note: The Ruling Span Calculation cannot be applied to the currently loaded pole.  This calculation 

is for reference only.  

  
3. Select OK to close the window.  

  

Working with the Pole Section Evaluation  

To evaluate damage and decay on the pole for reference only, complete the 

following steps:   

1. Select Tools > Misc. > Pole Section Evaluation.  



 Osmose O-Calc® Pro 7.0.1                                    Confidential  User Guide  

 268                   ©2024 Osmose Utilities Services, Inc.  

  

2. Select Add and select a damage or decay item from drop down list.  

Note: To remove a damage or decay item from your list select the item to be removed and select 

Remove from the toolbar.  

3. Modify the damage or decay attributes.  

  
Note: The calculations are updated automatically and are not editable.  

Working with the Force Summary of Selection  

To display the force summary of the selected object(s) in the Inventory Window, complete 

the following steps:   

1. Select Tools > Misc. > Data > Force Summary of Selection.  

  
Note:  At least one object needs to be selected in the Inventory Window in order to 

display the Force Summary of Selection window.  
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2. Select OK to close the window.  

Working with the Fill Moment Table  

To display the Fill Moment Table for the pole currently displayed in the Inventory 

Window, complete the following steps:   

1. Select the Pole in the Inventory Window.  

2. Select Tools > Misc. > Data > Fill Moment Table.  

  

3. Click OK to the confirmation message.  

  
4. In the Data Entry select the Phys. Consts filter.   

5. Change the Override Moment Cap radio button to Yes.   
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6. Select the Moment Cap radio button to display the populated table.  

  

Once the Moment Capacity vs Height table is displayed the toolbar menu provides a 

variety of options:  

  

  

The following options are available 

from the File menu:  

Save. Select the Save option to save 

any modifications.  

Cancel. Select the Cancel option to 

exit the table without saving any 

changes.  
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The following options are available 

from the Value menu:  

Add. Select the Add option to add a 

new row to the table.  

Remove. Select the Remove option 

to remove a selected row from the 

table.  

Sort. Select the Sort option to sort 

the table by height.  

Import. Select the Import option to 

import a CSV file.  

Export. Select the Export option to 

export the current table values to a 

CSV file.  

7. Select the Height or Moment Cap you would like to change and enter the 

new value you would like to use.  

8. Select File > Save.  

Note: Select File > Cancel to close the Moment Capacity vs Height table without saving any 

modifications.  

Clean Temp Folder   

To clean the temp folder, complete the following steps:   

1. Select Tools > Misc > Clean Temp Folder.  

   

2. Select OK to the confirmation message.  
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Bulk Owner Edit  

To initiate bulk owner edits, complete the following steps:   

1. Select Tools > Misc. > Bulk Owner Edit.  

  

2. In the Bulk Set Owner window, enter the needed changes. Click OK.  

  

3. To make edits to Description entries, use the Bulk Description Operations 

option.  
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Change the Access Permission   

  

To change your access permission, complete the following steps:  

  

 Select Tools > User Level.  

  
Note:  The User Level can also be updated by left clicking on the User Level in the Status Bar and 

selected the preferred User Level.  

  

1. Select the desired User Level.   

2. Select OK to the confirmation message.  

  

Note:  The current User Level will automatically be updated at the bottom of the Status Bar.    

Note: Changes to the User Level are per O-Calc® Pro session.  Any changes to the User Level are 

not permanent. For additional information on O-Calc® Pro Security Level, see O-Calc ® Pro 

Security Administration.  
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Misc. Options  

Changing the Unit Convention  

To change the unit convention, complete the following steps:   

1. Select Options > Unit Convention.  

  
Note:  English is the default unit convention when the application is initially installed.   

Changing Pole Saved Confirmation Message  

To change if the “Pole Saved” confirmation message displays, complete the following 

steps:   

1. To enable\disable the Pole Saved confirmation message option, select Options 

> Misc. Options > Display “Pole Saved” Confirmation.  
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Note:  The Display “Pole Saved” Confirmation option is enabled by default.   

Note:  When the Display “Pole Saved” Confirmation option is enabled a check mark will display 

next to the menu option.  When the option is disabled the checkmark is not displayed.   

Dividing Add Menu Items by Category  

To change how the “Add Element” menu is displayed, complete the following steps:  

1. To enable\disable the Divide Add Menu Items by category option, select 

Options >  Misc. Options > Divide Add Menu Items by Category  

Note: Disabling the divide add menu option displays all elements to be added to an item in one list.   
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Changing the Inventory Window Tool Bar Display  

To change if the Inventory Window toolbar displays text next to each image, complete the 

following steps:   

  

1. To enable\disable the text that displays next to each image in the Inventory 

Window toolbar, select Options  > Misc. Options > Show Text and Images 

in Inventory Menu.  
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Note:  When the Show Text and Images in Inventory Menu option is enabled a check mark will 

display next to the menu option.  When the option is disabled the checkmark is not displayed.   

Changing the Visual Style  

The O-Calc Pro interface displays in a blue, flat visual style by default. To change to a 

different display style, complete the following steps:  

1. Select View >Theme > make your desired selection from the available options.  

   

Changing the Mouse Wheel Functionality  

To reverse the mouse wheel direction, complete the following steps:  

1. Select Options > Misc. Options > User Interface Conventions > Invert 

Mouse Wheel.  
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Note: The Invert Mouse Wheel function affects the 3D View, Bird’s Eye View, Perspective Camera 

and Top View only.  

Modifying the Spans Default Rated Strength Percentage  

When a span is added from the Master Catalog where the tension mode is “Static” or 

“Manual” a default percentage of a spans rated strength is used to calculate the span’s 

tension.  The default percentage for each type of span can be changed at any time by 

completing the following steps:  

1. Select Options > Misc. Options > Percent of Span Rated Strength to Apply 

as Tension.  

  

 

2. Select the Span’s Percent you would like to change and enter the new default 

percentage you would like to use for the selected span.  

Note: To load a previously saved Percent of Tension set select the Import button   and 

browse to the location of the file.  
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Note:  This value will not be applied if the span is a subcomponent of complex assembly.  

3. Select the Export button  to save the currently displayed set of 

percent of tensions value to a file.  

4. Select OK.  

Note:  To revert the entire listing of span percentages of Rated Strength back to their default values 

select Restore Default Values.  

Working with the Pole Archive History  

The Pole History Archive provides an audit trail of the changes made at each save point.  

When the Pole History Archive option is enabled, each time you save changes to a pole a 

snapshot of that pole is created and stored as a history record.  Each history entry records 

who made the changes and when they were made.  By retaining a history of each time, a 

pole has been saved, you are able to review previous revisions to a pole and even revert to 

a pole’s previous revision.  To enable the Pole History Archive, complete the following 

steps:   

1. Select Options > Misc. Options > Save Pole History Archive.  
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Note: When the Save Pole History Archive option is enabled a check mark will display next to the 

menu option.  When the option is disabled the check mark is not displayed.  

2. Create a new pole in the Inventory Window and save the pole using the File > 

Save Pole option.  

 

The first time the pole is saved a Pole History Archive file is created.    

3. To review the pole’s history archive, select File > More Options > Open 

Archived Pole.  Browse to the location of the saved pole and select the (pole 

name).pplx file.  

Note: The Open Archived Pol e option is only visible when the Save Pole History Archive option is 

enabled.  

    

  
New pole  
created in the  
Inventory  
Window   
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4. Complete modifications to the current pole in the Inventory Window and save 

the pole using the File > Save Pole option.  

  

 

  

The Revision History area is automatically updated.  

5. To review previous revision to a pole or to revert a pole to a previous version, 

select File > Open Archived Pole.  Browse to the location of the pole you 

wish to work with and select the (pole name) .pplx file.  Select the Revision 

History record you would like work with.  

Saved pole’s initial Revision History entry   

  

  

  

  

  

  

  

    

    

  

Active pole with  
objects added    
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6. Select Open Archived Version.  

  

The selected Revision History snapshot is loaded in the Inventory Window and can be 

reviewed.  The pole is completely editable at this time and it can be modified and saved.  If 

the revision is saved, it will then become the active version of that pole and replace the 

.pplx file.  For safety, a new revision history record will be added at that time that stores a 

snapshot of the previously saved version of the pole.   

Changing the Auto Save  

By default, the Auto Save option is set to Never, to select an auto save interval based on 

the number of edits made, complete the following steps:   

1. Select Options > Misc. Options > Auto Save: Never > open the drop-down 

and select an available option from the menu.  

  

  

  

    

Select  
the  
revision  
history  
file   

Select the (pole name).pplx file   
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Setting the Idle Time Interval  

To set the idle time before calculations are calculated, complete the following steps:   

2. Select Options > Misc. Options > Idle Timer Interval (currently set time).  
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3. Enter the Idle Timer Interval in milliseconds.  

   
Note: The Idle Time Interval can be set to a minimum 1000 milliseconds and a maximum of 5000 

milliseconds.  

Note: The Auto Capacity Summary option needs to be enabled for the Idle Timer to activate.    

4. Select OK.  
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Displaying Assemblies in the Tree View  

In the Catalog by default, equipment assemblies are not displayed in the tree view, unless 

they are directly under a folder.    

 

To display assemblies without regard to where they display in the tree view, complete the 

following steps:   

1. Select Options > Misc. Options > Assemblies Shown in New and Subst 

Trees.  

   

 

  

  

With the option  
disa bled   the  
equipment  
needs to be  
directly under a  
folder to display  
in the tree view.   
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Note: When the Assemblies Shown in New and Subst Trees option is enabled a check mark will 

display next to the menu option.  When the option is disabled the check mark is not displayed.  

Setting Height After Assembly Drop  

To set the height of equipment or an assembly being dragged onto the current pole from a 

catalog, complete the following steps:   

1. Select Options > Misc. Options > Set Height After Assembly Drop.  

  

 

2. Select the Set at automatic height recommendation.   

  

3. Or select the Edit Height option, and in the Edit window enter a Height 

value. Click OK.  
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Note: When the Set Height After Assembly Drop is selected the height adjustment window will 

display each time a drag-and-drop operation occurs from a catalog.  The height value displayed is 

the pole attachment height of the topmost item of the assembly.  All other items will be adjusted 

relative to the topmost attachment height.  

Buffering in Image Measurement  

O-Calc ® Pro uses an off-screen bitmap buffer to reduce redraws flicker of the photo 

measurement screen.  This option requires a large amount of system memory.  On 

computers where memory levels or CPU performance do not meet the stated O-Calc ® Pro 

requirements this option may be enabled in an attempt to reduce memory consumption and 

increase performance at the expense of increased image flickering.  To enable double 

buffering in the Measurement Window, complete the following steps:   

1. Select Options > Misc. Options > Double Buffer in Image Measurement.  

   

 
Note: When the Double Buffer in Image Measurement option is enabled a check mark will display 

next to the menu option.  When the option is disabled the check mark is not displayed.  
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Note: To review a complete list of O-Calc ® Pro system requirements, see System Requirements.  

Enabling 3D Hardware Acceleration  

O-Calc ® Pro uses the advanced graphical processing unit of the graphics card to 

accelerate 3D rendering and processing.  This feature requires that the graphics card meet 

WDDM 1.0 or higher and be fully Direct 3D compliant.  If your graphics card does not 

meet those requirements you may disable the use of 3D hardware acceleration.  This will 

result in severely reduced 3D rendering performance.   

This feature is enabled by default. To disable the 3D Hardware Acceleration, complete the 

following steps:   

1. Select Options > Misc. Options > deselect the Enable 3D Hardware 

Acceleration option, to disable it.  

  

 
Note: When the Enable 3D Hardware Acceleration option is enabled a check mark will display next 

to the menu option.  When the option is disabled the check mark is not displayed.  

Changing the Keyboard Delete Confirmation Message  

When deleting objects in the Inventory Window using the delete button on your keyboard 

a delete confirmation message is displayed.  This message is enabled by default.  To 

change if the delete confirmation message displays, complete the following steps:   

1. To disable the Delete confirmation message select Options > Misc. Options > 

Warn on Keyboard Delete.  
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Note: When the Warn on Keyboard Delete option is enabled a check mark will display next to the 

menu option.  When the option is disabled the check mark is not displayed.  

Copying Values from the Data Entry Window  

The copy value feature allows you to easily copy values or value sets from the Data Entry 

Window onto the clipboard.  To use this feature, complete the following steps:   

1. To enable/disable the copy to clipboard on item click option select Options > 

Misc. Options > Automatic Copy to Clipboard on Item Click.  
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2. In the Data Entry select any attribute value to copy, right click to paste to 

clipboard.  

 

Note:  Only one attribute per copy.  To copy both the header and attribute, select the header.  

  

3. If the Automatic Copy to Clipboard on Item Chick is disabled, you can use 

the Ctrl + C to copy any attribute value or data entry header, Ctrl + V to paste 

to clipboard.  

Data Entry Header  Selecting the Data Entry Header 

then selecting Ctrl + C will copy 

all the objects and attribute values 

within the selected category to the 

clipboard.  

  

Streetlight  -   8  ft. Arm   
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Object  Selecting an object then selecting 

Ctrl + C will copy the object value 

and the objects attribute value to 

the clipboard.  

Attribute  Selecting an attribute then 

selecting Ctrl + C will copy the 

attribute value to the clipboard.  

  

Switching Views Using Function Keys  

To easily switch between the O-Calc ® Pro views keyboard shortcuts and function keys 

have been enabled.  To work with these features, complete the following steps:   

  

1. To enable/disable the Enable Shortcut and Function Keys option select Options 

> Misc. Options > Enable Shortcut and Function Keys.  

  

  

  

Note: When the Enable Shortcut and Function Keys option is enabled a check mark will display 

next to the menu option.  When the option is disabled the check mark is not displayed.  
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Shortcut and Function Keys capabilities are:  

F1  Press F1 to switch to the 3D View.  

F2  Press F2 to switch to the Charts View.  

F3  Press F3 to switch to the Data Entry Window.  

F4  Press F4 to switch to the Measure Window.  

F5  Press F5 to switch to the Reports Window.  

F6  Press F6 to switch to the Inventory Window.  

F7  Press F7 to switch to the Heat Map Window.  

CTRL + F7  Press CTRL + F7 to switch to the Capacity Window.  

F8  Press F8 to switch to the Schematic Window.  

F9  Press F9 to switch to the Top View Window.  

F11  Press F11 to save the current changes.  

F12  Press F12 to switch the 3D View to the Bird’s Eye 

View.   

Insert  Pressing the Insert button while an object is selected 

in the Inventory window will display a shortened list 

of convenient features.   

(Example: Add objects, select  multiple objects and 

add notes)  

CTRL + Insert  Press CTRL + Insert to modify an insert.  

CTRL + ?  Press CTRL + ? to switch to the Find Menu Item 

Window.  

Delete  Press the Delete button to delete objects in the 

Inventory Window.  

  

Working with the Stub Pole Menu Options  

While performing analysis on stub poles several options are automatically enabled.  O-

Calc ® Pro allows you to adjust which of these options you would like enabled or 

disabled.    
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Enabling Create as New Pole for Stub Pole  

To enable/disable the right click menu options to create a new stub pole as a new pole 

analysis, complete the following steps:   

1. To enable/disable the Create as New Pole option select Options > Misc. 

Options > Stub Pole Options > Create as New Pole Enabled.  

  

 

  

Note: When the Create as New Pole Enabled option is enabled a check mark will display next to the 

menu option.  When the option is disabled the check mark is not displayed.  

Note: At least one of the Stub Pole “Create” options needs to be enabled.  

  

Enabling Create as New Version for Stub Pole  

To enable/disable the right click menu option to create a new version of the existing stub 

pole, complete the following steps:   

1. To enable/disable the Create as Version Enabled option select Options > Misc. 

Options > Stub Pole Options > Create as Version Enabled.  
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Note: At least one of the Stub Pole “Create” options needs to be enabled.  

Enabling the Auto-Guy for Stub Pole  

To enable/disable the right click menu option to automatically auto guy a new stub pole, 

complete the following steps:   

1. To enable/disable the Auto Guy Stub Pole option select Options > Misc. 

Options > Stub Pole Options > Auto Guy Stub Pole Enabled.  

Automatically Display Error Tab  

To display any error(s) in a separate tab, that causes the calculation engine not to complete, 

complete the following steps:  

1. Select Options > Misc. Options > Show Error Tab Automatically.  

  

 

 

Override Auto Setting of Wind Drag Coefficient 

Override Auto Setting of Wind Drag Coefficient enables users to override wind drag 

coefficient values.  By default, the override setting is off, and the O-Calc Pro application 

will automatically adjust the Wind Drag Coefficient based on the shape of the equipment 

to value of 1 for cylindrical objects and a value of 1.6 for cubic objects. 

To override the default wind, drag coefficient, complete the following steps: 

1. Select Options > Misc. Options > Override Auto Setting of Wind Drag 

Coefficient. 
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Note: When the ‘Override Auto Setting of Wind Drag Coefficient’ option is enabled a check mark is 

displayed next to the menu option. Entering a value of zero in the Data Entry returns the option to 

the default mode of ‘Auto’. 

 

2. Select an object and in Data Entry change the Wind Drag Coef. Value to a 

number between 0 and 1. 
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Managing Plugins  

Plugins add extra features and functionality to the core of the O-Calc Pro software 

offerings. Plugins provide the ability to customize tasks and gather needed information. To 

work with available plugins, complete the following steps:  

1. Select Options > Manage Plugins.  

  
Note: The available list of plugins is dependent on the customer’s installation.   

2. Select any plugins you would like to enable, by clicking in the corresponding 

box to place a check mark.  

   

3. Click the Apply button.  
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4. Click Yes to the Restart? message.  

  

  

  

Working with Catalog Configurations  

  

O-Calc® Pro allows the user to configure and utilize multiple Master and User Catalogs.   

Each catalog configuration displays independently within O-Calc Pro.  The Catalog 

Configuration tool allows you to add, remove and edit any catalog configurations.  

Working with Catalog Configuration  

To open the catalog configuration window, complete the following steps:   

1. Select Tools > Catalog Maintenance > Configure Catalogs.  
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Note: A default Master and User Catalog are provided upon installation of O-Calc Pro. Download 

additional Catalogs as desired. Use the Add, Remove and Edit Catalog buttons as needed.  

Adding a Catalog   

To add a catalog, complete the following steps:   

1. Select the Add Catalog button .  

  

2. Enter the catalog Name.  

  

3. Select the catalog Type from the drop-down list.  

Note: Master Catalogs have blue folders and cannot be edited, User Catalogs have yellow 

folders and can be edited.   
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4. Select the Catalog Path browse button  to browse to and select the catalog 

file and click the Open button.  

5. The State Path is automatically populated. Or you can use the browse button 

 to browse to and select the catalog expansion file you would like to use 

and click Open.  

6. In the Catalog Configuration window, click OK to close.  

Note: There is no undo for this operation.  

 

7. Click OK to close the Catalog Configuration window.  

Editing a Catalog   

To edit a catalog configuration, complete the following steps:   

1. Select Tools > Catalog Maintenance > Configure Catalogs.  

2. Select the Catalog you would like to edit.  

    

  

  

New Master Catalog  
is added.   
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4. Complete any modifications to the catalog configuration.  

  

5. Click OK to close the Add Catalog Entry window.  

Note: There is no undo for this operation.  

6. Click OK to close the Catalog Configuration window.  

7. Click OK to the Restart Required message.  

Removing a Catalog  

To remove a catalog configuration, complete the following steps:   

1. Select Tools > Catalog Maintenance > Configure Catalogs.  

2. Select the Catalog you would like to delete.  

3. Select the Remove Catalog button .   

4. Select Yes to the remove confirmation message.  

Note: There is no undo for this operation. These customizations can only be restored by reverting to 

a previously saved backup of the Master Catalog.   

Note: Backup versions of the Master Catalog can be obtained by selecting Help > Folders > User 

Root Folder > Catalog Backup. For additional information on restoring a backup version of the 

Master Catalog see Working with Catalog Backups.  

Downloading New Catalogs  

To download the latest version of a catalog, complete the following steps:  

1. Select Tools > Catalog Maintenance > Configure Catalogs.  

2. In the Catalog Configuration window, select the Download Catalog(s) button.  

3. Launches a Web Browser that navigates to https://www.osmose.com/o-

calc/catalogs  

3.   Select the  Edit   Catalog   button  .   

https://www.osmose.com/o-calc/catalogs
https://www.osmose.com/o-calc/catalogs
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4. Select a catalog to download – clicking on it will begin the download, close 

web browser when the download completes.  

5. User will be prompted to choose a save location.  

▪ If saving in same location as older versions of a catalog, this action 

overwrites the older version.   

6. In O-Calc, select Tools > Catalog Maintenance > Configure Catalogs  

7. Use the Add Catalog button.  

  

Working with Sealed LoadCases  

  

The LoadCase element contains the environmental and convention parameters required to 

codify such things as the standards body being used, the local wind and ice conditions, 

overload factors to be applied in different conditions, and to different element types, etc.  

Arguably the LoadCase is the most critical element in O-Calc® Pro, and the one that must 

be controlled and manipulated with the most care, and by the most qualified personnel.  

For this reason, O-Calc® Pro adds an extra layer of protection to LoadCase elements 

referred to as LoadCase Sealing.  

O-Calc® Pro provides a set of sealed LoadCases pre-shipped in the Master Catalog that 

contain the correct parameters for all commonly encountered NESC and GO95 conditions, 

including extreme wind and extreme load.  These LoadCases cannot be modified by any 

user regardless of their user level.  They are “Sealed” against modification.  

A user of “Normal” or higher level can unseal a COPY of a sealed LoadCase and make 

modifications to that copy.  The resulting custom LoadCase can be placed in the User 

Catalog for future use or modification.  

A user of “Administrative” level can additionally re-seal a LoadCase and place the newly 

sealed LoadCase back into the Master Catalog for use by any other user(s).  Such a user 

may also re-seal a LoadCase that is located in the Catalog in an unsealed form.  

The remainder of this section details the steps involved in unsealing or re-sealing 

LoadCases.  

Unsealing a LoadCase  

To unseal a LoadCase in the Inventory Window for modifications, complete the following 

steps:   

Note: LoadCases should only be unsealed and modified with extreme caution.  Modifying 

LoadCase attributes will affect O-Calc® Pro calculations.   

1. Right click on the LoadCase to be unsealed in the Inventory Window and 

select Unseal this LoadCase.  

Note: LoadCases cannot be unsealed in the Master Catalog.  To add a LoadCase from the Master 

Catalog see Adding Load Cases to a Pole.  
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2. Select Yes to the confirmation message.  

  
Note: To undo the unsealing of the LoadCase, select Edit > Undo.  

3. Select File > Save.  

Once the LoadCase is unsealed you can modify the LoadCase attributes using the Edit 

option in the Inventory Window or the Data Entry.  For additional information on editing 

attributes see Editing Equipment Attributes.  

If you need to use the unsealed LoadCase for future use or modifications copy the 

LoadCase to a specific User Catalog folder.  To copy the unsealed LoadCase to a User 

Catalog folder left click on the LoadCase in the Inventory Window and drag it to a specific 

User Catalog folder.  

Re-Sealing a LoadCase   

Only users with Administrative privileges can re-seal an unsealed LoadCase. To re-seal 

and prevent additional modification to the LoadCase, complete the following steps:   

  

  



Osmose O-Calc® Pro 7.0.1                                Confidential                                                                User Guide  

©2024 Osmose Utilities Services, Inc.                                                                                                  303  

1. Right click on the LoadCase to be re-sealed in the Inventory Window and 

select Reseal this LoadCase.  

  

2. Select Yes to the confirmation message.  

 Note: To undo the sealing of the LoadCase, select Edit > Undo.  

3. Select File > Save.  

Locating O-Calc® Pro Folders   

To easily access O-Calc ® Pro user and common folders, complete the following steps:   

1. Select Help > Folders.  

   

2. Select the folder you need access to.  

Working with Jumper Cables  

Jumper cables can be generated between two insulators on a pole, or between an insulator 

and a terminal point.   

Creating a Jumper on a Double Dead-end  

To Jumper between two dead-end insulators follow the following steps:  

  

1. Select the first dead-end. In the data entry panel, filter the view to ‘jumper’ to 

see only the relevant information on jumpers  

2. In the first row, called JumperID, name the jumper to be created.  
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3. Now select the second dead-end. This dead-end will be the target dead-end for 

the jumper cable  

4. In the second row of the data entry panel, the Jumper Targ ID, type the name 

of the jumper from before. You should see the jumper appear in the 3D View 

after entering the jumper name.  

  
  

  

Using the Split and Jumper Option  

Instead of creating a jumper through the data entry panel as described above, the user can 

instead use the split and jumper method. For this tool the following conditions need to be 

met.  

1. There is only one dead-end insulator required  
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2. That dead-end insulator has two spans attached to it, in opposite 

directions To use this method, simply right click on the dead-end insulator and choose 

the split and jumper insulators option shown below.  

  
Development Information  

Retrieving Reference Information  

O-Calc® Pro contains a number of reports containing reference information.  Catalog and 

schema information is provided for developers.  Details of the values available to the 

reporting system are available for custom report authors.  Raw reports of data and 

calculated forces are all available to assist in the understanding of pole loading.  These 

utilities are intended for software and report architects and as such they are of limited use 

to general users.  To access the reference information, complete the following steps:  

1. Select Tools > Misc.  

There are four reference reports available:  

• Schema Explorer (PDF or HTML Format)  

• Dump Reporting Parameters  

• Dump Forces Detail Report  
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2. Select the reference report you would like to run.  

Note: These schemas can be enabled by setting the ‘SchemaAndForces’ value to try in the registry.  

The registry path is HKEY_CURRENT_USER>Software>PPL>Dump.  

Creating Custom Loading Districts   

In certain situations, it may be necessary to use custom loading districts within the O-

Calc® Pro application.  Creating a custom loading district file will replace the O-Calc® 

Pro default loading district values.  If you need any of the default loading district values, 

you will need to manually add them to your custom loading district file.    

Load Cases that currently use the O-Calc® Pro default loading districts will not be 

overwritten when a custom loading district file is created.  If you need pre-existing loading 

districts changed you will need to manually edit these LoadCases.  A LoadCase district can 

only be changed in an unsealed LoadCase.   

Note: For additional information on editing unsealed LoadCases see Working with Sealed 

LoadCases.  

To create a custom loading district file, complete the following steps:  

1. Open Notepad.  

2. Create a list within Notepad of the custom loading districts.  

•   Dump Catalog   
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3. Select File > Save.  

4. Save in \Documents and Settings\All Users\Application Data\OsmosePPL.  

Note: Read and write permission will be needed to the OsmosePPL directory. This directory can 

also be accessed by selecting Help>Folders>All Users Root Folder from within O-Calc Pro.   

5. Enter the File name as “customloadingdistricts.txt”.  

  

  

Note:  Once the customloadingdistricts.txt file has been created and saved to the correct location 

the OCalc® Pro application will automatically utilize this file.  O-Calc® Pro will need to be 

restarted for the changes to take effect.    

 To restore the default loading district values simply remove the customloadingdistricts.txt file from 

the OsmosePPL directory. O-Calc® Pro will need to be restarted for the changes to take effect.  

Working with Catalog Backups  

Each time changes are made to a catalog a backup of the catalog is automatically created 

when the current session is closed.    O-Calc ® Pro retains up to 10 backups of each 

catalogs, automatically deleting the oldest as new ones are created. By retaining a backup 

of each time, the catalog(s) are changed by session it allows you to revert to a previous 

catalog in case a change was done in error.   

Backups of the catalogs are easily accessible from within the O-Calc ® Pro application.  

The backups are located in a CatalogBackup folder wherever catalog files are located.     

Some of your catalog backup files can quickly be located using the links under the Help > 

Folders > User Root Folder.  

Each catalog backup file provides the date and time that the backup file was created right 

in the file name.    
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(Catalog Name).pplc.02_12_2016_08_03_18.Backup  

  

   Catalog Name          Date   Time  

To revert to a previous version of a catalog, complete the following steps:  

Note: The steps below are for reverting to a previous catalog.    

1. Open the catalog folder that has the catalog that you need to revert.  

2. Open the CatalogBackup folder.  

3. Select and copy the backup file you need to revert to.  

4. Edit (open) the Catalog Data Path that your current catalog resides in (the 

one you want to replace).  

Note: The Catalog’s Data Path is located in the Catalog Configuration window.  The Catalog 

Configuration window can be accessed by opening Tools>Catalog Maintenance>Configure 

Catalogs.  

5. Rename the catalog that resides in this folder.  

6. Copy the Catalog Backup file you copies in step 4.   

7. Edit the catalogs name by removing the Date, Time and the word Backup.  

8. O-Calc® Pro application will need to be closed and reopened before the 

change will take effect.   

Catalog Maintenance Mode  

O-Calc® Pro provides a Catalog Maintenance Mode that enables administrators to 

complete modifications within a catalog.   The Catalog Maintenance Mode allows anyone 

with administrative privileges to have full editing capabilities to all catalogs.  All attributes 

included attributes that are normally un-editable can be edited in this mode. This mode 

should only be accessed by the most qualified personnel as all changes are permanent once 

they are saved.   When the Catalog Maintenance Mode is activated, only modifications 

within the Catalog Window are permitted.  All options within O-Calc ® Pro that do not 

pertain to the Catalog Window are disabled until you have exited the Catalog Maintenance 

Mode.    

To use the Catalog Maintenance Mode, complete the following steps:  

Note: Only a person with Administrative privileges can access the Catalog Maintenance Mode.  

1. Close any pole that is opened in the Inventory Window File > Close Pole.  

2. Select Tools > Catalog Maintenance > Maintenance (Bulk Edit) Mode.  

Note: When the Maintenance Mode is enabled a check mark will display next to the menu option.  
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3. Select Yes to continue in Catalog Maintenance Mode.  

Note: The Status Bar will turn yellow and clearly indicate that the Catalog Maintenance Mode is active.    

4. Complete your modifications to the catalogs.  

Note: There is no undo option available.  

5. Deselect the Tools > Catalog Maintenance > Maintenance Mode option.  

  

6. Select Yes to save your changes.  

  

  

  

  

  

  

  

  

  

  

  

  

Appendix D – 3D Navigation Enhancements   

Using the Default and Alternate Control Scheme  
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Previous 3D View Controls included in our older versions of O-Calc Pro, restricted the 

camera to a cylindrical orbit 20,000 inches away from the centerline of the pole. 

Traditionally, the camera could move to a point on that cylinder only, and zooming was 

accomplished by changing the camera’s field of view. Panning was only possible along a 

vertical axis. But depending on field of vision (FOV) this made the ability to visualize 

other locations, i.e. adjacent poles, limited and hard to understand.  

  

In the 7.0.1 version of O-Calc Pro we have added 2 new control sets; Default and 

Alternate, which should make 3D navigation much more intuitive for users.   

  

To accompany these new control sets new filters and a Camera Look Point icon as been 

added in the form of a pink ball at the center of the 3D View window.  

  

Camera Look Point  

The pink “ball” icon represents the camera “look point”. The ball icon is displayed in the 

center of the 3D View.  

  

• To locate the Camera Look Point (hidden from view behind the pole) right 

click in the 3D View and drag left or right to reveal the ball icon.  

 

  

• To orbit around the Camera Look Point, right click your mouse and drag the 

3D View in a circular motion, around the Camera Look Point.  
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• To return the pole to the center of the 3D View, click the R (Reset) button.  

   

Note: When hovering the mouse over the camera look point and zooming in, the camera look point 

ball becomes enlarged. Simply hit the “R” to restore the ball icon to its original size.  

Alt Key Controls  

The use of additional key controls allows users greater range of motion capabilities within 

the 3D View. To try the movement actions, follow these steps:  
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1. Hold the Alt key and left click mouse on any object to move to that selected 

point.  

  
2. Release the Alt key to view the additional move options.  

  
3. Select the Near End of Span option.  

  
4. Select the Far End of Span option.  
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5. Select the Midpoint of Span option.  
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Alt and Shift Key Controls  

By using a left click you can move the camera, a right click action moves the camera look 

point. To try the movement actions, follow these steps:  

  

1. Hold the Shift key and drag the cursor to turn the look point up or down.  

   
2. Hold the Alt key turns the “X” direction off.  
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3. Hold the Alt and  mouse wheel casing a “trucking” motion which brings the 

camera forward or backward. This motion is especially useful when navigating 

in Line Design through a long line of poles.  

   

Alternate Control Scheme  

The Alternate Control Scheme was developed to make navigating in Line Design to 

multiple poles easier for users. These controls are based on 3D Modeling Industry 

standards.  The controls are divided into two sets; the Default Control set and Alternate 

Control set. To activate the Use Alternate Control Scheme option, follow these steps:  

  

1. From the Options menu, select Camera, and click the Use Alternate Control 

Scheme option.  

  

  

   

Note: Deselect (uncheck) the Use Alternate Control Scheme option to return to the Default Control 

set of controls.  
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Default Control Set  

Press the left mouse button and drag in the following directions:  

Mouse Direction  Resulting Effect in 3D View  

Left or Right  Movement turns the camera look point around in 

cylindrical rotation  

Up or Down  Moves the camera AND look point up or down equally  

Holding "Alt" key down  

  

Left and Right movement does nothing  

Up Down movement works as expected  

Holding "Shift" key down  

  

Left and Right movement works as expected  

Up and Down moves ONLY the camera (tilt)  

Holding "Shift" and "Alt" 

keys down simultaneously  

Move the mouse to cause a rocking motion in 360 

degrees  

  

Press the right mouse button and drag in the following 

directions:  

Mouse Direction  Resulting Effect in 3D View  

Left or Right  Orbits the camera look point around the camera (pan)  

Up or Down  Moves the camera AND look point up or down equally  

Holding "Alt" key down  

  

Left and Right movement does nothing  

Up Down movement works as expected  

Holding "Shift" key down  

  

Left and Right movement works as expected  

Up and Down moves ONLY the look point  (reverse 

tilt)  

Holding "Shift" and "Alt" 

keys down simultaneously  

Move the mouse to cause a forward and backward 

motion in 360 degrees  

  

Press the mouse wheel button and drag in the following 

directions:  

Mouse Direction  Resulting Effect in 3D View  

Forward  Moves the camera towards the look point (zoom in)  

Backward  Moves the camera away from the look point (zoom out)  
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Holding "Alt" key down  Forward - moves camera AND look point in look 

directions (dolly)  

  Backward – moves camera AND look point away from 

look direction (reverse dolly)  

Left Click  

Left click and Alt key  

Moves up, down, left, right, orbits around 360 degrees  

Moves look point to element clicked (if any)  

Right Click  Moves up, down, left, right, orbits around 360 degrees  

  

  

Alternate Control Set  

Although the alternate control set is based on current 3D modeling standards, it was a 

significant deviation from traditional O-Calc Pro controls, therefore it was decided against 

being the default control set.   

Press the left mouse button and drag in the following directions:  

Modifier Keys  Resulting Effect in 3D View  

None  X = Orbits Camera around the Look Point  

Y = Raises and Lowers the Camera Look Point  

Alt Key  X = Orbits Camera around Look Point  

Y = Raises and Lowers Camera only but NOT 

Look Point  

Shift Key  

  

X = Orbits Look Point around Camera  

Y = Raises and Lowers Camera only but NOT 

Look Point  

Holding "Shift" and "Alt" 

keys down simultaneously   

X = Orbits Camera around Look Point  

Y = Raises and Lowers Look Point but NOT Camera  

  

Press the right mouse button and drag in the following directions:  

Modifier Keys  Resulting Effect in 3D View  

None  X = Moves Camera and Look Point Perpendicular 

to Look Direction  

Y = Moves Camera and Look Point Parallel to 

Look Direction  
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Shift Key  X = No action  

Y = Moves Camera Towards or Away from Look 

Point (Zoom)  

Press the mouse wheel button and key below to drag in the following 

directions:  

Modifier Keys  Resulting Effect in 3D View  

None  Moves Camera Towards or Away form Look Point 

(Zoom)  

Shift Key  Raises and Lowers Camera and Look Point  

Alt Key  

  

Raises and Lowers Look Point but NOT Camera  

Shift and Alt Key  Raises and Lowers camera only but NOT Look Point  

  


