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Osmose O-Calc® Pro Line Design Overview 

About Osmose O-Calc® Pro Line Design 
Osmose O-Calc® Pro Line Design automates the calculation of structural loading on new and 

existing lines of utility poles. The Line Design enhancement of O-Calc Pro can be used for full line 

design, network extensions design, full circuit loading analysis, make ready engineering work 

and clearance analysis issue detection and correction.  

With O-Calc Pro Line Design, one can analyze an entire circuit (line of poles). As with previous 

versions of O-Calc Pro, non-structural engineers can decide whether more cables can be added 

or larger conductors can be used on existing pole lines. The calculations in O-Calc® Pro Line 

Design are complex, but the operator interface is designed for simplicity of use. In addition to 

technical load calculations and statistics, this application provides a configurable, three-

dimensional visual rendering of each utility line’s load conditions and environmental conditions.  

O-Calc® Pro Line Design can be used to evaluate the integrity of an entire line of poles and each 

pole within the line. It can quickly assess the impact of re-conductoring, by automatically 

stringing new spans up to each pole in a line. The O-Calc® Pro analysis of stress along the length 

of the pole for each pole in a line can be used to consider cost-effective alternatives to replacing 

overloaded poles.  

O-Calc® Pro Line Design is a powerful new resource in evaluating structural load for joint use, 

safety, network reliability, and network planning purposes.  

Osmose O-Calc® Pro Line Design Concepts 
Osmose O-Calc® Pro allows you to model a line of utility structures (wood, steel, or concrete 

poles) by defining the components of each structure using the Inventory Window or 

interactively constructing the line of structures in the 3D View and Line Design View. All 

methods can be used simultaneously. There are several methods that can be used to create a 

line of poles, each starting with predefined components from the Master or User Catalogs.  
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Understanding the O-Calc® Pro Line Design Workspace 
 

Workspace Windows 
and Tabs 

Description 

Line Design Tab New user interface area specifically for the Line Design Features in O-
Calc® Pro Version 6.0 and higher. 

Line Design Tab Area Where the Line Design specific tabs are found, and where the 
associated information for each can be viewed. Includes Poles, GIS 
Files, Map, and Clearance tabs.  

Main Line Design Area Menu options on the Main Line Design area are related to opening, 
closing, and modifying the entire line, or segments of that line.  

Poles Tab The Poles Tab has menu options for adding, editing, or removing poles 
within the Line Design. 

GIS Tab Where a User can add GIS files, including Shapefiles and GeoJson files. 
Once added, a list of the added files is shown plus a check to enable or 
disable each layer. 

Map Tab Map options that can be displayed, including public domain maps 
such as OMV Tiles and Open Street Maps. Other subscription services 
are available, like Bing maps and Google Maps.  
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Understanding the O-Calc® Pro Line Design Menus 

Main Line Design Area Ribbon – Functions  
This section of the user guide reviews various functions that can be performed from the Line Design 

menu. 

 

 

 

Collapses or Expands the Line Design area which 
shows the poles on a background map. This 
feature is helpful for expanding the map area. 

 

Use the magnifying glass icon to search for any 
Line Design menu items. 

 

File Options 

 

Open Line Design… 

Within the File menu, the Open Line Design option is used to open an existing, previously saved Line 

Design file. A Line Design file has the file extension ‘.pplld’. Only one Line Design file can be open at a 

time, so the Open Line Design option is disabled if a .pplld file is already open. 

To open an existing line design, or a .pplld file, follow these steps: 

1. Under the File option, select Open Line Design… 

2. In the Load Line Design window, select a .pplld file and 

3. Click Open. 

Alternatively, Line Design files can also be opened by dragging and dropping a line design file into the 

Poles tab, beside the Main Line Design area.  

*Note: The license key for subscription map services are the 
responsibility of the end user; they are not provided with your O-Calc 
Pro license.  

Clearance Tab This tab is used to create clearance violation rules and check for 
violations. Tools are available to model field conditions like foliage, 
structures, surfaces, and easements of various types.  
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Save Line Design 

The Save Line Design option enables the user to manually force a save to the Line Design file. While 

most edits are dynamically saved, selecting this option will force all edits that have been made to be 

committed to the line design file.  

1. In the Line Design area, under the File option, select Save Line Design. 

 

Save Line Design As… 

The Save Line Design As option allows a user to take the currently open line design and save it with a 

different name, maintaining the previously opened line design. Effectively performing a save as allows 

the user to commit all edits done prior to the save as to a new copy of the line design, which can be 

renamed.  

1. In the Main Line Design area, under the File Option, select Save Line Design As… 

2. A windows explorer window will open; select a location and enter a file name for the new .pplld 

file, then click Save. 

Close Line Design 

The Close Line Design option allows a user to exit Line Design mode when a line design file is open. A 

user will not be able to exit the O-Calc Pro application while a Line Design file is open. Some of the 

standard (upper left corner of O-Calc Pro) File menu options are disabled while a Line Design file is open 

and this message in red appears when the user attempts to open the standard File menu: 

 

1. Under the File option in the Line Design panel, select the Close Line Design option to close an 

open line design file. 

Note: When opening, editing, saving, or closing Line Design files, there is no option to ‘undo’ any of 

these operations. These changes are saved dynamically as the user works, so there is no option to undo 

a previous action. Any changes that are made are stored and must be corrected manually by the user. 

Previously Opened Line Design Files 

In O-Calc Pro Line Design the last six line design files (.pplld file type) the user accessed are displayed for 

easy retrieval.  To see the list of the six most recently opened Line Design files: 
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1. Click the File option. 

2. Below the Close Line Design option, a list will be displayed: 

 

 

New Line Design > Using Line Wizard 

To start a new line design using the wizard functionality, follow these steps: 

1. Begin by opening the .pplx file for the first pole in the line, or by modeling a new pole. Any pole 

can be your Line Design seed (template) pole. Click yes to specify which span set for multiple 

span sets, i.e. tangent pole with spans, and continue to the next step of selecting the span 

direction. 

  
2. In the Line Design menu, under the File option, select New Line Design. 

3. From the options, select the Using Line Wizard option. 
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4. The pink ‘Select Line Start’ prompt at the top of the map area indicates you are ready to start 

using Line Wizard. Use the cursor to select a point on the map where you’d like to place the 

starting pole – notice the cursor displays the coordinates for where it is placed. 

5. Left click once to place the first pole in the line. Notice the yellow ‘Extend (click here when 

done)’ prompt at the top of the map area. 

6. Continue to place poles on the map as desired and click the yellow prompt when done. 
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Note: Use the Mouse Scroll wheel to zoom in or out; hold down the right-click and drag to pan 

around the map view.  As the mouse is moved to the location of the next pole, the coordinates of 

the next pole and the distance from the previous pole will display on the cursor.  

 

7. Notice the ‘O-Calc Pro – Working’ progress bar. Note: You may also be prompted to save the 

original seed pole (template used to start the line) .pplx file. 

8. The Create Line Design window appears. Enter a File name, click Save. 

 

Starting a line design using the wizard tool is the easiest approach to modeling an entire line of poles. 

This method allows the user to set up the first (seed) pole as essentially a template pole, with 

attachments like those attached on all other poles in the line. By creating a line using the wizard, the 

attachments on the seed pole are carried over to each new pole in the line. Each pole is labeled 

according to the order in which they were placed.  Additionally, the wizard ensures that the connectivity 

of the spans is carried from one pole to the next.  

Tip: To assign the Pole Number as you are adding poles to the map using the Line Wizard, simply 

click to toggle on the Edit Pole ID When Created option. Go to Line Design > Options > Editing 

Options > Edit Pole ID When Created. 

 

New Line Design > Terminate Wizard Line 

This setting is used to automatically end a line on conductors created using the line design wizard. It is 

enabled by default and ensures that when a line is being extended using the wizard, the last pole in the 

line does not further extend any attached spans.  
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Line of poles that terminates. 

This feature would be disabled if additional poles were going to be added later, perhaps by adding an 

existing .pplx file to the line design. To disable this feature, follow these steps: 

1. Under the File option, select New Line Design 

2. Select Terminate Wizard Line to un-check and disable the feature.  

 

Line of poles that do not terminate. 

New Line Design > Start Line with Current Pole(s) 

To start a new line design using a single existing .pplx file with valid coordinates, follow these steps: 

1. Begin by opening the .pplx file for the first pole in the line design. 

2. Ensure that it has coordinates entered under Edit > Pole Coordinates. 

3. Under the File option, select New Line Design. 

4. From the options, select Start Line with Current Pole(s). 

 
5. The Create Line Design window appears, enter a File name, click Save. 
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6. A pole icon (dot) will be placed o the map for the first pole in the line design and a 

corresponding pole is added to the list under the Poles tab. 

 
7. Additional (as many as you want, typically 40 is what the average device can process in a timely 

manner) poles can be added using the Add PPLX Files to Line Design Method. 

 
 

Taking an existing pole and using it to start a line design is also an acceptable method, although there 

are some additional steps when compared to using Line Wizard.  

• First, coordinates must but entered for this pole – they cannot be added by selecting a point on 

the map, like they are when the Line Wizard is used.  

• Secondly, any new poles in the line must be added individually and without connectivity.  

New poles that are added will have to be manually linked (connected) to each adjacent pole in the line. 

This process is outlined in this guide under the section about Linking Spans. When a line design is 

created using this method, the poles that are added are not labeled in the Poles tab, they appear with 

the Pole Number designation of ‘Unset’.  

New Line Design > Import  

Another method for starting a new line design is the use of a spreadsheet of data and a pole model to 

generate the line of poles. This method would be useful for a list of poles and their coordinates, and 

essentially batch-generating them. To use this method, follow these steps: 

1. Begin by opening the .pplx file for the first pole in the line or modeling a new pole.  

2. Under the File option, select New Line Design. 

3. From the selections, choose Import, followed by Create Line from Data. 
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4. When prompted, select a data file to use and click OK. 

5. When prompted, enter a name for the line design and click Save. 

 

This approach requires the imported pole data to be formatted in a very specific way. For more 

information on formatting that data click the Show Expected Format option. See the section Formatting 

Input Data for Creating Line Design. Using this method requires a seed pole to be chosen or modeled. 

Then, using the pole data file, O-Calc Pro generates the additional poles in the line, copying over the 

attachments from the seed pole. When this operation is performed using a pole data file with multiple 

entries, each entry is added to the line design, in the order they are listed. Connectivity between the 

poles is applied, like it is when using the Line Wizard feature. 

Export > Overhead View 

This function allows a user to export the line of poles that they have modeled in several formats, 

specifically as an overhead view of the line. The export of the overhead view can be used to generate 

several file formats, including DXF, Shapefile, PDF, EMF, and GeoJSON. The level of detail of the 
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exported overhead view can be either Simplified View or Mesh View. Simplified view represents the 

insulators as nodes, while Mesh view renders them in more detail.  

 

To open the window shown above, follow these steps: 

1. Under the File option, select Export 

2. Select Overhead View 

3. Set the Format for the exported file, and the level of Detail 

4. Click Export; if enabled, the file will open after the export is complete 

But how do you know which format to choose? That would depend on how the data were going to be 

used. Regarding the formats, a Shapefile could be loaded into a GIS program or a PDF could be used to 

generate a graphic for a report or presentation. The other formats would have more technical 

applications, like a GeoJSON.  

 

Simplified (insulator shown as node)                            Mesh (insulator is rendered in detail) 

In the left image, the Simplified overhead view is shown, with each insulator being represented as a 

node. In the right image, the Mesh overhead view is shown, with each insulator being rendered in more 

detail.  

Export > Profile View 

This function allows a user to export a line of poles in several formats, specifically as a Profile (side) View 

of the line. The Profile View of the line design can be exported as a DXF, Shapefile, or PDF. Additionally, 

there is a drop-down menu that enables the user to form several preset scale factors, indicated by Horiz 

%, which is the amount of ‘horizontal percent’ used in the scaling shown in the exported file.  
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For instance, in this image the Horiz % is set to 10, so the exported file is scaled down to 10% of its 

original horizontal scale. This results in an output that is easier to read, as shown below.  

 

The screen shot above shows an example of profile view. This profile view was exported with a 10% 

scale factor in the horizontal direction. 

This function also has an option to immediately open the exported results when they are created just 

like in the Export Overhead View tool.  

Export > Mesh (3D) 

The Mesh (3D) export option allows a user to export the entire line of poles as a 3D file, like in a Collada 

(KMZ), Shapefile, of DXF format. These files can often be used to view a 3D rendering of the pole line, 

like what can be seen in the 3D View tab in O-Calc Pro. Here, there is also an option to open the results 
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when the export is complete. Note: This same type of result can be achieved using Show Pole on Google 

Earth > Render Structure. Learn more about Plugins at our Wiki site: http://o-calcpro.com/wiki/ 

Below is an image of the Collada, or KMZ file exported and displayed in Google Earth.  

 

Edit Options 

Lock Wind 

Locking the wind angles on one or several poles allows the user to determine loading on the entire line, 

given a specific wind direction. By default, O-Calc Pro sweeps the wind around the entire pole and 

identifies a wind direction as being the ‘worst case scenario’. In this situation, the worst wind angle is 

calculated by the program and any capacity meter readings are based on that worst-case wind direction.  

To lock the wind that is calculated in Line Design, follow these steps: 

1. Under the Edit option, select Lock Wind 

http://o-calcpro.com/wiki/
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2. From the list, select the poles for which the wind will be locked; these can be: 

a. All Poles 

b. Checked Poles 

c. Current Pole 

 

3. Enter a value for the wind angle; this would be the wind direction that wind is coming towards, 

not the direction that it is coming from. 

4. Click OK. 

5. O-Calc Pro will iterate through each pole in the line design, adjusting the wind angles to the 

value entered for the selected poles. Click OK. 

 

Freeze Guys 

This Freeze Guys feature is designed to be used if, and only if, span-head guy wires and the associated 

stub poles are going to be processed as individual .pplx files at some point in time. Typically, when a 

span-head guy is used, the tension applied on that guy wire is calculated dynamically, depending on the 

wind, and loading on the pole that it is supporting. Then, when the stub pole is analyzed, the tension 

would have to be entered manually or essentially ‘copied’ from the main pole to the stub pole.  

When freezing (locking) the guys, the tension going to the stub pole on the span-head guy is then copied 

and used as the tension coming from the span-head guy to the main pole.  

To freeze (lock) the tension of the guy wires applied to subsequent poles in a line design, follow these 

steps: 

1. Under Edit > Freeze Guys, select Freeze Span/Head Guys. 
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2. From the list, select the poles for which the span-head guy wire tension will be frozen: 

a. All Poles 

b. Checked Poles 

c. Current Pole 

 

3. Enter a value for the wind angle that will be applied to calculate the tension of the span-head 

guy wire; this tension will be fixed, so the individual .pplx file of the stub pole can be analyzed.  

Utilities > Fix Orphan Links 

 

The Fix Orphan Links feature allows the user to remove the icon (chain-link with red slash through it) in 

the Inventory for spans that were previously linked. Orphaned spans can occur when a pole in a Line 

Design has been removed. The spans that had been linked to that pole’s spans are considered 

‘Orphaned’ or previously linked. The spans that remain may need to be un-linked from the deleted pole. 

To un-link globally rather than individually, follow these steps: 

1. From the Line Design menu select Edit > Utilities > Fix Orphan Links. 

 
2. The chain-link symbols on the orphaned spans will be removed.  
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Utilities > Constrain All Elements 

This feature is ideal for situations that arise after a substitution or edit has been performed that results 

in a configuration that is illegal. For instance, a crossarm with insulators that are placed beyond the end 

of the crossarm. This feature forces the illegal arrangement to become legal, by adjusting the placement 

of objects. To use this feature, follow these steps: 

1. Begin with a pole in a line design, perhaps like the one pictured here: 

 

2. Make an edit that could be considered illegal – like shortening the crossarm or substituting it 

with a smaller size: 
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3. In the Line Design Tab, go to the Edit > Utilities menu, and select Constrain All Elements 

4. Corrects illegal arrangement by snapping to legal position, in this case to ends of crossarm. 

 

Undo/Redo 

These options allow a user to undo or redo the previous action that was performed in the Line Design 

Tab. Just like previous versions of O-Calc Pro, there are keyboard shortcuts for both actions.  

Undo CTRL + Z 

Redo CTRL + Y 

Tools Options  
The tools menu includes many functions designed to simplify and expedite the line design process. The 

tools outlined here are meant to be used when a line design has already been created and needs to be 

edited.  

Map Measure Tool 

The Map Measure Tool option allows a user to determine the location, length, and direction of a span 

from the main line design area. This tool can be useful in determining the distances and angle between 

structures or other features visible in the main line design area. To use the tool, follow these steps: 

1. Select Tools > Map Measure Tool. A small window appears in the map area as shown below.  
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2. Left mouse click and hold in the map area while moving the red dotted line (measure tool) to 

indicate the measurement location from and to points on the map. The data in the map 

measure tool window will update as you move around. The measure tool records as soon as you 

release the left mouse click.  

3. To end use of the Map Measure Tool and cause the window of data to disappear, simply go to 

Tools > Map Measure Tool and deselect the option. 

Span Bay Linking Tool 

From the Tools menu select the Span Bay Linking Tool, click the Bay Linker option, this allows the 

yellow arrows to appear on the map for span that are not yet linked. Using the drag and drop method, 

users can click between span bays in a line design to link up the spans automatically. This feature is 
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useful in the linking processes by allowing O-Calc to automatically match up the adjacent wire type for 

linking without needing to switch views or the selected pole.  

  

  

View PPLX Directory on Map 

The View PPLX Directory on Map option allows a user to choose a directory, or folder, of poles to 

display in the Map area. From this set of poles, a subset may be selected and used to generate a new 

Line Design File. To use this operation, follow these steps: 

1. Set up a directory or folder of the poles you wish to include each must have pole coordinates. 

2. Ensure that a Line Design file is not open. 

3. In the Main Line Design area ribbon, select the Tools option. 

4. From the list, select the View PPLX Directory on Map option. 

5. In windows explorer, navigate to, and select the directory where the poles can be found, and 

click Select Folder. 

6. After processing, pole icons (dots) appear on the map to show where each of the poles are 

located. 
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7. Select all the poles by clicking on each, or a subset by clicking on the desired poles. 

 

8. Under the File option, select New Line Design > Start Line with Current Pole(s) 

9. When prompted, enter a name for the Line Design, and click Save 

After the Line Design has been created, edits can be made including linking spans and reordering the 

poles.  

Extend or Branch Line 

There are multiple scenarios where using this tool could be beneficial. Essentially, extending or 

branching a line means adding additional poles to a line design either in the same segment, or creating a 

branch segment from an existing line. In either case, a pole is selected as the origin of the extension, and 

additional poles can be added with spans linked to that origin pole. Additional examples of both 

scenarios can be found in Appendix A – Common Workflows.  

 

To extend or add a branch to a line, follow these steps: 
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1. Open a line design file. 

2. Select a pole in the line to use as the starting point for the extension or branch. 

a. The selected pole should have a set of unlinked spans going in a single direction, with 

uniform length; if it doesn’t, this informational message will display: 

 

b. If this message is shown, click ‘OK’ and create an unlinked span set on the selected pole. 

3. From the Line Design menu, select the Tools option. 

4. From the list, place the cursor over the Extend or Branch Line option. Select from the two 

options; Add a Single Pole; Add a Line of Poles. Keep in mind that if the Terminate Line from 

Current Pole is checked, this option results in the spans being terminated automatically at the 

last pole you add. If unchecked, a set of unlinked spans will remain when the last pole is added. 

 

 
 

5. Continue this process until the line extension is complete, then click the yellow Extend (click 

here when done) prompt at the top of the map area. All the spans are linked automatically. 

 

Import 

The Import option can be used to import pole information and coordinates to extend or branch a line. 

The Import tool is outlined in full here.  
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Perform Stringing 

The Perform Stringing function aims to speed up adding a new span (communication or electric) to an 

entire line of poles, or multiple poles in a line. This function requires that a stringing assembly be set 

before using this tool.  

Setting a Default Stringing Assembly 

A default stringing assembly is typically an assembly with an insulator or hardware object, and its 

associated conductor or communication bundle. For instance, a three-bolt with a communication 

bundle, or a dead-end insulator with a secondary span. This default stringing assembly must either be 

found in the Master Catalog or created and placed in the User Catalog. The setting of a default stringing 

assembly is only possible from within a catalog when right-clicking on the parent object (hardware or 

insulator) for the assembly. 

In the image below, the user would right-click on the bolt object within ‘1.5” Telco Assembly’. In the 

menu, select the Set Line Design Stringing Assembly option. Once a line design stringing assembly has 

been set, it will remain the default stinging assembly until a different one is set.  

 

Perform Stringing 

After the stringing assembly has been set, the Perform Stringing operation can be performed for All 

Poles, or only for Checked Poles.  Follow these steps to perform stringing: 

1. Open a Line Design. 

2. If necessary, check the poles listed in the Poles tab that you would like to perform stringing on. 

a. This step is not necessary if stringing will be done on all the poles. 
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3. Under Tools, hover the cursor over Perform Stringing, and select either All Poles or Checked 

Poles. 

 

4. The Stringing Height Settings window opens. 

 

a. Set – Users can choose where to set the stringing assembly; either using the top, center 

or bottom of the element being used as the parent (insulator or hardware) object. 

b. At – Users can choose the attachment height the stringing object will be added on each 

pole.  

c. Relative to – Users can choose where the placement height will be relative to; 

groundline, tip of the pole, the top lower, bottom power, top comm or lowest comm. 

d. Saved settings - Any name entered here will be used to store the selected settings for 

future use, this is optional. Use the ‘X’ to delete a Saved setting entry. 

5. When finished, click OK. 

When the operation is completed the chosen stringing assembly is placed on the intended poles. Refer 

to the 3D View area to inspect the results and perform any necessary edits. 
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Add Drops to Current Pole 

The Add Drops to Current (pole in the Inventory) Pole feature allows a user to add multiple drops at 

once coming from one pole and extending in different directions. This feature also requires setting a 

Line Design Stringing Assembly, which will be used for the service drop. Follow these steps to add drops 

to the current pole: 

1. Open a Line Design. 

2. Click on the pole to have the service drops added to it. 

3. Ensure that a default stringing assembly has been set from a catalog by right clicking on the 

parent (insulator or hardware) object within the assembly. 

4. Under Tools, click the Add Drops to Current Pole option. 

 
 

 

 

 

 

 

 

 

 

 

 

5. The Stringing Height Settings dialog window opens. 
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a. Set – Users can choose where to set the stringing assembly; either using the top, center 

or bottom of the element being used as the parent (insulator or hardware) object. 

b. At – Users can choose the attachment height the stringing object will be added on each 

pole.  

c. Relative to – Users can choose where the placement height will be relative to; 

groundline, tip of the pole, the top lower, bottom power, top comm or lowest comm. 

d. Saved settings - Any name entered here will be used to store the selected settings for 

future use, this is optional. Use the ‘X’ to delete a Saved setting entry. 

6. When finished, click OK. 

7. Now drops can be added by clicking on the map; the point that is clicked on the map is the end 

of the drop location. Hold the CTRL key while adding drops on the map to cause the drops to 

come off one insulator. Do not hold the CTRL key to cause each drop to have its own insulator. 

8. Click the Add Drops (Click Here when done) prompt at the top of the map area, when finished. 
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Fix Span Rolls 

The Fix Span Rolls operation is used to correct for spans that have been drawn as crossing over the top 

of one another. When spans are being linked, or generated crisscrossing spans can occur. See the 

crisscrossed spans in the 3D View and in the Map area below: 

 

        

Crisscrossed spans can be corrected by following these steps: 

1. Open a line design with spans that are crisscrossing. 

2. From Line Design, select the Tools option. 

3. Hover the cursor over the Fix Span Rolls option. 

4. Select from the two options; Fix Span Rolls and Rotate Arms or Fix Span Rolls (Do Not Rotate 

Arms). 

5. Next, select the poles to be included in the operation; Current Pole Only, All Poles in Line, or 

Checked Poles. 
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Align Insulators 

The Align Insulators tool is used to realign insulator angles to their respective span angles. This 

operation can perform a bulk edit for an entire pole, subset of poles in a line design, or the entire line. 

Follow these steps to align insulators: 

1. Open an existing or create a new Line Design file. 

2. From Line Design go to the Tools menu then hover over the option Align Insulators, click on one 

of the three options. 

      
3. In this example we used the current pole only option to align these insulators with the spans. 

See below the before and after results: 
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Other Tools > Auto LOL/Merge 

The Auto LOL/Merge tool can be used when previously created pplx files are used to create a line 

design. Creating a line design from existing pplx files requires that the user manually link each of the 

spans from one span to other on each pole. To assist with this process, the Auto LOL/Merge tool 

attempts to link the spans for the user. This tool was a first-generation tool in Line Design. Subsequently, 

the Span Bay Linking tool was developed for the same purpose and has added visual features. To use 

Auto LOL/Merge, follow these steps: 

1. Open an existing pplx file with coordinates. 

2. From the Line Design menu, select File > New Line Design > Start with Line with Current 

Pole(s). 

3. In the Create Line Design window, enter a File name, click OK. 

a. The line design pole appears in the map area; if not visible, go to View > Zoom to Poles. 
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4. Add additional poles to the Line Design. 

a. In the Poles tab, select File > Add PPLX Files to Line Design. 

b. Navigate to the stored .pplx files and select multiple poles or add one at a time. 

c. Once selected, click ‘OK’ to add the poles to the line design. 

i. If the selected poles had a pole image embedded, a warning message will 

display – click ok on the warning message. Multiple messages will show if 

multiple poles were added that had images. 

ii. The poles will still be added to the line design, but the images are removed. 
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5. Next, under Tools, hover the cursor over Other Tools and click Auto LOL/Merge. 

 

6. The Auto LOL/Merge dialog opens, where several parameters can be set. 

 

a. Set the target, or which poles will be included in the merge; All Poles; Selected Pole 

Only; Checked Poles Only. 

b. Select the Operations to perform: 

i. Set LOL – is to determine a Line of Lead 

ii. Merge Spans 

iii. Merge Guys 

iv. Add Jumpers (up or down placement) 

v. Ignore Elevation 
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c. The Auto LOL Merge > Settings > Edit Thresholds option contains the Bay and Merge 

Thresholds window for inputting the values used when merging spans, along with 

parameters pertaining to how other spans are merged during the operation. 

  

This tool only identifies situations that fit the thresholds set under the ‘Settings’ options; not all 

spans may be linked or merged if they fall outside the set thresholds, or there are multiple merge 

options that satisfy the thresholds, and the program cannot decide which to use. So, while this tool 

may help expedite the process, it is a starting point. A user can use this tool, then continue the 

manual linking process or decide to use the newer feature; Tools > Span Bay Linking Tool > Bay 

Linker. 

 

7. Click OK when the desired values are entered.  

8. To return to the default values at any time click the Reset to Defaults option in Settings. 
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Other Tools > Generate Differences 

The Generate Differences option allows a user to select a Line Design and then compare the results 

against one that is currently loaded. The output can be in the form of a .Json or .xml file along with 

several other output options. 

• With no Line Design open select a Line Design to compare against 

 

• Then load up another Line Design. Once loaded the option for output and difference comparison 
will be populated.  

 

• Save as Json or xml – this option allows the differences to output and get saved in either of 
these formats 

• Display Diffs After Creation – this allows the user to immediately see the generated differences 

• Save Diffs All Poles – this allows for the user to save the difference for all the poles in the Line 
Design  

• Save Checked Poles Only - this prompts the user to save the differences for only the checked 
poles in the Line Design  

• Save Current Pole Only - this prompts the user to save the differences for only the currently 
selected pole in the Line Design   

• Show Differences – this menu option contains 2 more options.  
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▪ Checked Poles Only - this will set the differences to be displayed with only the 
currently checked poles 

▪ All Poles - this will set the differences to be displayed for all poles in the Line 
Design 

The Version Poles option allows a user to create a pole copy inside of their Inventory based on the 
Checked Pole Only or All Poles selection. 
 

Other Tools > Split Span Head Anchors 

The Split Span Head Anchors tool allows a user to generate individual anchors for span head guys that 

are modeled as being attached to one anchor. Below is an image of a set of span head guy wires, all 

attached to the same anchor, or stub pole.  

 

It is common to see a stub pole with multiple guy wires attached to it. However, in O-Calc Pro Line 

Design it is not possible to link guy wires when there is more than one attached to the same stub pole. 

For more information on guy linking, see this section. To split the span head anchors, follow these steps: 

1. Open a Line Design. 

2. Set a pole with an associated stub pole as the active pole; ensure that the stub pole has multiple 

guy wires attached to it. 

3. In the Main Line Design area, select the Tools drop-down menu and hover the cursor over Other 

Tools. 

4. Click on Split Span Head Anchors; a new stub pole should be generated for each of the span 

head guy wires, but these stub poles will all be in the same location, so they will appear to be 
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one pole; in the image below, three stub poles are listed in the inventory, but in the 3D View, 

they are rendered as overlapping; they must be moved to be seen.  

 

5. Reposition the individual stub poles by adjusting the Lead Length and Lead Angle attributes in 

the Date Entry panel. Once each of the span head guys has been assigned to its own stub pole, 

guy linking can be used. 
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Other Tools > Remove All Pole Attachments 

Remove All Pole Attachments allows a user to easily remove all or selected attachments from a pole(s). 

Follow these steps to remove attachments: 

1. Open a Line Design. 

2. If desired, check a subset of the poles listed in the Poles tab. 

3. From Line Design, select the Tools > Other Tools > Remove All Pole Attachments. 
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4. Select an option from the pop-up window: 

 

5. In the Pole Attachments window (shown below) users can isolate which attachments to 

Remove or Keep by checking or unchecking the corresponding boxes. Click OK when done.  

Note: Ctrl-Z can be used to undo the operation if desired. 
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Other Tools > Bulk Set Owners 

The Bulk Set Owners tool allows a user to easily set ownership for not only the components on an 

individual pole, but to set ownership and propagate that ownership across spans that are linked. For 

instance, ownership could be set for the spans on a pole, and then that ownership is carried down along 

the links to every other segment of that line. To set bulk ownership, follow these steps: 

1. Open a Line Design. 

2. From Line Design, select Tools > Other Tools > Bulk Set Owners. Select which poles ownership is 

going to be set for; Current Pole Only; All Poles in Line; Checked Poles Only. 

 
 

This tool allows for a user to edit Ownership easily and quickly for objects. In addition to this, new 

functionality has been added to the O-Calc Pro Query tool, accessible from the Catalog or Inventory 

Menu. See the O-Calc Pro user guide for information on this new functionality regarding ownership.  
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3. The Bulk Set Owner window appears listing the attachments on the pole as shown below. 

 

4. Enter the owner for each object, if desired. The Pole owner defaults to itself, but this can also be 

overridden. Once entered, click OK.  

 

5. Move to the next pole in the line and examine the ownership; if you had selected All Poles in 

Line, each owner should now be set.  

Other Tools > Bulk Description Operations 

The Bulk Description operations allow a user to modify the descriptions for objects on a single pole in a 

line, or for a selection of poles in a line. To use this tool, follow these steps: 

1. Open a Line Design. 

2. Select Tools > Other Tools > Bulk Descriptions Operations. 

a. Select either Clear Descriptions or Edit Descriptions 

b. Select the poles this action will be performed on; Current Pole Only; All Poles in Line; 

Checked Poles Only. 

Each object in O-Calc Pro has a default description. This feature allows a user to enter a description that 

they understand or are more familiar with. 
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3. The Edit Descriptions window appears. 

 

4. Enter the descriptions for the desired objects and click OK. 

 

 

 

 

Bulk Pole Edit 
Th Bulk Edit Poles window allows the user to edit options for the poles in a line design. To use this tool, 

follow these steps: 
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1. Select one of the two options presented; Checked Poles Only or All Poles in Line. 

 

2. In the Bulk Edit Poles window, enter the desired pole edits. Click OK. 

  

View Options 

Refresh Map 

This option allows a user to refresh the map that is drawn in the Main Line Design Area. To use this 

option, follow these steps: 

1. Open a Line Design.  

2. In the Line Design View menu, click Refresh Map. 

This feature would be used when a change or edit has been made, that doesn’t appear to be reflected in 

the map view. This could also be used to redraw map or OMV tiles in the map view.  



Osmose O-Calc® Pro 7.0 Confidential Line Design User Guide 

48   ©2023 Osmose Utilites Services, Inc.  
 

Copy Viewport 

This option allows a user to take a screenshot of the main line design area’s current view of a map. To 

capture this view, follow these steps: 

1. Open a Line Design 

2. Zoom in/out to the desired map scale 

3. Pan to desired map view 

4. Under View, click Copy Viewport 

5. Where desired, right-click and paste, or use CTRL+V to paste copied viewport in desired location, 

like the example shown here: 

 

This would be useful for taking a quick screenshot of a line design that is in progress to share with 

another user.  

Set/Hide Ground in 3D View 

Set Ground in 3D View is an option that alters the display of the ground that is normally seen in the 3D 

View Tab. Below is an image of a line design, with the default appearance of the ground.  
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This default appearance just shows a green area to represent the ground. Use the following steps to set 

the map in Line Design as the ground area. Results may vary depending upon the source used for the 

map information, and the degree of detail available. 

1. Open a Line Design. 

2. Go to the View menu, click the Set Ground in 3D View option. 

3. From the 3D View the ground matches the appearance of the map around the line design. 
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The intent is to allow users to see where other map objects are in relation to the line of poles, without 

having to switch back to map view repeatedly. To revert to the green ground appearance, under the 

View menu, select the Hide Ground in 3D View option. 

Profile View > Profile Chart 

This option allows the user to view a profile of a line design showing basic information and relative 

elevation pole to pole, for any selection of poles in a line design. From the profile chart we can see basic 

information; pole number; pole height; attachment heights; span lengths and change in pole elevation 

relative from pole to pole.  

1. Open a Line Design file. 

2. Use the checkboxes in the Poles list to include which poles in include in the profile chart.  

3. From Line Design go to View > Profile View > select the Profile Chart option. 

Height in Feet 

In this chart, the height above ground line is shown on the Y-axis to the left-hand side. This allows a user 

to see the various heights for the poles and their attachments. This range adjusts to fit all the selected 

poles within the profile view.  

Profile Length in Feet 

Along the X-axis, a length is shown to indicate the distances between poles in the profile view. This 

range adjusts to fit all selected poles within the profile view.  

 

 

Note: Draw order is extremely important for this tool – for more information on draw order, see the 

section Sort/Check Helper or Auto Order  Should the pole order within the Poles list not be consecutive 

the chart results may appear skewed as in this example: 
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Profile View > Profile Viewer 

The Profile Viewer display’s details of a selection of poles from a line design in profile, or a view from the 

side rather than from above. This chart offers the ability to resize the window, zoom to fit the window, 

zoom in and out on the chart to read details, and to print. 

To view the details of selection of poles, follow these steps: 

1. Open a Line Design file. 

2. Use the checkboxes in the Poles list to include which poles in include in the profile viewer.  

3. From Line Design go to View > Profile View > select the Profile Viewer option. 

 

 
Note: Draw order is extremely important for this tool – for more information on draw order, see the 

section Sort/Check Helper or Auto Order 
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Overhead View 

Overhead View is a tool that generates an overhead, or birds-eye view of the line of poles. The overhead 

view contains information for each pole in the line, including the Pole Number, the Latitude and 

Longitude and Elevation.  

From this window, there are two menus: a file menu and a view menu. The file menu contains options 

to Save, Print, or Exit. The view menu contains an option to Zoom to Fit.  

To generate this view: 

1. Open a Line Design. 

2. Go to View > Overhead View to generate an image like the one shown here: 
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Reset to Extents 

The Reset to Extents option sets the Main Line Design Area map to its widest area. It is helpful to use 

this tool when you must move to a new location on the map. 

 

 

Zoom to Poles 

This view function focuses on the poles in the line design. This zoom option is ideal when a line design is 

opened, but due to zooming out and panning around, a user has lost sight of the poles in the Main Line 

Design Area. To use this function: 

1. Open a line design file 

2. Zoom out or pan away from where the poles are in the map view 

3. In the Main Line Design Area, go to the View drop-down list 

4. Select Zoom to Poles 

 

 

 

 

 

 

 

This narrows the focus in map area to only the poles in the line design. 
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Zoom to Shapefiles 

In the Line Design > GIS Files tab, users can display User Defined Data in various formats in map area.  

Data formats used are Shapefiles; KML File; CSV Lat Lon File; GeoJSON File; GeoImage File; GPS NMEA 

File formats. For more information on how to incorporate User Defined data, see the GIS Files Tab 

section. Zoom to Shapefiles will focus the map area on the shapefile or shapefiles in the map. If multiple 

shapefiles are loaded, the user must choose one of the files to use for the zoom feature.   

To easily navigate to where Shapefile or GeoJSON are displayed in the map area, follow these steps: 

1. Open a line design file and add the User Defined Data as a shapefile or a GeoJSON File. 

Note: More information on adding shapefiles can be found in the Shapefiles section. 

2. Zoom out or pan away from where the shapefiles are in the map view 

3. In the GIS Files tab, left-click on one of the shapefiles – should be highlighted 

4. In the Main Line Design Area, go to the View drop-down list 

5. Select Zoom to Shapefiles 

Note: this option is not available if a Shapefile has not been selected from the list. 
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Center on Coordinate 

Rather than using an item in the map as the focus, a user has the option to use latitude and longitude to 

center the map. To center the map on a set of coordinates, follow these steps: 

1. Open a line design file. 

2. From Line Design go to View > Center on Coordinate, the Geolocation window appears. Enter 

the values or select on the map and click OK. 

 
 

3. Click the Set Convention button to choose a different Lat Lon Format if desired. 

 
4. Enter the coordinates to be centered on and click OK. 

Note: The red crosshair indicating the center of the map area will not align with the coordinates selected. 

 

Filter by Height > Enable Filter by Height 

This setting is used to enable the height filter sliding scale in the map view of the Main Line Design Area. 

Enabling this option displays a height filter scale to the left-land side of the Main Line Design Area. In 

addition to the height filter scale, numeric values can be entered at the top and bottom of the scale. To 

enable the filter, follow these steps: 

1. From Line Design, select View > Filter by Height. 

2. Click to toggle on/off the Enable Filter by Height option. 
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Enabling this setting allows a user to edit the height filter on-the-fly, rather than having to adjust it in 

the Schematic View and copy it or set the max height from the View menu.  

For instance, when pole heights cover a range of values, it may be beneficial to enable this setting to 

easily adjust the height filter settings. 

Filter by Height > Copy from Schematic View 

The schematic view tab has always enabled users to filter spans based on the span’s attachment height 

on the pole; spans that are not within the range selected are not shown in the 3D View tab. In O-Calc 

Pro Line Design a user may adjust the height filter in the schematic view and apply those adjustments to 

the map display in the Main Line Design Area. To apply the Schematic View height filter settings to the 

Main Line Design Area map, follow these steps: 
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1. Open a line design, select any pole and view in the 3D View. 

2. In the Schematic View tab, the pole will be visible with associated attachment heights; the 

heights filter is on the left-hand side of this window. 

 

3. The height filter can be adjusted at the top and bottom, to set the height range that will be 

shown in the 3D View; adjust as desired. 

4. From Line Design, click on the View menu option. 

5. Select the Filter by Height list and click Copy from Schematic View. 

6. Any adjustments will be applied to both the 3D View for each pole in the line, and for the map 

area. 
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This feature could be used when edits to the spans are being made from the map area, and a user 

wishes to see only spans at certain heights. Hiding all spans that don’t fall within the set height range 

could make it easier to edit only those that are within the given range.  

Filter by Height > Set Max Height 

A user is also able to set a maximum height based on a selected value from a list. To filter by a maximum 

height, follow these steps: 

1. Open a line design, select any pole, and view in 3D View. 

2. From Line Design, select the View > Filter by Height, and hover the cursor over the Set Max 

Height option. 

 

3. From the drop-down list, select a maximum height value; any spans above this height will not be 

displayed in the 3D View tab or the map area. 

By using this feature, only spans below the target height will be visible in 3D View or in the map; this 

also enables the user to easily edit spans that are lower on the pole, that would otherwise be difficult to 

edit in the map view. This is particularly true for complex poles, or those with spans that overlap in the 

map.  

Filter by Link Status 

This setting allows a user to filter the spans shown in the 3D View tab or the Main Line Design Area 

based on if those spans are part of a linked pair. To use this filter option, follow these steps: 

1. Open a line design 

2. Select a pole in the line design and view it in the 3D View tab 

3. In the Main Line Design Area, select the View option. 

4. Enable it by clicking on the Filter by Link Status option. 

5. In the map area, a new All Spans drop-down is now visible in the bottom right corner; this 

option allows a user to set what spans they would like to see; All Spans; Linked; Un-Linked. 
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Enabling this feature allows a user to easily determine if any spans are not linked correctly or identify 

poles that have spans that are not linked as they should be. 

Options 
This menu item lists a series of settings that can be adjusted by the user, as well as several functions that 

can be performed.  

Draw Pole Labels/ Draw Pole Label Backgrounds/ Draw Pole Notes 

These settings allow a user to toggle on or off the labels and notes that display the Pole Number in the 

map area. To adjust these settings, follow these steps: 

1. Open a line design. 

2. Determine if the labels are needed; below is an example of the labels being displayed. 
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3. To turn the labels off, go to the Options menu in the Main Line Design Area ribbon 

4. Hover on Rendering Options 

5. Click on the first option in the list, Draw Pole Labels 

 

6. The labels will turn off; repeat this process to draw the labels again 
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The use of these labels in the map view of the Main Line Design Area is determined by the user; they 

may be unnecessary if the map view is crowded or cluttered, but also may be helpful for identifying a 

specific pole in the line quickly.  

To draw pole label backgrounds, follow these steps: 

1. Open a Line Design 

2. Enable draw pole labels. If the labels are difficult to see would be helpful to draw pole label 

backgrounds. 

3. Go to Options > Rendering Options in the Main Line Design Area Ribbon and select Draw Pole 

Label Background. An example is shown below.    

4. A white box should appear behind the pole labels in the map. 
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Draw Pole Notes 

This setting allows a user to toggle on or off a label that displays the content of a Note associated with a 

pole in a line design. To adjust this setting, follow these steps: 

1. Open a line design. 

2. Identify a pole with a note attached to it; this can be done by looking through the poles for one 

with a note item in the Inventory list. 

 

3. To turn the labels on, go to the Options menu in the Main Line Design Area Ribbon. 

4. Click on the second option in the list, Draw Pole Notes. 

5. When checked, the note will be displayed in map area. 

 

6. To turn off the notes in the Main Line Design Area, repeat steps 3 and 4. 

The use of these notes in the map view of the Main Line Design Area is determined by the user; notes 

may be useful if there are comments about a pole that need to be visible, but these notes may also be 

turned off if not needed by the user.  

Note objects have many uses. The two wiki page articles, Fun with Notes and More Fun with Notes 

provide additional information on how these can be used. Furthermore, when notes are displayed in the 

map view of the Main Line Design Area, they can be adjusted from the map view. Information on these 

adjustments can be found in Appendix B, under the Controlling Notes in Map View section.  

 

http://o-calcpro.com/wiki/2017/05/16/fun-with-notes/
http://o-calcpro.com/wiki/2017/10/27/more-fun-with-notes-notes-and-the-dmt-process/
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Drag Pole from Source on Map 

This menu allows users the ability to manage how they want to add poles to their line designs. Drag Pole 

from Source on Map contains options to allow poles from the users catalogs or even from the existing 

line design to be drag and dropped onto the map to create additional poles in the current line design. 

Additionally, there are options under the menu to control how and where these poles are added. 

This menu is found in the Line Design Tab under Options > Editing Options  

  

Add Pole to Line on Drag from Catalog 

Checking this option allows the user to drag and drop poles from their catalogs to the line design map to 

add them to the line design. 

 

 

Edit Coordinates on Drag from Source  

Checking this option allows the user to adjust the latitude and longitude of the new pole created from 

dragging and dropping a pole into the line design. 
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When this option is enabled an additional geolocation pop up window is generated after the user drag 

and drops a pole in the Line Design Map. The user must then specify the latitude and longitude of the 

pole and hit ok. 

 

 

Extend Line on Drag from Existing Pole 

This option allows the user to drag and drop a pole into the line design using a pole that already exists in 

the line design. 

 

To use this option, follow these steps: 

1. Select a pole at the end of your line design in the Line Design Map. 

2. Left click and hold on your mouse then drag to a desired location in the Line Design Map. A 

symbol will appear on the map indicating that a new pole is ready to be added in that location. 
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3. Release the left mouse and a small dialog box will appear. 

  
4. Select the Create Pole and Link option. 

 

Link on Drag from Existing Pole 

Checking this option allows the user to link spans on two poles from the line design map by drag and 

drop from the selected pole to another pole. 

 

To use this option, follow these steps: 

1. Open or create a line design which has the following conditions: 

a. Two or more poles 

b. Having the same span quantity, type, and construction type. 

c. At least 1 unlinked span bay on each pole 

Ex)  

  

2. Enable the Link on Drag from Existing Pole option. 
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3. In the Line Design Map, click on and drag away from the first pole you wish to link onto the 

second pole you link. A symbol will appear when you hover over the second pole indicating that 

you are ready to link the poles. 

  

4. Release the left mouse button while hovering over the second pole to be linked. O-calc will then 

link the two poles together. 

 

5. Verify that the two poles are linked together as desired. 

Drag and Drop on Map Enabled 

The Drag and Drop on Map Enabled option allows the user to do several pole loading operations 

directly from the map area. The user can add additional crossarms, spans and insulators to a pole or 

crossarm, add extra equipment to the pole, and add additional guys and anchors to the pole. The 

procedure to utilize this option is as follows.  

1. Open and existing Line Design or create a new Line Design. 

2. The Line Design must contain the feature you wish to duplicate already attached to the pole. 

This can be done through any number of attaching procedures. 

3.  Select the component to be duplicated in the map area (for spans the insulator must be 

selected) and drag it over to the pole or crossarm that you wish to attach it to. 
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The complexity of edits that can be made with this option is limited, however it allows the user to 

quickly build a pole that can be easily edited further for accuracy.   

Alternatively, edits made by drag and drop method within the 3D View offer more options as shown in 

the pop-up options below.   
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Map Drag Left Mouse Button 

This option allows the user to use the left mouse button to pan around the map area instead of the right 

mouse button. To enable this option, go to Options > User Interface Options > Map Drag Left Mouse 

Button as shown below.  
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Include Pole Note Images 

In addition to toggling on or off the display of pole notes in the map view, a user can further control 

what is shown by deciding whether to show pole images that are included in pole notes. To adjust this 

setting, follow these steps: 

1. Open a line design and identify a pole with a note attached to it; this note should include an 

image file. 

 

2. Determine whether the Draw Pole Notes option is disabled; if this option is disabled, enable it.  

3. To display pole images in the note shown in the map area, go to the Options > Rendering 

Options menu in Line Design. 

4. Click on the Include Pole Note Images option. 

Note: If the Draw Pole Notes option is disabled, the note will not display even when the Include Pole 

Note Images option is enabled. 
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5. The image will be added to the displayed note in the map view; this note may need to be resized 

or moved to see the image 

 

Displaying the pole image in the note may be useful if a user needs to quickly determine whether a pole 

image is associated with a pole, or perhaps how many images are associated with each pole in a line 

design.  

Draw Terrain Mesh 

This setting allows a user to toggle on or off a visual in the map view of the Main Line Design Area; this 

visual identifies the area where the poles in the line design are. It essentially identifies the area where 

the line design is by drawing a polygon around all the poles in the opened line design. To adjust this 

setting, follow these steps: 

1. Open a line design, zoom out until all the poles in the line design are visible in the map area. 
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2. Go to the Options > Rendering Options menu. 

3. Click on Draw Terrain Mesh; a green polygon will be drawn around all the poles in the line 

design. 

This setting will be useful when zooming out and attempting to identify all poles in the line. When 

zoomed out to a larger scale, the green polygon may be easier to see. 

Configure Elevation Provider 

To perform this configuration, follow these steps: 

1. From the Poles list in Line Design, go to Edit > Set Elevation(s) > Configure Elevation Provider. 

2. From the list, select Configure Geolocation Provider. 

 

3. Select a provider from the list. 

4. Enter an API Key, click OK. 

Note: API Key’s are not provided; they must be obtained by the user from the Provider. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Optional Elevation Provider Configuration Settings 

The new USGS URL effective 3/1/2023 is: https://epqs.nationalmap.gov/v1/xml?x=-

<longitude>&y=<latitude>&units=Meters&wkid=4326&includeDate=True. To use this URL the user must 

alter the configuration settings located in their app configuration file. 

https://epqs.nationalmap.gov/v1/xml?x=-%3clongitude%3e&y=%3clatitude%3e&units=Meters&wkid=4326&includeDate=True
https://epqs.nationalmap.gov/v1/xml?x=-%3clongitude%3e&y=%3clatitude%3e&units=Meters&wkid=4326&includeDate=True
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To find the App configuration file follow the following steps: 

1. Navigate to the Assemblies folder by going through Help > Folders > Development > Assemblies 

Folder. 

 
 

2. In the File Explorer window that appears scroll through the files until you find the XML 

configuration file for the O-Ca Pro application. ** Note the name of this file will depend on the 

name of the O-Calc application you are running. Ex) PPL.exe.config My file is called 

PPL_OsmoseInternal_BETA.exe.config as you can see in the image below.  
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3. Highlight and Right Click the file. Choose the open with option and open this file with Notepad.  
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To change the elevation provider settings the user must uncomment the Elevation Provider USGS URL 

found in the app settings section of the configuration file.  

To do so remove the ‘!—’ at the head and ‘—’ at the end of the highlighted row of text below. **Note 

leave the ‘<’ and ‘>’ symbols**  

 

It should look like this after you are done. 

 

 

In addition to this setting there is also a diagnostic feature to help the user determine if the config 

changes are working as expected. In the same configuration file, there is also the 

‘EnableElevationProviderDiagnostics’ setting. Uncommenting this line and setting the condition to ‘True’ 

will write elevation and URL information to a text file named ElevationProviderDiagnostics.txt in the 

users local temp folder. Use this to check the elevation and location on the next pole that you adjust the 

elevation on. 

**Note: The latitude and longitude values of the URL are expected to be represented with {Lat} and 

{Lng} respectively. They will be replaced at runtime with the respective coordinates. Embedded 

ampersands ‘&’ are expected to be represented in the .config file as pipe ‘|’symbol.  These as well will 

be replaced at runtime with ‘&’ ** 
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Warn on Duplicate PPLX File 

This setting will generate a pop-up notification when a user is adding a pole to a line design that has 

already been added. It is possible to add existing PPLX files to a line design file; the steps for this process 

can be found here. However, if this setting is enabled and a user attempt to add the same PPLX file more 

than once, a cautionary message will display, like the one shown here: 

 

 

Show Center Marker 

This setting allows a user to toggle on or off the red crosshair that marks the center of the map view in 

the map area. To adjust this setting, follow these steps: 

1. From Line Design, click on the Options > Rendering Options menu. 

2. Click on Show Center Marker. 

 

3. This will turn the red crosshair on or off; pictured above is the map view when this is enabled. 

This crosshair assists the user with positioning when panning around the map view.  

Draw Road Width (OMVT) 

This setting allows the user to control how much detail is included in the map view of the Main Line 

Design Area. This setting can be toggled on or off to adjust the appearance of road features in the map. 

To adjust this setting, follow these steps: 
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1. Open a line design, in the map area, note that with the option disabled, lines are used to 

represent roads, as shown below. 

 

2. To enable enhanced road drawing, go to Options > Draw Road Width (OMVT). 

3. This will show the road’s relative width in the map view of the map area.  
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4. To disable this feature, repeat steps 3 and 4 in this section. 

Drawing the widths of the roads in the map view may be beneficial when zoomed in to a smaller scale. 

Placement of poles in relation to roads would be easier if a user could see approximately where those 

road edges were. For larger scale maps, this setting may cause the map to look more cluttered.  

Draw Map Scale 

This setting allows a user to toggle on or off the scale bar that is shown in the map view of the Main Line 

Design Area. To adjust this setting, follow these steps: 

1. From Line Design, click on the Options > Rendering Options > Draw Map Scale. 

2. Enabling this feature will show a scale bar in the map view of the Main Line Design Area. This 

scale bar adjusts dynamically as a user zooms in an out, changing the units to fit the scale.  

 

3. To disable this feature, repeat steps 1 and 2 in this section. 
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A scale bar is immensely beneficial when using the map view of the Main Line Design Area. Having a 

quick, accessible way to determine distances in the map view can only benefit the user.  

For reference, the scale bar will stop increasing in unit size after 2500 miles and will stop decreasing in 

unit size after 4 feet.  

OMVT Render Thresholds 

This setting allows a user to adjust the settings used when displaying the OMV Tiles in the Map view of 

the Main Line Design Area. 

 

These thresholds control the zoom and scaling of each of the listed components of the OMV Tiles. If 

altered, these can be reverted to the default values by clicking on the ‘Reset’ button.  

Edit Rendering Colors 

Each component of a model created in O-Calc Pro is drawn rendered or drawn in a specific color. A user 

can change those colors, should they desire. To set custom colors, follow these steps: 

1. In the Main Line Design Area, go to the Options > Rendering Options list 

2. From the list, select Edit Rendering Colors 

3. In the window that opens, use the ‘+’ sign next to each type of object to view the currently 

assigned colors 
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4. To change a color, click once on the item you wish reassign the color for; a color selector tool 

will open. 

 

5. Select or create a new color; use the ‘Add to Custom Colors’ option to save custom colors for 

repeated use. 
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6. Click ‘OK’ to see the new color choice in the Edit Render Colors window. 

 

Import/Export Custom Render Colors 

Once set, it is also possible to export these custom colors to other users, using these steps: 

1. From Line Design, go to Options > Rendering Options > Edit Rendering Colors. 

2. Select the File option, select Export. 

3. When prompted, enter a name for the custom colors file, and choose a save location; the file 

type will be a .pplr file, click Save. 

This file can be sent to another user, who can then import the file using these steps: 

1. From Line Design, go to the Options > Rendering Options list. 

2. From the list, select Edit Rendering Colors. 
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3. In the Edit Render Colors window, select the File option, select Import. 

4. When prompted, choose a .pplr file for the import. 

5. Click Open. 

Restore Default Colors 

Should a user wish to restore the default color selections, follow these steps: 

1. From Line Design, go to Options > Rendering Options list. 

2. From the list, select Edit Rendering Colors. 

3. In the Edit Render Colors window, select the File option. 

4. Select Reset to Defaults. 

5. When prompted, select ‘Yes’ on the warning message. 

6. When prompted, select ‘Yes’ to restart the program. 

Display MCU Flags 

This setting allows a user to see an indication of a pole’s pass/fail status in the Poles Tab, and in the 3D 

View window. The MCU Flag appears in the Poles tab as a red or green dot, found beside the pole in the 

list. A green dot indicates a pole that is passing based on the applied load parameters, while a red dot 

indicates that the pole is failing.  

 

In the 3D View, the same indication is given at the base of each pole in the line.  
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MCU Flag Thresholds 

Adjusting this setting alters the values that are used to determine whether a pole is considered passing 

or failing. To access these thresholds: 

1. In the Main Line Design area, select Options > Rendering Options 

2. Click MCU Flag Thresholds 

3. The MCU Flay Thresholds dialog opens 

 

The default values shown above indicate that a pole will be marked as green, or passing, if its Maximum 

Capacity utilization is less than or equal to 85%. Any pole with a MCU between 95.1% and 95% will be 

marked in yellow, to indicate that the MCU value is approaching failure. Any pole with a MCU between 

95.1% and 99.5% will be marked in orange, indicating that it is very close to failure. Any pole with a MCU 

beyond this value will be marked in red, as a failing pole. These thresholds can be edited to suit the 

user’s needs. 
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Edit Pole ID When Created 

This setting allows a user to enable editing the Pole ID assigned to newly generated poles when the Line 

Wizard is being used. When the Line Wizard is used to create a line of poles, a Pole ID is automatically 

populated for each added pole. When this option is enabled, each Pole ID can be edited when the new 

pole is added. To enable this feature, follow these steps: 

1. Click on the Options > Editing Options menu in the Main Line Design Area Ribbon 

2. Click the eleventh option in the list, Edit Pole ID When Created 

3. Enabling this feature will show a prompt for a Pole ID to be entered when a pole is added using 

the Line Wizard feature 

 

4. To disable this feature, repeat steps 1 and 2 in this section 

If a Pole ID needs to be changed after the line design has been generated, this is possible in the Data 

Entry panel.  

Auto-Jumper Created Poles and Default Jumper Placement 

These two Options menu choices relate to the placement of Jumper in a Line Design. The Auto-Jumper 

Created Poles option ensures that Jumper Cables are placed automatically when a line design is created 

using the line design wizard. The second parameter here, the Default Jumper Placement, determines 

where the jumper will be placed when the Auto-Jumper Created Poles option is enabled.  
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The above image shows that jumper cables can be placed either above, below, or to either side of the 

insulators when they are placed automatically.  

Auto Fix Span Rolls 

When creating a line design using the Line Wizard, or when adding a series of poles to your current line 

design from the Extend or Branch Line tool, the spans may become crisscrossed, or rolled. Enabling this 

tool will automatically check whether or not your spans are rolled when using those tools and correct 

them.   

 

For example, in this line design created with the Line Wizard, the spans are rolled as noted in the red 

circle: 

 

To fix this I have several options. I can choose to fix the links manually, or I can go to the 3D View and 

right click on the crossarm and choose the fix span rolls option as shown below: 
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Finally, the user can enable the Auto fix span rolls option prior to creating or adding additional poles to 

their line design. To do so, go to Options > Editing Options > Auto-Fix Span Rolls and check the option 

to enable it. Below is a Line Design created with the Auto-Fix Span Rolls option enabled without any 

additional edits made: 
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Drag Pole From Source To Map 

When using Drag Pole From Source To Map there are several options. 

 

• Add Pole to Line on Drag From Catalog - this allows a user to drag a pole from the Catalog 

and drop it on the Line Design map. 

• Edit Coordinates on Drag From Source – this will bring up a Geolocation dialog box once 

a pole is dropped in the Line Design map. 

 

• Extend Line on Drag From Existing Pole – this allows the user to select a pole while in Line 

Design map view and drag/drop to a new location to make a new pole. 

• Link On Drag From Existing Pole - this allows the user to select a pole while in Line Design 

map view and drag/drop to a new location to make a new pole and link it to the origin 

pole. 

 

Storage Options 

This setting can only be adjusted when a Line Design is not open. This setting allows a user to determine 

whether they’d like to back up or archive the work they are doing, and if so, how it should be stored.  
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To enable this feature: 

1. Ensure no Line Design Files are open. 

2. Under Options, hover the cursor over Storage Options. 

3. Click on Auto Backup/History. 

4. Set where the backup will be stored; the options include. 

a. Storing all poles in a compressed archive folder 

b. Storing all poles in a high-performance archive 

c. Storing all poles in a Single Folder 

d. Leave the poles in the original location 

When enabling the option to store a backup or history, keep in mind that these files will take up 

additional storage space on your computer.  

Merge/Bay Thresholds 

This setting allows a user to adjust the parameters associated with the Auto LOL/Merge tool. These 

parameters can also be accessed from the Settings button associated with the Auto LOL / Merge tool. 

Adjust these parameters by: 

1. From Line Design, select the Options > Editing Options > Merge/Bay Thresholds > Edit 

Thresholds. 
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2. Adjust the parameters as desired to determine which spans will be linked within the parameters 

defined when the Auto LOL/Merge tool is used. These parameters could be adjusted for 

accuracy of the Auto LOL/Merge tool. 

 

Show Load Report on Reports Tab 

This setting determines where the O-Calc Pro Line Analysis report will display, after it has been 

generated using the steps outlined in the Calculate section. When is option is enabled, running an 

analysis on a line design will show the results under the reports tab. When this option is disabled, a 

separate window will open to display the O-Calc Pro Line Analysis Report. To adjust this setting: 

1. From Line Design, select Options > User Interface Options > Show Load Report on Reports Tab. 

 

Mirror “Poles” Menu on Main 

This setting determines if the features available under the Poles tab, in the Line Design Tab area, will be 

duplicated in the Main Line Design area ribbon. When this option is disabled, the features found in the 

Poles tab can only be accessed there. When this option is enabled, it is possible to access these features 

directly from the Main Line Design area Ribbon. To adjust this setting: 

1. From Line Design, select the Options > Editing Options > Mirror “Poles” Menu on Main. 

2. Verify that the Poles drop-down list is added to the Line Design tool bar area. 
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Dock Line Design Tools 

This setting determines where the Line Design Tabs will be placed. When enabled, this setting creates a 

separate tab, beside the Line Design Tab, where these options can be accessed. Below are images of 

each arrangement.  

The image below shows the layout when this setting is enabled. The Line Design Tabs appear under the 

Line Design Info tab, rather than beside the Main Line Design area.  

 

When this setting is disabled, the Line Design tabs appear beside the Main Line Design Area.  

 

To adjust this setting: 

1. In the Main Line Design area, select Options > User Interface Options 

2. Click Dock Line Design Tools 

3. O-Calc Pro will alert you to restart the program. Click Yes.  

Dock Clearance Tools 

This tool allows the user to add the Clearance tools as a tab to the Docking Layout of O-Calc Pro. This 

tool works similarly to Dock Line Design Tools. To adjust this setting go to Options > User Interface 

Options in the Main Line Design Area Ribbon, then click Dock Clearance Tools. O-Calc Pro will ask you to 

restart the program. 

Shortcut Keys 

A user can view existing shortcut keys in O-Calc Pro by pressing the ‘Alt’ key on their keyboards. Once 

the ‘Alt’ key is pressed, several letters become underlined to indicate that a shortcut can be used to 

access those options.  
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In Line Design new functionality has been added for users to define their own shortcuts to perform 

many actions. To set up user defined shortcuts, follow these steps: 

1. From Line Design, select the Options > User Interface Options > Shortcut Keys. 

 
2. This launches the Shortcut Key Editor window. 
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3. Select the desired action that the shortcut will perform. 

4. Set the keys that will be used in the shortcut. 

5. Click Apply. 

6. Click File and Save. 

Shortcuts can be created, saved, exported, or imported from another user.  

 

For more information, see the section on the Shortcut Key Editor in Appendix B.  
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Allow Pole Versions in Inventory 

Pole versioning functionality has now been extended to work with Line Design files. If a user wishes to 

allow pole versions in a line design the user must enable this option located under Options > User 

Interface Options > Allow Pole Versions in Inventory. 

Once enabled, the user can right click on their pole and select New > Version of This Pole. 

 

In the inventory tab, the user will then see a copy of the pole and its equipment with which the user can 

edit to make a different version of the pole. 

 

 

Calculate 
These functions allow the user to ‘solve’ the line design by running the calculation engine with O-Calc 

Pro once the line design is ready for analysis. The options here allow the user to choose what is 

analyzed, and how the analysis will be run.   

Options > Auto Solve Enabled 

When this option is enabled, O-Calc Pro will automatically update the line calculation after every edit. 

This feature will save the user time by eliminating the need to run a manual calculation to see the effect 

of the user’s edits by clicking the Ready button, located in the tool bar below the Capacity display. 

Re-Solve All 

This option will recalculate all poles in the Line Design according to the specifications of the latest 

changes 

Line Analysis 

Under this heading the user will find various options for manual line calculation 
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Current Pole 

Running an analysis on the current pole in the line runs an individual pole loading analysis on the pole; 

the result would be equivalent to the result generated in previous versions of O-Calc Pro. This 

calculation can also be obtained for a pole by clicking on the ‘Ready’ button in the lower left tool bar 

ribbon of O-Calc Pro, just below the Capacity display. 

 

Checked Poles Only 

In this heading the user can calculate a subset of poles from the entire line by checking the desired poles 

in the poles tab then using the drop-down menu to run a fixed wind or sweep wind calculation. You can 

also Re-run the last angle set, clear the MCU flags, and View Mesh for the checked poles similarly to the 

Run Entire Line features above.  

It is important to note that O-Calc Pro calculates for transferred loads in Line designs so if a subset of 

poles is calculated the line cannot account for the transferred load from a pole that is not calculated. 

 

Entire Line > Fixed Wind 

When running a calculation on an entire line of poles, there are two options for the user. This option 

allows a user to set the wind parameters that will be used when running an analysis on the entire line of 

poles. To run a calculation on an entire line using a fixed wind direction, follow these steps: 

1. Open a line design 

2. In the Main Line Design Area ribbon, select the Calculate option 

3. Hover the cursor over the Entire Line menu 

4. Select Fixed Wind 

5. Enter a value for the Wind Angle in the pop-up window, then click OK 

 

6. A report will be generated under the Reports tab in the main O-Calc Pro Interface. 
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7. Once finished reviewing the report, modifications to the calculations can be made by beginning 

this process over again and selecting a different Wind Angle, or using the Sweep Wind method, 

outlined in the next section. 

More information on interpreting the results of this report can be found on the associated wiki page, 

found here. When setting the wind angle, it is important to remember that this is the direction the wind 

is coming from, not the direction it is going to.  

Entire Line > Sweep Wind 

The other method available to a user allows for a more dynamic analysis of the line design. This option 

allows the user to set the parameters for analyzing a line design with wind coming from different 

directions and outputting the results for the worst-case scenario. By using this method, a user can easily 

determine the worst-case wind angle, and what that wind angle would do to the analysis of the entire 

line of poles. To use this method, follow these steps: 

1. Open a line design. 

2. From Line Design, select Calculate > Entire Line > Sweep Wind option. 

3. Use the default values or enter values for the Start Angle, End Angle, and the Increment to be 

used; click OK. 

http://o-calcpro.com/wiki/2018/12/18/understanding-the-o-calc-pro-line-analysis-report-2/
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4. This process will take a few moments longer than the Fixed Wind, but a report will be generated 

under the Reports tab in the main O-Calc Pro Interface. 

 

5. Once finished reviewing the report, modifications to the calculations can be made by beginning 

this process over again and selecting different values for the Start Angle, End Angle, and 

Increment Parameters. 

More information on interpreting the results of this report can be found on the associated wiki page, 

found here. When setting the Start and End Angles, it is important to remember that these are the 

angles that the wind is coming from. The Increment value determines which Wind Angles are also 

calculated between the Start and End Angles. 

http://o-calcpro.com/wiki/2018/12/18/understanding-the-o-calc-pro-line-analysis-report-2/
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Entire Line > Re Run Last Angle Set 

Re Run Last Angle Set allows the user to run the same calculation that was previously run after making 

further alterations to the line design. 

Entire Line > Clear MCU Flags 

Clear MCU Flags is used to clear the green, yellow, orange, and red flags that visually show the MCU 

thresholds on the poles tab of the Line Design Tabs Area. The flags will only appear after a pole or line 

design is calculated. The flags will be updated after every time the pole is calculated. Below is a before 

and after image of the Poles Tab when the Clear MCU Flags.     
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Entire Line > View Mesh   

This feature allows the user to view the mesh on the active pole created by O-Calc Pro used in the finite 

element analysis (FEA) calculation. This is helpful to visualize the loads acting on the pole and to view 

the pole deflection they cause. 

 

To bring up the mesh viewer window simply navigate to Calculate > Entire Line > View Mesh in the Main 

Line Design Area Ribbon.  

Options > Fix Span / Head Anchors 

  This option allows the user to change how O-Calc calculates span guys in line design. Normally when a 

pole is loaded and subsequently deflects, this deflection is applied to the span guy and is incorporated in 

the overall calculation of the line. By selecting the Fix Span / Head Anchors option, the deflection at the 

end of the span guy is not considered during the calculation of the line. 

Note: If this option is selected, O-Calc Pro will generate a warning in the analysis report as shown below. 
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Understanding the O-Calc Pro Line Design Tabs 
Aside from the new functions available from the Main Line Design Area, there are additional features 

available in four new tabs within the Line Design tab. Each of these tabs allows a user to exert further 

control over editing line designs and using additional data to supplement the model.  

Poles Tab 
The poles tab, found among the Line Design tabs, is essentially the ‘Inventory’ of all the poles that can 

be found in a line design. This tab is empty unless a line design is being viewed or edited. Once a line 

design is opened, a user can make pole selections and edits from this tab. The available edits are 

outlined in subsequent sections.  

All poles tabs can also be accessed from the Main Line Design area ribbon, provided that the Mirror 

‘Poles’ Menu on Main option has been checked.  

File Menu 

The File menu within the Poles tab allows a user to perform several functions when a line design has 

been opened. If a line design has not been opened, these menu options are not accessible.  

New Pole 

The New Pole option from this menu allows a user to generate a new pole while a line design is open. 

Additionally, a user can set the coordinates for the new pole being created. Below is an image showing a 

line design with three poles.  

https://osmose1934-my.sharepoint.com/personal/arose_osmose_com/Documents/Documents/O-Calc/O-Calc%20Documents/Mirror#_
https://osmose1934-my.sharepoint.com/personal/arose_osmose_com/Documents/Documents/O-Calc/O-Calc%20Documents/Mirror#_
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To add a new pole, follow these steps: 

1. Open a line design 

2. In the Poles tab, click on the File drop-down menu 

3. Hover the cursor over the New Pole option, and select a pole type from the list 

 

4. After the type of pole is selected, a Geolocation window will prompt for the coordinates and 

elevation of the new pole. The coordinates are set to the location of the center of the map view 

by default, while Elevation defaults to 0. 

a. Key in the coordinates and elevation of the pole. 

b. Or click in the map view to use the coordinate values at the clicked point. 

5. Click OK; another window will prompt the user for a selection of the type of pole. Make 

selections for the pole’s height, class, and species, then click OK. 

6. The pole will be displayed on the map view, but it will not be linked to the other poles in the 

Line Design since the new pole has no attachments. 
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7. Attachments can be added and manually linked to the other poles in the Line Design; more 

information on linking spans manually can be found here. 

Add PPLX Files to Line Design 

The Add PPLX Files to Line Design option from this menu allows a user to add previously created PPLX 

files to a line design after the line design has been started. Regardless of the method used to create the 

line design, additional poles can be added using this method. Below is an image of a line design file.  

 

To add an additional pole to this line design, follow these steps: 

1. Open a line design file 

2. Go to the Poles tab, click File > Add PPLX Files to Line Design. 

3. When prompted, select an existing pplx file using the Windows Explorer window; once selected, 

click Open. 

4. Depending on if the coordinates for the selected pole have already been set, the user may have 

to adjust the pole’s location. 

a. If the selected pole is far from the rest of the poles in the line, an error message will 

display; click OK on this warning to continue. 

 

b. When zooming out, it is possible to view all the poles in the line design, even those that 

are too far away from the rest of the line. 
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c. If necessary, reposition the pole to a position closer to the line; see Position Selected 

Pole 

5. Once the pole has been positioned correctly, it will be possible to link the spans on the added 

pplx file to spans on another pole in the line design; for further instruction on linking, see the 

Linking Spans Workflow in Appendix A. 

By using this feature, a user can add any pplx file that has already been created to a line design. This 

eliminates the need to rebuild the pole from scratch when the line design is being created, although the 

user does have that option as well.  

Export to PPLX File 

The Export to PPLX File option from this menu allows a user to activate a pole in a line design, and 

export it as a standalone pplx file, or a standalone pole model that is not part of a line design. To use this 

feature: 

1. Open a Line Design. 

2. Select the pole that needs to be exported; ensure that it is the active pole, or the pole shown in 

the Inventory window. 

3. In the Poles Tab, click on the File drop-down menu. 

4. Hover the cursor over the Export to PPLX File option, and select: 

a. Current Pole to PPLX 

b. Checked Poles to PPLX  

c. All Poles to PPLX 

5. When Prompted, enter a name for the PPLX file and set the location; then click Save. 

By using this feature, it is possible to generate a line of poles using the Line Design functionality, and still 

be able to generate single pplx models of each pole in a line.  
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Edit Menu 

The Edit menu, found within the Poles Tab, allows a user to adjust parameters for the poles in a line 

design.  

Position Selected Pole 

The Position Selected Pole option allows a user to set the Geolocation, or the coordinates, of a pole in a 

line design. The Geolocation changes are shown in the Map view, where the poles in a line design are 

displayed. To use this feature: 

1. Open a Line Design 

2. In the Poles Tab, click Edit > Position Selected Pole; a geolocation window will open. 

 

3. Manually enter new coordinates or click on a spot in the map area to update the coordinates. 

4. Click OK; the pole should be shown in its new location. 

Rotate Selected Pole 

The Rotate Selected Pole option allows a user to change the rotation, or line of lead, for a pole in a line 

design. This adjustment rotates the pole structure, including all elements attached to the pole. To use 

this feature:  

1. Open a Line Design, in the Poles tab, click Edit > Rotate Selected Pole; a rotation window will 

open. 

 

2. Enter a value for the rotation, and click OK. 

Set Elevation 

The Set Elevation option allows a user to model the poles in a line design at their actual elevations, 

taking terrain and environmental conditions into account when making assessments. Before using this 

tool, a user must Configure Elevation Provider, to identify where the elevation data will be taken from.  
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1. Open a Line Design, in the Poles tab, click Edit > Set Elevation, then select Configure Elevation 

Provider. 

2. In the opened window, set a Provider. If necessary, enter a valid API Key and click Ok  

 

Once the elevation provider is set, the user can modify the elevation for the current pole, checked poles, 

or all poles.  

3. In the Poles Tab, click on the Edit drop-down menu. 

4. Hover the cursor over Set Elevation, then select which pole or poles will be affected. 

5. A prompt will inform the user that the elevation value has been set. 

Split Spans and Insert Pole 

The Split Spans and Insert Pole option allows a user to easily insert a new pole into an existing line 

design without having to tediously un-link spans and adjust each attachment. This feature simple 

generates a new pole between two selected poles and modifies all attachments for the user. To use this 

feature, follow these steps: 

1. Open a Line Design; below is an image of an existing line design. 
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2. In the Poles tab, check the poles on either side of the spans that you’d like to split. For instance, 

to insert a pole between pole 1 and pole 2, I must check those poles. 

 
3. In the Poles tab, click Edit > Split Spans and Insert Pole. 

4. If enabled, a prompt for a Pole ID will appear, where a new pole number can be entered; click 

OK. 

5. A new pole will be placed between the checked poles, and will be shown in the Poles Tab, Map 

view and 3D View. 

 

This feature can be particularly useful when span lengths in a line put an excessive amount of load on 

one or more poles; inserting a pole would greatly reduce the stresses being applied to the surrounding 

poles.  

Remove Pole and Merge Spans 

The Remove Pole and Merge Spans option is very similar to the previous option. This allows a user to 

easily remove a pole in a line without tediously un-linking each span associated with a pole, or the 

surrounding poles. This feature removes the selected pole and links the orphaned spans to new 

counterparts on the next pole in the line. To use this feature: 

1. Open a Line Design; below is the same example from the previous section. 
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2. In the Poles tab, check the pole that needs to be removed. 

 

3. In the Poles tab, click on the Edit drop-down list. 

4. Click Remove Pole and Merge Spans; a confirmation prompt will appear – click Yes. 

 

5. The pole that had been checked will be removed from the line design; verify that the remaining 

spans have been linked together. 
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View Menu 

The View menu allows a user to manage how the poles are ordered and displayed in the map view, and 

within the Poles tab. The options here can be used to manage subsets of poles, sort the poles list, or 

reorder the list of poles.  

Pole Set 

The Pole Set option allows a user to view pole sets that have been created. A pole set is a subset of the 

poles in a Line Design. Selecting this option will display a list of Pole Sets that have been saved. See the 

next section in this document for information on how to save a pole set.  

Save Pole Set 

The Save Pole Set option allows a user to flag a set of poles, essentially like a bookmark. This saved pole 

set can be selected to easily select the poles within that set. This would be particularly useful for larger 

line designs, where a subset would need to be selected. To create a pole set, follow these steps: 

1. Open a Line Design. 

2. From the Poles tab, check each of the poles that will be included in the pole set. 

 

3. From the Poles tab, click on the View drop-down menu. 
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4. Select the Save Pole Set option; a window will open prompting the user to enter a name for the 

pole set. 

 

5. Enter a Pole Set Name, and click OK; now this named set of poles will be available under the 

Pole Set option. 

Check All and Uncheck All 

These two options allow a user to easily check all the poles in a line design or uncheck all the poles in a 

line design easily.  

Lasso 

This feature allows the user to check and uncheck specific poles in a line design by drawing a box around 

those poles in the line design map area. Follow the steps below to use the Lasso feature. 

1. From Line Design select the Poles tab > View > Lasso. 

2. Click on Lasso and the following box should appear in the upper left-hand corner of the map 

area. 

 

3. Left click in the map area at various points to create a box around the poles you wish to check or 

uncheck. 
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4. Select the yellow box in the upper left-hand corner to finish your lasso, then choose whether to 

check or uncheck the selected poles in the pop-up window. 

 

This feature is most helpful when trying to select poles that are not next to each other in your line 

design or when you wish to quickly select several poles at once using a visual method. 

Sort/Check Helper 

The Sort/Check Helper is a tool that allows for quick reordering of poles in a Line Design. For certain 

features, like the Profile View tool, the order of the poles is extremely important. This order can be seen 

in the Poles tab, indicated by the numbers in parenthesis beside each pole.  

 

To re-order the poles using the Sort/Check Helper, follow these steps: 

1. Open a Line Design 

2. From the Poles tab, select View > Sort/Check Helper; a yellow prompt appears above the map 

area. 
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3. This message indicates that by holding down the ‘Shift’ key, a user can reorder the poles. 

4. Hold down Shift, and hover the cursor over the pole that should be first in the new pole order; 

notice that the pole’s order number has changed, and it is displayed in green. 

 

5. Continue to hold down Shift, and move the cursor over the next pole in the new order; continue 

to do so until all the poles have been assigned a new order number. 
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6. When finished, click on the yellow text that reads Hover to Select, Hold ‘Shift’ to check, Click 

here when done. 

7. If all the poles in the line design have been re-ordered, the Sort/Check Helper will close 

automatically. 

Refresh 

The Refresh option forces all panels and windows of the application to redraw.  

Clear MCU Flags 

The Clear MCU Flags option allows a user to remove any MCU Flags that are displayed in the Poles Tab. 

Below is an image of a Line Design, with the MCU Flags displayed.  

 

These MCU Flags are generated when a pole’s Maximum Capacity Utilization is calculated, either 

manually or by using the options under the Calculate menu in the Main Line Design Area. By clearing the 

MCU Flags, the user removes the Pass/Fail indicator that was generated the last time the pole was 

solved. This option can be found under the View drop-down menu, under the Poles tab.  

Reset 

The Reset option restores the original pole order, if any manipulation has been made using the 

Sort/Check Helper or the Auto-Order option. This option can be found under the View drop-down 

menu, under the Poles tab.  
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Auto-Order 

The Auto-Order option organizes the poles list in an order, going from one end of a line design to the 

other. This option can be found under the View drop-down menu, under the Poles tab. 

Distances and Bearings 

By clicking on the Distances and Bearings option under the View drop-down menu, a user can see a list 

of the distances and directions, or bearings, from one pole to the next pole nearest to it. Below is an 

example of this list.  

 

GIS Files Tab 
The GIS Files tab allows users to preview and add user defined data to line designs. Initially GIS Data can 

be previewed before a line design has been created. Once a line design has been created, GIS data in the 

form of polylines and polygons can be added and viewed in the Main Line Design Area Map.  

File 

The file tab allows the user to preview or add several types of GIS files. Each file type and how to add 

them to O-Calc Pro are listed below. 

Preview Shapefile 

Before a line design has been started, Shapefile’s can be previewed. Once a line design has been 

created, shapefiles can then be added to the line design. This feature is useful to determine which 

shapefiles are ideal to be added to a line design. To preview a shapefile, follow these steps: 

1. Click on the GIS Files tab in the set of Line Design tabs. 

2. Select the File drop-down list and click Preview Shapefile. 

3. A session of windows explorer will open; navigate to the desired shapefile, select it, and click 

Open. 

4. The shapefile will be added to the GIS Files list with a description of the type and an assigned 

number; in the example below, the type of shapefile is a polygon. 
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5. If the shapefile is outside the current map view, go to the View menu in the GIS Files tab, and 

select Zoom to Bounds. 

Note: Multiple GIS Files can be added at the same time; when selecting a file in the windows explorer 

window, hold down the Ctrl key to select multiple files, then click Open.  

Preview KML file 

Before a line design has been started, KML files can be previewed. Once a line design has been created, 

KML Files can then be added to the line design. This feature is useful to determine which KML Files are 

ideal to be added to a line design. To preview a KML File, follow these steps: 

1. Click on the GIS Files tab in the set of Line Design tabs. 

2. Select the File drop-down list and click Preview KML File. 

3. A session of windows explorer will open; navigate to the desired KML file, select it, and click 

Open. 

4. The KML File will be added to the GIS Files list with a description of the type and an assigned 

number; in the example below, the type of KML File is a polygon. 

 

5. If the KML File is outside of the current map view, go to the View menu in the GIS Files tab, and 

select Zoom to Bounds. 

Preview CSV Lat Lon file 

Before a line design has been started, a CSV Lat Lon file can be previewed. Once a line design has been 

created, a CSV Lat Lon file can then be added to the line design. This feature is useful to determine 

which CSV Lat Lon files are ideal to be added to a line design. To preview a CSV Lat Lon file, follow these 

steps: 

1. Click on the GIS Files tab in the set of Line Design tabs. 

2. Select the File drop-down list and click Preview CSV Lat Lon File. 

3. A session of windows explorer will open; navigate to the desired CSV Lat Lon file, select it, and 

click Open. 

4. The CSV Lat Lon file will be added to the GIS Files list with a description of the type and an 

assigned number. 

5. If the CSV Lat Lon file is outside the current map view, go to the View menu in the GIS Files tab, 

and select Zoom to Bounds. 

Preview GeoJSON file 

Before a line design has been started, GeoJSON files can be previewed. Once a line design has been 

created, GeoJSON files can then be added to the line design. This feature is useful to determine which 

GeoJSON files are ideal to be added to a line design. To preview a GeoJSON, follow these steps: 



Osmose O-Calc® Pro 7.0 Confidential Line Design User Guide 

114   ©2023 Osmose Utilites Services, Inc.  
 

1. Click on the GIS Files tab in the set of Line Design tabs. 

2. Select the File drop-down list and click Preview GeoJSON. 

3. A session of windows explorer will open; navigate to the desired GeoJSON, select it, and click 

Open. 

4. The GeoJSON file will be added to the GIS Files list with a description of the type and an assigned 

number. 

5. If the GeoJSON file is outside of the current map view, go to the View menu in the GIS Files tab, 

and select Zoom to Bounds. 

 

Preview GPS NMEA file 

Before a line design has been started, a GPS NMEA file can be previewed. Once a line design has been 

created, GPS NMEA files can then be added to the line design. This feature is useful to determine which 

GPS NMEA files are ideal to be added to a line design. To preview a GPS NMEA file, follow these steps: 

1. Click on the GIS Files tab in the set of Line Design tabs 

2. Select the File drop-down list, and click Preview GPS NMEA File 

3. A session of windows explorer will open; navigate to the desired GPS NMEA file, select it, and 

click Open 

4. The GPS NMEA file will be added to the GIS Files list with a description of the type and an 

assigned number 

5. If the GPS NMEA file is outside the current map view, go to the View menu in the GIS Files tab, 

and select Zoom to Bounds 

Clear Preview 

Any number of GIS Files can be previewed prior to starting a line design. Once a user is finished 

previewing GIS files, they can all be removed simultaneously from the GIS Files list. To do so: 

1. Select the File drop-down menu from the GIS Files tab 

2. Select Clear Preview 

Note: Clearing a preview cannot be undone. 

Add Shapefile to Line Design 

Adding shapefiles to a Line Design can only be done after the Line Design has been started. To add this 

type of GIS data to a Line Design, follow these steps: 

1. Create or open a Line Design file 

2. Click on the GIS Files tab in the set of Line Design tabs 

3. Select the File drop-down list, and click Add Shapefile to Line Design 

4. A session of windows explorer will open; navigate to the desired Shapefile, select it, and click 

Open 

5. The Shapefile will be added to the GIS Files list with a description of the type, and an assigned 

number 

6. Ensure that the Display GIS files box is checked 

7. If the Shapefile is outside of the current map view, go to the View menu in the GIS Files tab, and 

select Zoom to Bounds 
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Add KML File to Line Design 

Adding KML files to a Line Design can only be done after the Line Design has been started. To add this 

type of GIS data to a Line Design, follow these steps: 

1. Create or open a Line Design file 

2. Click on the GIS Files tab in the set of Line Design tabs 

3. Select the File drop-down list, and click Add KML file to Line Design 

4. A session of windows explorer will open; navigate to the desired KML file, select it, and click 

Open 

5. The KML file will be added to the GIS Files list with a description of the type, and an assigned 

number 

6. Ensure that the Display GIS files box is checked 

7. If the KML file is outside of the current map view, go to the View menu in the GIS Files tab, and 

select Zoom to Bounds 

Add CSV Lat Lon file to Line Design 

Adding CSV Lat Lon files to a Line Design can only be done after the Line Design has been started. To add 

this type of GIS data to a Line Design, follow these steps: 

1. Create or open a Line Design file 

2. Click on the GIS Files tab in the set of Line Design tabs 

3. Select the File drop-down list, and click Add CSV Lat Lon file to Line Design 

4. A session of windows explorer will open; navigate to the desired CSV Lat Lon file, select it, and 

click Open 

5. The CSV Lat Lon file will be added to the GIS Files list with a description of the type, and an 

assigned number 

6. Ensure that the Display GIS files box is checked 

7. If the CSV Lat Lon file is outside of the current map view, go to the View menu in the GIS Files 

tab, and select Zoom to Bounds 

Add GeoJSON file to Line Design 

Adding GeoJSON files to a Line Design can only be done after the Line Design has been started. To add 

this type of GIS data to a Line Design, follow these steps: 

8. Create or open a Line Design file 

9. Click on the GIS Files tab in the set of Line Design tabs 

10. Select the File drop-down list, and click Add GeoJSON file to Line Design 

11. A session of windows explorer will open; navigate to the desired GeoJSON file, select it, and click 

Open. 

12. The GeoJSON file will be added to the GIS Files list with a description of the type, and an 

assigned number. 

13. Ensure that the Display GIS files box is checked. 

14. If the GeoJSON file is outside of the current map view, go to the View menu in the GIS Files tab, 

and select Zoom to Bounds. 
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Add GeoImage file to Line Design 

Adding GeoJSON files to a Line Design can only be done after the Line Design has been started. To add 

this type of GIS data to a Line Design, follow these steps: 

1. Create or open a Line Design file. 

2. Click on the GIS Files tab in the set of Line Design tabs. 

3. Select the File drop-down list, and click Add GeoJSON file to Line Design. 

4. A session of windows explorer will open; navigate to the desired GeoJSON file, select it, and click 

Open. 

5. The GeoJSON file will be added to the GIS Files list with a description of the type, and an 

assigned number. 

6. Ensure that the Display GIS files box is checked. 

7. If the GeoJSON file is outside of the current map view, go to the View menu in the GIS Files tab, 

and select Zoom to Bounds. 

Add GPS NMEA file to Line Design 

Adding GeoJSON files to a Line Design can only be done after the Line Design has been started. To add 

this type of GIS data to a Line Design, follow these steps: 

1. Create or open a Line Design file. 

2. Click on the GIS Files tab in the set of Line Design tabs.. 

3. Select the File drop-down list, and click Add GeoJSON file to Line Design 

4. A session of windows explorer will open; navigate to the desired GeoJSON file, select it, and click 

Open. 

5. The GeoJSON file will be added to the GIS Files list with a description of the type, and an 

assigned number. 

6. Ensure that the Display GIS files box is checked. 

7. If the GeoJSON file is outside of the current map view, go to the View menu in the GIS Files tab, 

and select Zoom to Bounds. 

Remove Selected GIS file 

Any number of GIS Files can be added to a line design. If a user has added a GIS File that they wish to 

remove, each GIS File must be removed individually. To do so: 

1. Highlight the GIS File 

2. Select the File drop-down menu from the GIS Files tab 

3. Select Remove Selected GIS File 

4. On the prompt, select Yes to delete the file 

5. Repeat steps 1-4 until all unnecessary GIS Files have been removed. 

Note: Remove a GIS File cannot be undone. 

View 

Listed below are the features included under the View tab. 

Zoom to Bounds 

This option allows a user to select a previewed or loaded GIS File, and zoon to the selected file’s extent.  
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Embed GIS in Line Design 

This checkbox allows the GIS files to be saved with the line design so they are available when the .pplld 

file is shared or opened on another computer. 

Tools 

The following tools are used to create files in O-Calc Pro such as GeoImages and other GIS file types. 

Create GeoImage 

This tool is used to create a geoimage file manually in O-Calc Pro by selecting the bounding area of the 

geoimage you wish to create then adding an image to that area from a file on your computer. 

 

Manually Create Poly 

Similar to creating a Geoimage file in O-Calc Pro, this option allows the user to manually designate an 

area in O-Calc Pro which the user can save as a .geojson file. 

Display GIS Files 

This checkbox allows a user to easily toggle on or off the display of all GIS Files being previewed or 

drawn in a line design.  

GIS File Attributes 

GIS files that are previewed or added to a line design are drawn using a set of default attributes. These 

attributes can be altered by the user, to adjust how a GIS file is rendered in the map view of the Main 

Line Design area. Below is an example of the attributes for a polygon GIS file.  

 

The left column indicates the attribute that can be adjusted, while the right column indicates the values 

associated with each attribute.  
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Displayed The Displayed attribute indicates whether the selected GIS File will be 
rendered in the Map view.  
 
Rather than remove a GIS File, a user can adjust this attribute to prevent a GIS 
File from being drawn.  

LineColor The LineColor attribute is the defined color used for the perimeter of a 
polygon or for polyline features. 

FillColor The FillColor attribute indicates the color used for the fill of polygon features. 

LineWidth The LineWidth attribute indicates the thickness of the line used in rendering 
the selected GIS File.  

Easement The Easement attribute indicates whether the selected GIS File will be used as 
an easement file. 

 

Map Tab 

Display OMV Tiles 

In O-Calc Pro Line Design, Open Map Vector Tiles (packets of geographic data) can be displayed.  This is 

an emerging method for delivering styled web maps, combining certain benefits of pre-rendered raster 

map tiles with vector map data. 

OMVT Folder Path 

Displaying the OVM Tiles will show simplified roads and labels. To do so: 

1. Click the map tab 

2. Click into the check box labeled Display OMV Tiles 

3. If the map path is not displayed in the OMVT folder path, proceed to step 4 

4. Click the ellipse button to navigate to the file location, add file as prompted 

 



Osmose O-Calc® Pro 7.0 Confidential Line Design User Guide 

©2023 Osmose Utilities Services, Inc.      119 
 

Display Map Tiles 

Additionally, The Map View in the Line Design Tab can read and display map tiles from many sources 

such as OpenStreetMap, Google Maps, or Bing. The user can also display map tiles created from 

formatted LiDAR. 

 

Tile Source 

For some maps, a key may be required that must be obtained/purchased by the user from the host’s 

website. The user can select the provider using the dropdown menu under tile source. 

Cache Tiles to Disk 

The user can cache map tiles to a location on their computer by selecting this option and choosing a file 

location. 

Display GeoImages 

The display GeoImages checkbox allows the user to display GeoImage files from their computer on the 

Line Design Map. 
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GeoImage Folder Path 

The user must enter a valid folder path containing O-Calc consumable GeoImage files in this field to 

display GeoImages on the Line Design Map. 

Clearance Tab 
In the Line Design Tabs area, the Clearance Tab can be used to assess clearance violations between the 

attachments on any pole in a line design, and environmental objects like the ground line, surfaces, 

structures, and foliage. The clearance analysis tool in Line Design has been expanded, to allow for 

analysis to be performed in a broader way, rather than strictly in profile.  
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Violations Tab 

The violations tab will track any clearance rule violations that have occurred across the length of a line 

design. Once the rules and environmental objects have been created, the violations tab will list for the 

user where the violations are, and what they are.  

Violations 

The Violations button will list any violations to the clearance rules that have been created. The user can 

filter the results based on All Poles, Checked Poles, or the Current Pole. When no violations are found, 

the list will remain blank. When Violations are found, a list of each of the poles with a violation will be 

generated. Within this list will be the attachments on each pole that are associated with a rule violation.  

Un-Tagged Spans 

The Un-Tagged Spans button will list any spans within the line design that have not been marked with a 

clearance group. When clearance rules are generated, the user must also assign a clearance group tag to 

each span that will be considered when the analysis is run – any spans that are not tagged with a 

clearance group will not be considered in the analysis. To easily identify if a span has not been tagged, 

follow these steps: 

1. Open a Line Design 
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2. Set the Clearance Rules; this includes the rules, the clearance groups, and the clearance objects 

like structures, surfaces, and foliage.  

3. Run the clearance analysis 

4. Under the Clearance tab, go to the Violations section 

5. Click on the Un-Tagged Spans option; a list of poles will be generated 

6. From this list of poles, each span that does not have a clearance group tag will be shown 

 

The Un-Tagged Spans list can be used to easily identify spans that may have been overlooked when 

clearance group tags were placed.  

Obstructions Tab 

The Obstruction Tab allows a user to set up the parameters for the clearance analysis that is being 

performed. Here, the rules that will be used can be created. Additionally, the environmental objects that 

will be considered in the analysis can be created in this tab.  

Add Menu Options 

The Add menu allows a user to add surfaces, structures, or foliage to the landscape around a line design, 

to be considered when a clearance analysis is being run. Adding clearance objects to the landscape of a 

line design allows them to be considered when the analysis is run.  

Clearance objects can be created by importing a csv file with a list of locations and measurements. To 

import the csv file the user must navigate to add menu options > … > Import from file after creating the 

appropriate clearance rules. 
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Clearance objects can also be created manually. The first type of object that can be added is a structure. 

Any type of structure can be created in the Clearance Rules Editor. Then, all created structures are listed 

under this Add Menu option. For instance, if I were to add a shed to my line design, I could consider it 

when the analysis is run.  

                

Once the structure object is selected, it can be placed in the map view. The cursor will show the object 

being placed, along with the latitude and longitude for where it is going to be placed.  
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Choose a location for the shed and left-click on the map. A prompt will require the dimensions for the 

object.  

Continue clicking on the map to place more of the object, and then finish adding by clicking the yellow 

Add Shed (Click here when done) button. The object will be shown in the Map view, as well as in the 3D 

View.  
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Additional prompts will allow a user to set the elevations for objects based on any elevation provider 

that has been set-up.  

A similar process can be used for adding foliage; the type of foliage is selected, and a left-click in the 

map area is used to place it.  

 

Adding a surface is slightly different; the surface type is selected, and a left-click in the map area is used 

to place it. However, when it is drawn, it typically would not have a height value, just a width.  
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Rules > Violations Report 

By selecting the Violations Report option, a user will be given a report that lists all the clearance 

violations that have been found in a line design.  

 

Rules > Show Clearance Rules 

The Show Clearance Rules option allows a user to view a report that lists all the rules that have been 

created, or are currently active in the open session of O-Calc Pro. This file lists the rule name, clearance 

requirement, source, and target information for each rule.  
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Rules > Edit Clearance Rules 

The Edit Clearance Rules option opens the Clearance Rules Editor; this is the first step in running a 

clearance analysis. The rules, clearance group tags, and clearance objects can all be created in this 

window.  

Clearance Rules indicate the distances that must be between various objects. A typical clearance rule 

required that the required amount of clearance (in feet) be entered first. Then the rule can be named 

and given a description. In the image below, a clearance rule has been generated called Comm to 

Ground which indicates that there must be 18 feet of clearance between communication spans and the 

ground.  
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Next, the Sources and Targets that this rule will apply to need to be set. This can be done by clicking the 

‘…’ button next to the (Collection) area.  

 

This opens another window, where the sources and targets can be set. The sources are the upper limit 

of the rule; these are the objects that, in this case, must be 18 feet above the ground. The targets are 

the lower limits; these are the objects that must be 18 feet below the sources. The lists for sources and 

targets are populated based on the Clearance Groups and Clearance Objects that have been created. For 

more information on creating clearance groups and objects, see the associated article.  

http://o-calcpro.com/wiki/2017/05/23/clearance-analysis-process-and-report/
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Once the sources and targets are selected, click OK. The last step for creating a rule is to assign a 

violation name, severity, and if desired a location. This process can be repeated to create any number of 

rules. These rules must be carefully created for an accurate clearance analysis report.  

Rules > Import Clearance Rules 

The Import Clearance Rules option allows a user to take a generated file of clearance rules from a 

source, and import them into their own session of O-Calc Pro.  

Rules > Export Clearance Rules 

The Export Clearance Rules option allows a user to take the clearance rules they have created and share 

them with others by exporting them as a standalone file.  

Edit > Select by Position 

The Select by Position option opens a geolocation window where coordinates can be entered. Objects 

at that location can be selected, or the nearest object to that point will be selected.  

Edit > Dimensions 

The Dimensions option under the edit menu allows a user to change the dimensions of the clearance 

object after it has already been set. For instance, the width and height of any clearance object can be 

adjusted. Simply select the item from the list of clearance objects, and under the Edit menu, select this 

option.  

Edit > Set Elevation 

Under the Edit menu in the Obstruction tab, there is an option that allows a user to set the elevation for 

one or more clearance objects. When a clearance object is added, there is a prompt to set the elevation 
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at that point. If a user chooses not to, but wishes to edit the elevation later, this option can be used. 

There are several choices available for setting the elevation:  

 

The user can set the elevation for either a selected obstruction, or all obstructions at once. If an 

elevation provider has not yet bene configured, there is an option to do so from this menu item. Lastly, 

a user can enable the Auto Apply Elevation option, to automatically set the appropriate elevation for an 

object if an elevation provider has already been configured.  

Edit > Set Position 

The Set Position option allows a user to adjust the position of a clearance object after it has already 

been placed. Selecting this option will open a geolocation window, where a user can manually type in 

the coordinates for a new position or click in the map view to set the location.  

Edit > Delete 

The Delete option allows a user to remove a clearance object from the list, and therefore the clearance 

analysis.  

Easement Tab 

The third sub tab found on the Clearance Tab is called the Easement Tab. The Easement Tab is to define 

a polygon that can be labeled as an easement. Once an easement polygon has been defined, O-Calc Pro 

Line Design will list pole, anchors, etc. that have coordinates that are outside of the easement polygon. 

To add an easement polygon to your Line Design, use the GID Files tab to load a Shapefile, KML file, or 

other supported file to the Line Design. Once loaded, select the file, and change the Easement attribute 

from False to True. If no file is loaded the following prompt appears: 
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Violations 

Within the Easement Tab, once one or more easement polygons have been defined and the Violations 

button is selected, all objects (poles, anchors, push braces, or stub poles) that are not located in at least 

one easement polygon will be listed. 

Understanding Changes to the 3D View Window 
Many of the features outlined in this document pertain specifically to the Line Design tab. However, 

there are additional enhancements related to Line Design that can be found in other parts of the 

program’s interface, including the 3D View Tab.  

 

Updates to the 3D View Controls 
The 3D view controls have been updated and enhanced to work more intuitively and to provide 

additional features to help users fully realize the advantages of full line analysis in Line Design.  
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Changes to the HUD (Heads-up Display) 

The Heads-up display has been replaced in version 6.02 due to the changes to the camera control 

system. Instead of the Heads-up display found in the upper left-hand corner of the 3D View window you 

will see 3 buttons: (R), (B), and the 3D View Options Menu button in between. 

 

The 3D view options menu allows the user to save, copy, or print an image of the 3D view. 

 

Camera Look Point 

Previous 3D View Controls included in our older versions of O-Calc Pro, restricted the camera to a 

cylindrical orbit 20,000 inches away from the centerline of the pole. Traditionally, the camera could 

move to a point on that cylinder only, and zooming was accomplished by changing the camera’s field of 

view. Panning was only possible along a vertical axis. But depending on field of vision (FOV), this made 

the ability to visualize other locations, i.e. adjacent poles, limited and hard to understand. 

In the new camera system, the camera look point is now adjustable allowing the user to be able to 

visualize their workspace more effectively.  

The “ball” icon represents the camera “look point”. The camera always looks at this point and therefore 

this ball will always remain in the middle of the 3D View. 
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The user can select a point on the screen where they wish to place the camera look point by utilizing the 

Alt Key Controls enumerated below. 

1. Hold Alt key and left click mouse on any object to move to that selected point. 

 

2. When a span is selected the following menu will appear when the Alt button is released. 
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Changing the control scheme 

There are two new control sets, Default and Alternate, to choose from. To change the active control 

scheme, use the following instructions. 

From the Options menu, select Camera, and click the User Alternate Control Scheme option.    
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Default control scheme 

Press Left mouse button and move mouse: 

• Left-Right mouse movement orbits the camera around the look point (orbit) 

• Up-Down mouse movement moves the camera AND look point up or down equally 

• While holding "Alt" key down: 

o Left-Right mouse movement does nothing 

o Up-Down mouse movement works normally 

• While holding "Left Shift" key down: 

o Left-Right mouse movement works normally 

o Up-Down mouse movement moves ONLY the camera (tilt)  

• You may hold "Shift" and "Alt" together 

Press Right mouse button and move mouse: 

• Left-Right mouse movement orbits the look point around the camera (pan) 

• Up-Down mouse movement moves the camera AND look point up or down equally 

• While holding "Alt" key down: 

o Left-Right mouse movement does nothing 

o Up-Down mouse movement works normally 

• While holding "Left Shift" key down: 

o Left-Right mouse movement works normally 

o Up-Down mouse movement moves ONLY the look point (reverse tilt)  

• You may hold "Shift" and "Alt" together 

Mouse Wheel 

• Scrolling Forward on the mouse wheel moves camera towards look point (zoom in) 

• Scrolling Backward on the mouse wheel moves camera away from look point (zoom out) 

• If the option Invert Mouse Wheel is selected, then the previous settings will be reversed. To 

check this setting go to Options > Misc Options > User Interface Conventions … > Invert Mouse 

Wheel 

• While holding "Alt" key down: 

o Scrolling Forwards on the mouse wheel moves camera towards look point (dolly) 

o Scrolling Backwards on the mouse wheel moves camera towards look point (reverse 

dolly) 

o If the option Invert Mouse Wheel is selected, then the previous settings will be 

reversed. 

Alternate control scheme 

Although the alternate control set is based on current 3D modeling standards, it was a significant 

deviation from traditional O-Calc controls, therefore it was decided against being the default control set. 

 

Left Mouse Click and Drag: 
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• Left and Right to Orbit Camera around Look Point 

• Up and Down to Raise and Lower Camera and Look Point 

Left Mouse Click and Drag with the Alt Key Held Down: 

• Left and Right to Orbit Camera around Look Point 

• Up and Down to Raise and Lower Camera only but NOT Look Point 

Left Mouse Click and Drag with the Shift Key Held Down: 

• Left and Right to Orbit Look Point around Camera 

• Up and Down to Raise and Lower Camera only but NOT Look Point 

Left Mouse Click and Drag with Both the Shift and Alt Key Held Down together: 

• Left and Right to Orbit Camera around Look Point 

• Up and Down to Raise and Lower Look Point but NOT Camera 

Right Mouse Click and Drag: 

• Left and Right to Move Camera and Look Point Perpendicular to Look Direction 

• Up and Down to Move Camera and Look Point Parallel to Look Direction 

Right Mouse Click and Drag with Shift Held Down 

• Left and Right Movement has no action 

• Up and Down to Move Camera Towards or Away from Look Point (Zoom) 

Mouse Wheel 

• Moves Camera Towards or Away from Look Point (Zoom) 

• Hold the Shift Key to Raise and Lower the Camera and the Look Point 

• Hold the Alt Key to Raise and Lower the Look point but Not the Camera 

• Hold Both the Shift and Alt Keys to Raise and Lower the Camera but Not the Look Point 

 

Wind Direction Arrow 
When a pole or line design is calculated in O-Calc Pro the Wind Direction Arrow will be displayed in the 

3D View.  In version 6.0 the description was updated to avoid confusion as O-Calc Pro now makes 

distinctions between the Groundline Capacity Utilization(GCU) and the Maximum Capacity Utilization 

(MCU). Now the text under the arrow will say W (for wind), the wind angle in degrees, and the wind 

pressure in pounds per square foot (psf). 
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Pole Filter Options 
In Line design the user can see many poles at a time in the 3D view. However, at times, a user may wish 

to view only focus on a smaller number of poles rather than the entire line. 

On the lower right corner of the 3D View the user can access a dropdown with pole filter options to only 

display the checked poles, unchecked poles, or the selected pole only. 

 

By default, the selection in this list is set to ‘All Poles’, which means that all Poles present in the line 

design are shown in the 3D View. 

Span Visualization Options 
The user can adjust the visual thickness of the spans in the 3D View by adjusting the value in a 

dropdown box in the lower right corner of the 3D View. Options include 1X x, 2X, 4X, 8X, and 16X the 

actual thickness of the span. 
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Filtering Spans by Linked Status 
The 3D View window displays a rendering of the currently open pole, or the active pole in an open line 

design. When a line design is open, each of the poles are displayed in the 3D View tab. above is an 

example of a line design visible in the 3D View tab.  

A new drop-down menu in the bottom-right corner of the 3D View window allows a user to filter what is 

displayed in the 3D View by looking at certain characteristics of spans. Specifically, the drop-down menu 

will allow a user to view spans based on if they are linked to other spans in a line design.  

 

By default, the selection in this list is set to ‘All Spans’, which means that all spans present in the line 

design, regardless of linked status, are shown in the 3D View. This selection can be changed to any of 

the following options as well: 

Linked Selecting to display only the ‘Linked’ spans will only draw those that are linked to 
another span in the line design. 

Un-Linked Selecting to display only the ‘Un-Linked’ spans will only draw those that are not linked 
to any other span in the line design. 

Sel Pole Selecting to display only the ‘Sel Pole’ spans will only draw the spans associated with 
the selected, or the current pole in the line design.  

 

Scaling Rendered Poles 
The 3D View renders a single pole or the active pole in an open line design. When a line design is open, 

each of the poles in the line is displayed in the 3D View tab.  

A new numeric field in the bottom-right corner of the 3D View allows a user to change the scaling of the 

line design shown in the 3D View.  
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By default, the value is set to 100, which corresponds to the standard scale used when rendering in the 

3D View. When using the up or down arrows, the scaling can be changed incrementally. Doing so will 

render the poles closer together, allowing a user to see more poles in the line at the same time. In the 

image below, the scaling has been set to 25, so poles appear closer together without adjusting the span 

length between poles.  

 

Distance Filtering 
The user can also filter poles by their distance from the selected pole. A numeric field is placed in the 

bottom right corner of the 3D View which allows the users to adjust the range, in 50ft increments, in 

which poles are rendered.  

For example, if an adjacent pole in a line design is 60ft away from the selected pole, it will not be 

rendered in the 3D view if the distance filtering range is set to 50ft. It will be rendered if the range is set 

to 100ft.  
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Understanding Reports and Charts Generated in Line Design 
The automatic calculation functionality for a single pole is disabled in Line Design Mode. Instead, when a 

line design is completed, a user has the option to run a calculation on a single pole or the entire line of 

poles. The Line Analysis report analyzes an entire line of poles based on the wind parameters set by the 

user. To generate a report, read the Calculate Options section of this document. 
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Entire Line Analysis with Fixed Wind Report 

 

The name of the Line Design file is provided in the upper left-hand corner of the report. The date the 

report was generated is shown under the O-Calc Pro Line Analysis title. The wind angle of 0° shown 

above the pole data is the value inputted for the Fixed Wind Angle parameter when calculating. 

The first section of the report indicates the worst wind angle for each pole in the line with regards to 

MCU (Maximum Capacity Utilization) and GCU (Groundline Capacity Utilization). In the example above, 

the greatest MCU for pole 1 occurs at a wind angle of 0° and is 29.6%.  

In the next section of the report each pole in the line is addressed indicating each pole’s GCU 

(Groundline Capacity Utilization), VCU (Vertical Capacity Utilization), TCU (Transverse Capacity 

Utilization), and MCU (Maximum Capacity Utilization). The values are provided as percentages and are 

color coded based on pass/ close to failure/ fail basis. Values in red indicate failure or exceeding 100%. 

The O-Calc Pro Line Analysis Report will also provide information on any guying on the poles in a line, if 

present. Each guy wire present in the line design is shown, with an indication of which pole it is attached 

to. Additionally, the tension and capacity of each guy wire is shown. These values may change based on 

the wind angle being analyzed, so these guy wires are included under each wind angle section. 
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Entire Line Analysis with Sweeping Wind Report 
The image below shows the values that would be found with a wind angle of 0° and 10°. When 

calculating using the sweep wind option the report will display the values according to the min, max, 

and interval the user inputs. 

Other than reporting multiple wind angles, the sweeping wind report is organized the same way as the 

fixed wind report. 

Partial Line Analysis Report 
Instead of calculating for every pole in a line design, the user can choose the poles in the line design 

which they wish to analyze and run either a fixed or sweeping wind calculation. 

The report would look the same as the reports above but would only include the poles designated by 

the user. 

Violations Report 
The Violations Report was discussed in a previous section of this document. See this section 

Profile Chart 
The Profile Chart was discussed in a previous section of this document See this section 

Appendix A – Common Workflows 
This section of the user guide outlines some common scenarios that would be encountered while 

working with the new features of Line Design. While these workflows are centered on specific examples, 

the steps outlined could be applied to a similar situation encountered by a user. 
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Linking Spans 
Linking spans refers to the process of taking two poles in a line design and connecting them through a 

connection of the spans on one pole, to corresponding spans on another pole. There are several rules 

that must be followed when spans are going to be linked; those rules are listed here: 

1. Spans that are going to be linked must be the same span type; for instance, a primary span can 

only be linked to another primary span, and a communication messenger only to another 

communication messenger 

2. Spans can only be linked to one other span; one span cannot be linked to multiple spans on 

another pole in the line design 

3. When linking communication bundles, the number and type of communication conduits that are 

included in the bundle are determined by the span that acts as the origin of the link. For 

instance, a communication bundle with two conduits being linked to a communication bundle 

with three conduits – The bundle on the active pole when the linking occurs is the format that 

would be used 

4. Unlinking spans must be done on both segments involved in the initial link 

Linking Single Spans 

The most basic aspect of linking spans is linking one span to another. In the image below, two poles in a 

line design are not linked.  

 

This image shows the pole on the left having three primary spans, a secondary, and a communication 

bundle. The pole on the right has three primary spans, a secondary, and a communication span. At this 

stage, both poles are in the line design, but they are not linked. To link the primary spans from one pole 

to those on the other pole, follow these steps: 
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1. Determine which is the active pole; this can be done by seeing which pole is listed in the 

inventory, and is indicated by the compass being present underneath the pole in the 3D View. In 

this example, the pole on the left is the active pole.  

2. Select one of the primary wires on the active pole; you will not be able to select spans on a pole 

that is not active.  

 

3. Once the span on the active pole is selected, left-click and hold on the span, and drag-and-drop 

it to a span on the other pole that it should be linked to. This can be done from the Inventory 

window, or from the 3D View.  

a. If performing from the inventory window, find the selected span, and left-click and hold 

on that span 
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i. Drag-and-drop, placing the cursor overtop of the span to be linked to, in the 3D 

View; the symbol of the cursor will show a small curved arrow, used to indicate 

that a link is possible 

ii. Let go of the mouse click, and the spans will become linked 

 

b. If performing from the 3D View, find the selected span, and left-click and hold on that 

span 

i. Drag-and-drop, placing the cursor overtop of the span to be linked to in the 3D 

View; the symbol of the cursor will show a small curved arrow, used to indicate 

that a link is possible 

ii. Let go of the mouse click, and the spans will become linked 
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Now that the primary wires are linked, any changes that occur on one of the spans can be applied to all 

of the spans that are linked to it; this concept is called Connectivity. 

Linking Span Guys 

Span guys can also be linked similarly to linking single spans, however there is an extra rule. As span 

guys are modeled like other types of guys in O-Calc Pro, they are attached to the pole with an anchor 

and guy brace. In order for span guys to successfully link, there must only be one guy per anchor.  

The Split Spans Head Anchors tool described in this document allows the user to quickly prepare span 

guys for Linking. 

When the span guys are prepared for linking, the user can easily link the span guys following the 

procedure for linking single spans in the previous section. 

Unlinking Spans 

Another common scenario may be that two spans were linked together that should not have been. 

These spans would have to be unlinked before the corrections could be made. In the image below, two 

of the spans that were linked are incorrect; they must be unlinked before the corrections can be made.  

http://o-calcpro.com/wiki/2019/01/02/connectivity-in-o-calc-pro-line-design/
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To unlink the spans in this image that are crossing, follow these steps: 

1. Open a line design with linked spans that must be unlinked 

2. Select one of the poles in the line with spans that must be unlinked; using the same example, 

the pole on the right is selected as the active pole 

3. Select the span to be unlinked 

4. Right-click on the span, either in the 3D View or the Inventory tab, and in the menu select Un-

Link Span 
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a. This will un-link the two spans involved in the original link, but that does not complete 

the process; both segments of the link must be Un-linked.  

5. Switch to the other pole with the span to be unlinked; switch to this pole by either clicking on it 

in the 3D view, or selecting it from the Poles list in the Line Design tab 

6. Select the span that was part of the link; it needs to be Un-Linked as well; right-click on it and 

select Un-Link Span from the menu 

a. Now both segments are free to be linked to other spans 

Again, Un-Linking spans is vital if those spans need to be Linked to another span. Both sides must be Un-

Linked before new Links can be formed.  

Linking Communication Bundles 

When communication bundles need to be linked together, there are a few more factors to keep in mind. 

Communication bundles on poles may have different messenger wire sizes, and different conduits 

included in each bundle.  

In the image below, the pole on the left has a communication bundle with a with a 5/16” EHS 

Messenger wire and a Telco conduit. 
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When communication bundles are linked together, the active pole determines the final contents of the 

linked communication bundle. So, if the pole on the left is selected when the Linking is performed, the 

Linked communication bundle will have a 5/16” messenger. If the pole on the right is selected when the 

linking is performed, the Linked communication bundle may have a different sized messenger. To link 

communication bundles, follow these steps: 

1. Open a line design with communication spans to be linked 

2. Select one of the poles in the line with spans that need to be linked; using the same example, 

the pole on the right is active and selected 

3. Select the messenger wire of the bundle to be linked 

4. Left-click and hold on the messenger wire, either in the 3D View or in the inventory window 

5. Drag-and-Drop the selected messenger, placing the cursor overtop of the messenger wire for 

the bundle it will be linked to; the curved arrow symbol will appear to indicate that a Link can 

occur 

6. Release the mouse click, and the bundles will become linked 
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7. Look at the inventory window; it shows that the active pole has a communication bundle with 

5/16” EHS Messenger wire and a Telco conduit 

8. Switch to the pole on the right; the non-active pole when the Linking occurred 

 

9. Look at the inventory window; it shows that the active pole has a communication bundle with 

the 5/16th messenger wire; it has taken on the properties of the communication bundle on the 

active pole when the Linking was performed 

Linking to Insulators 

In some cases, such as when using the Add PPLX Files to Line Design function, it may be necessary to link 

the spans of a new pole to an existing line. However, there may not be spans to link to. In the image 
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below, the pole on the left needs to be linked to the rest of the line design, but there are no available 

spans on the pole on the right.  

 

In these situations, it is possible to link spans to an insulator rather than another span. This can be done 

using the following steps: 

1. Open a line design with spans to be linked 

2. Select one of the poles in the line with spans that need to be linked; using the same example, 

the pole on the left is active and selected 

3. Select the messenger wire of the bundle to be linked 

4. Left-click and hold on the messenger wire, either in the 3D View or in the inventory window 

5. Drag-and-drop the selected messenger wire, placing the cursor over the insulator on the 

adjacent pole, where the link should occur 

6. Release the mouse click to link the selected span to the insulator 

7. Continue this process for each span that needs to be linked to an insulator on the adjacent pole 
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When linking to an insulator, the span that is being linked is effectively created on the neighboring pole. 

So, when Un-linking these spans, the Un-Link operation will have to be done to the original spans, and 

the span that was generated on the neighboring pole. Un-linking does not remove the span that was 

created on the adjacent pole.  

For a reminder on the Un-linking process, see this section.  

Editing Line Designs directly from the Line Design Map 
In select circumstances the user may wish to edit poles in a Line Design directly from the overhead Line 

Design Map view. To satisfy this need O-Calc allows the user to drag and drop elements from the 

catalog, inventory, or from the selected pole in the Line Design Map and attach them to another pole in 

the line design.  

This functionality works similar to how drag and drop additions work in the 3D view, with two 

exceptions: 

1. The Line Design Map has a setting called MapDragMinZoom that disallows the user from using 

this feature when the Map is zoomed too far away. This is because it is difficult to see where you 

are dragging elements accurately when so far away. This setting can be adjusted by the user in 

the computers registry at Computer\HKEY_CURRENT_USER\Software\PPL\LineDesign 

2. Also, since the drag and drop feature is always on, user could accidentally invoke this feature in 

the Line Design Map when moving around. Therefore, an additional prompt was added to 

confirm that the user is sure they wish to make the change. A message will appear like the one 

below 



Osmose O-Calc® Pro 7.0 Confidential Line Design User Guide 

©2023 Osmose Utilities Services, Inc.      153 
 

 

 

Transitioning from Spacer Cable Construction to Standard Framing 
In some scenarios it is necessary to model poles where the construction type changes between standard 

construction and spacer cable construction. Spacer cable construction is used primarily in areas where 

clearance space is limited. To model the switch between standard and spacer cable construction and 

maintain connectivity in Line design, O-Calc Pro utilizes a series of terminal objects and jumper cables. 

The steps below. 
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1. Start with a line design containing a series of poles with spacer cable construction. Be sure to 

link the poles together.  

 

2. Switch the framing on half of the pole to standard framing with deadend insulators. 

 

 

3. Add a terminal object to each conductor of the spacer cable. To do this, users have several 

options. In the 3D View users can right click on the desired span and in the resulting menu 

choose App Other > Terminal. Users can perform similar steps from the Inventory Tab as well. 

Finally, users can drag and drop a terminal object from the catalog. 
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4. Next, the user can choose to trim the spacer cables away from the pole for visual clarity when 

jumpering to the deadend insulator. First, click on the terminal object in the Inventory Tab to 

view its details in the Data Entry Panel. In the Data Entry Panel, edit the Rel Offset (in) attribute. 

Then, on the span object go to the Trim to Terminal attribute and change the value from no to 

yes. 
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5. Now, the spans can be jumpered together. The best way to do so is to left click on the terminal 

and drag and drop onto the deadend insulator. 
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Appendix B – Miscellaneous Topics 

Formatting Input Data for Creating Line Design 
When using a pole data file to generate a line of poles, the pole data file must be generated in a very 

specific way. To see the required format, follow these steps: 

1. Under the File option, select New Line Design 

2. From the options, select the Import list and the Show Expected Format 

 
3. Review the pole data format requirements, as shown above 

4. Create or modify a pole data sheet in .csv format to be used for the Create Line from Data 

process 



Osmose O-Calc® Pro 7.0 Confidential Line Design User Guide 

158   ©2023 Osmose Utilites Services, Inc.  
 

5. Once the pole data sheet has been created and saved in .csv format, open a single pole file, a 

.pplx file, in O-Calc Pro 

This process is useful for creating a line of poles based on a list of pole information. For instance, 

modeling the first pole in the line and then having a spreadsheet of subsequent pole data. This would be 

faster than individually placing each pole with the line wizard, as all poles would be generated at once.  

Using the Shortcut Key Editor 
This tool gives the user a great amount of control over how the software responds to user defined 

commands. The user can use this option to make options and tasks take less time in order to work more 

efficiently. To do so follow the following steps: 

1. Navigate to Options > Shortcut Keys in the Main Line Design Menu. This will open a window with 

a list of all the Line Design Menu features.  

2. Select the feature or option that you wish to create shortcut for. It should be highlighted when 

selected. 

3. Create a unique combination of keys that will become the shortcut using the tools in the 

window. 

4. Select Apply and close the window. 

Controlling Notes in Map View 
This section outlines how note objects can be edited when they are being displayed in the map view of 

the Main Line Design Area.  

Clearing Cache Tiles 

Clear the local cache 

This clears the local display cache for the selected layer, but no other layers in the cache. Clearing the 

cache for a service affects all the layers in all of your maps that reference this service: local caches are 

stored on a service-by-service basis, and if you have multiple layers that reference a cached map service, 

they all utilize the same caches of tiles in your Windows temporary folder. 

The local cache for on your machine is always stored in a folder called MapCacheV1, and like all 

temporary data, this folder is stored under your Windows temporary folder. Inside the MapCacheV1 

folder a separate subfolder is maintained for each cached map service, and this is the last part of the 

path you see. 

Tip: Caches being used by basemap layers cannot be cleared while in use. To clear the cache, remove 

the basemap layers form the map. 

If you normally draw maps for only a few areas, such as your agency’s local study area, the cache won’t 

become really large, because the tiles you draw will likely already be in your cache. If you draw maps for 

many different areas, your cache can grow. Whenever you draw a new area, new tiles are stored in the 

local cache. 

View Information on the Layer’s Cache Size and Storage Location 

The dialog box shows the display cache size of the current layer and path of the cache location on disk. 

This helps you monitor its use. 
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Setting Conventions for Geolocation Tools 
The Geolocation tools used by O-Calc Pro control how information about a pole or related object’s 

location is entered or displayed. Setting up Geolocation preferences controls the format for how 

coordinates are entered, and what units are used for elevation. To set up Geolocation tools, follow 

these steps: 

1. Under the standard O-Calc Pro ribbon, select the Edit drop-down menu 

2. Select the Pole Coordinates option; this will open the Geolocation window 

 

3. In the above image, the conventions being used are signed degrees as the unit for latitude and 

longitude, with meters being used as the convention for elevation. These parameters can be 

changed by clicking on the Set Convention option 

4. Hover the cursor over the Lat Long Format option, and select a different convention to use 

a. Select the Degrees convention 

 
b. Select the Degs and Mins convention 

 
c. Select the Degs, Mins, Secs convention 
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5. Hover the cursor over the Elevation Format option, and select a different convention to use 

a. Select the Decimal Feet convention 

 
b. Select the Feet and Decimal Inches convention 

c. Select the Feet and Inch Fraction convention 

6. Once all selections are made, click OK  

Setting Pole Coordinates from the Map View 
When a pole is modeled from scratch, the user has the option to input the pole coordinates for that 

pole. However, this is not mandatory.  

When a pole without coordinates is open, it is possible to set coordinates for it interactively in the Map 

view of the Main Line Design area. Follow these steps to do so: 

1. Open a .pplx file that does not have coordinates set 

2. Go to the Line Design Tab’s Map view 

3. Left-click anywhere in the map view; a prompt will appear 

 

4. Select ‘Yes’ To set the pole’s coordinates to the selected location on the map 
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**Note: To reposition the pole after the coordinates have been set, set the instruction under Position 

Selected Pole 

Display Unit Options  
In previous versions of O-Calc Pro, display units could be set to either the Scientific metric 

system(meters) or the English system(feet). Both options are still available, but now a user can select a 

different format to use for how units are displayed in O-Calc Pro. To change these options, follow these 

steps: 

1. Under the main menu in O-Calc Pro, select the Options drop-down list 

2. Hover the cursor over the Units Convention option to see the available choices 

 

3. Begin by selecting either the English or Scientific units from the first dropdown list 

4. Then, use the second drop-down list to select the display format for the units; choose from the 

options: 

a. Decimal Feet 

b. Feet Decimal Inches 

c. Feet Fraction Inches 

d. Feet Whole Inches 

5. Use the Format Feet in DEP option to toggle on or off in the data entry panel 
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Jumper Cables  
The ability to model Jumper Cables in O-Calc Pro Line design is an essential component of many new 

features and concepts. Jumper cables ensure connectivity between spans that run from one pole to the 

next in Line Design. There are several ways in which Jumper cables can be generated and modified; 

those methods outlined here. For example, if the pole has a double crossarm using deadend insulators, 

the spans in the different directions are not connected until a jumper cable is attached between the two 

insulators. The two images below show the spans without and with jumper cables. There are several 

ways in which jumper cables can be generated and modified; those methods are outlined here. 

To add jumpers to the insulators manually perform one of the following procedures: 

Option A: 

To manually create a jumper cable between two insulators, within the 3D View left click and hold on one 

insulator, then drag and unclick on the second insulator. In the fly-out window, pick the option ‘Add 

Jumper’. Be sure to verify that the jumper cable is correctly drawn. The jumper can be modified in the 

data entry window.  

 

Option B: 

1. Create a pole construction like the image captioned “Deadend Insulators without Jumper Cable” 
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2. Select the insulators you wish to jumper together, then, in the data entry widow use the filters 

to see the following screen.    

 

3. In the JumperID row enter unique ID’s for each Jumper. In the Jumper Targ ID row enter the 

Jumper ID of the other Jumper. You only need to enter the target ID for one Jumper. Otherwise 

you will get duplicate jumpers. Use the next three rows to modify the properties of the jumper. 

Below is an example of how the data can be filled out.   

 

4. The example above will generate the jumper shown in the image “Deadend Insulators with 

Jumper Cable”. 

 

Deadend Insulators without Jumper Cable 

Deadend Insulators with Jumper Cable 
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The image below shows that jumper cables can be placed either above, below, or to either side of the 

insulators when they are placed automatically. 

 Jumper cables can also be drawn between an insulator and an object by using what is called a Terminal. 

The terminal is a point where the jumper cables will end. Typically, it is placed at a point near 

equipment, such as a transformer. Jumper cables can go from one insulator to another, but cannot loop 

around back to the original insulator. 

Deleting Jumper Cables is done easily by deleting the Jumper Id and Jumper Target Id in the data entry 

panel. Additionally, the user can right click on an existing jumper cable and the popup menu that 

appears will have the option to delete that jumper.  

 

Auto-Generated Jumper Cables 

O-Calc Pro Line Design will auto-generate jumper cables when needed while building a line from scratch 

with each new created pole. This option can be toggled on and off by either checking or unchecking the 

option ‘Auto-Jumper Created Poles’ found under the Options menu within the Line Design tab. When 

this option is checked, then the jumper will be created in one of four modes based on the selection in 

the drop down below the ‘Auto-Jumper Created Poles’. 

• Jumper Up – jumper cables are attached to insulators above the insulators 

• Jumper Down – jumper cables are attached to insulators below the insulators 

• Jumper Street – jumper cables are attached to side of insulators toward the 90-degree side 

• Jumper Field – jumper cables are attached to side of insulators toward the 270-degree side 

• Do Not Change – jumper cables are attached using the last used jumper orientation 

• Auto – jumper cables are attached in an orientation determined by an algorithm to create the 

shortest jumper possible 
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The Auto-Jumper Created Poles option ensures that jumper cables are place automatically when a line 

design is created using the line design wizard. The Default Jumper Placement option determines where 

the jumper will be placed when the Auto-Jumper Created Poles option is enabled. 


